Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 74304 - building kdelibs-3.3.1-r2 failed
Summary: building kdelibs-3.3.1-r2 failed
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2004-12-13 10:29 UTC by Ben Nelson
Modified: 2005-01-22 15:43 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

Preprocessed source (ccF9WgEa.out,656.60 KB, application/octet-stream)
2004-12-13 10:31 UTC, Ben Nelson

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Nelson 2004-12-13 10:29:25 UTC
In file included from kimagefilepreview.cpp:13:
/usr/qt/3/include/qcheckbox.h:49: internal compiler error: in 
   finish_member_declaration, at cp/semantics.c:1817
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:> for instructions.
In file included from ../../kdecore/kconfig.h:31,
                 from ../../kdecore/ksimpleconfig.h:25,
                 from ../../kio/kio/kservicetype.h:35,
                 from ../../kio/kio/kmimetype.h:35,
                 from ../../kio/kio/kfileitem.h:30,
                 from kpropertiesdialog.h:36,
                 from kfilesharedlg.h:23,
                 from kfilesharedlg.cpp:20:
../../kdecore/kconfigbase.h:241: internal compiler error: Segmentation fault

Reproducible: Always
Steps to Reproduce:
1. emerge -u kdelibs

Actual Results:  
See details

Expected Results:  
Comment 1 Ben Nelson 2004-12-13 10:31:36 UTC
Created attachment 45928 [details]
Preprocessed source
Comment 2 Carsten Lohrke (RETIRED) gentoo-dev 2004-12-13 11:00:40 UTC
Most likely you ran out of memory, face hardware issues (e.g. broken ram, cpu or an overheating box) or use a broken compiler.
Comment 3 Ben Nelson 2004-12-13 11:05:59 UTC
Doubt it was a memory issue with a gig of RAM and only a browser running at the time.  And the machine doesn't seem to be overheating.  Running gcc-3.3.4-r1 , builds everything else w/o issue.  Any other ideas?
Comment 4 Simone Gotti (RETIRED) gentoo-dev 2004-12-13 11:12:02 UTC
You didn't provided your "emerge info" output.

You said that with gcc 3.3.4 it's working? And with what version it gives this problem? Have you tried more then one time to look if the error is always in the same place?
Comment 5 Ben Nelson 2004-12-13 11:30:57 UTC
No, with gcc 3.3.4 everything *else* compiles just fine.  I've tried emerging the package 3 times now and it dies in the same spot every time.  Here's my emerge info output:

Portage 2.0.51-r3 (default-linux/x86/2004.0, gcc-3.3.4, glibc-, 2.6.8-gentoo-r8 i686)
System uname: 2.6.8-gentoo-r8 i686 Intel(R) Pentium(R) M processor 1700MHz
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-
Headers:  sys-kernel/linux-headers-2.4.19-r1,sys-kernel/linux-headers-2.4.21-r1
Libtools: sys-devel/libtool-1.5.2-r7
CFLAGS="-O3 -march=i686 -funroll-loops -pipe"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.1/share/config /usr/kde/3.2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=i686 -funroll-loops -pipe"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
USE="X aalib alsa apm arts avi berkdb bitmap-fonts cdr crypt cups encode esd f77 fam flac foomaticdb fortran gdbm gif gnome gpm gtk gtk2 imagemagick imlib java jpeg junit kde ldap libg++ libwww mad mikmod motif mpeg mysql ncurses nls oggvorbis opengl oss pam pdflib perl png python qt quicktime readline sdl slang speex spell ssl svga tcpd tiff truetype x86 xml xml2 xmms xv zlib"
Comment 6 Colin Tinker 2005-01-03 15:12:50 UTC
I have had this in the past if I compile any kdebase packages from within kde.  Try from the command line after a re boot and with X stopped.
Comment 7 Caleb Tennis (RETIRED) gentoo-dev 2005-01-22 15:43:29 UTC
Compiler bug that can't be fixed, unfortunately.