Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 742437 - www-apps/moodle-3.5.14 does not respect CFLAGS/LDFLAGS
Summary: www-apps/moodle-3.5.14 does not respect CFLAGS/LDFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Anthony Basile
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: qa-cflags ldflags
  Show dependency tree
 
Reported: 2020-09-14 05:58 UTC by Agostino Sarubbo
Modified: 2020-09-14 11:14 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,6.27 KB, text/plain)
2020-09-14 05:58 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-09-14 05:58:07 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: www-apps/moodle-3.5.14 does not respect CFLAGS/LDFLAGS.
Discovered on: amd64 (internal ref: ci)

NOTE:
To reproduce this issue you may want to add "-frecord-gcc-switches" to CFLAGS/CXXFLAGS/FFLAGS/FCFLAGS and LDFLAGS="${LDFLAGS} -Wl,--defsym=__gentoo_check_ldflags__=0". If this is not something about c/c++ see this bug as an hint to hide the QA warning (with QA_FLAGS_IGNORED) where is not possible to respect CFLAGS/LDFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2020-09-14 05:58:09 UTC
Created attachment 660087 [details]
build.log

build log and emerge --info
Comment 2 Anthony Basile gentoo-dev 2020-09-14 11:03:50 UTC
This is a false positive.  The package doesn't have any compiled code.  Its all just php scripts.
Comment 3 Agostino Sarubbo gentoo-dev 2020-09-14 11:14:32 UTC
the bug is intended to hide the qa notice if it is a false positive.