Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 740898 - sys-apps/portage: PORTAGE_BINHOST urlopen proxy support
Summary: sys-apps/portage: PORTAGE_BINHOST urlopen proxy support
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Binary packages support (show other bugs)
Hardware: All All
: Normal enhancement (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: 739718
  Show dependency tree
 
Reported: 2020-09-07 22:10 UTC by Zac Medico
Modified: 2020-11-22 07:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zac Medico gentoo-dev 2020-09-07 22:10:28 UTC
We've got this patch in https://github.com/gentoo/portage/pull/607 that adds proxy support to the urlopen function.
Comment 1 Larry the Git Cow gentoo-dev 2020-09-07 22:32:05 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/proj/portage.git/commit/?id=6e6d8e7f522fef3c32a7c71298024167c066a3c5

commit 6e6d8e7f522fef3c32a7c71298024167c066a3c5
Author:     Frédéric Pierret (fepitre) <frederic.pierret@qubes-os.org>
AuthorDate: 2020-08-20 09:35:23 +0000
Commit:     Zac Medico <zmedico@gentoo.org>
CommitDate: 2020-09-07 22:23:08 +0000

    Use portage proxy settings for fetching BINPKG host
    
    Bug: https://bugs.gentoo.org/740898
    See: https://github.com/gentoo/portage/pull/607
    Signed-off-by: Frédéric Pierret (fepitre) <frederic.pierret@qubes-os.org>
    Signed-off-by: Zac Medico <zmedico@gentoo.org>

 lib/portage/dbapi/bintree.py |  9 ++++++++-
 lib/portage/util/_urlopen.py | 10 +++++++---
 2 files changed, 15 insertions(+), 4 deletions(-)
Comment 2 Zac Medico gentoo-dev 2020-09-08 00:08:21 UTC

*** This bug has been marked as a duplicate of bug 339713 ***
Comment 3 Larry the Git Cow gentoo-dev 2020-09-08 03:51:41 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=fd840baeef963f5fe746f9167976ce0eed83a3b4

commit fd840baeef963f5fe746f9167976ce0eed83a3b4
Author:     Zac Medico <zmedico@gentoo.org>
AuthorDate: 2020-09-08 03:44:51 +0000
Commit:     Zac Medico <zmedico@gentoo.org>
CommitDate: 2020-09-08 03:51:23 +0000

    sys-apps/portage: Bump to version 3.0.6
    
     #668302 binrepos.conf: support fetchcommand customization
     #668334 Add binrepos.conf to replace PORTAGE_BINHOST
     #704416 env-update: create systemd user-session environment
     #737470 egencache --update-pkg-desc: emulate esync --verbose
     #737480 emerge --search: auto-detect regular expressions
     #739908 @change-deps: fix erroneous repeated rebuilds
     #740588 make.conf: Treat __* variables as local
     #740898 PORTAGE_BINHOST urlopen proxy support
     #740904 rsync and gemato proxy support
    
    Bug: https://bugs.gentoo.org/739718
    Bug: https://bugs.gentoo.org/668302
    Bug: https://bugs.gentoo.org/668334
    Bug: https://bugs.gentoo.org/704416
    Bug: https://bugs.gentoo.org/737470
    Bug: https://bugs.gentoo.org/737480
    Bug: https://bugs.gentoo.org/739908
    Bug: https://bugs.gentoo.org/740588
    Bug: https://bugs.gentoo.org/740898
    Bug: https://bugs.gentoo.org/740904
    Package-Manager: Portage-3.0.6, Repoman-3.0.1
    Signed-off-by: Zac Medico <zmedico@gentoo.org>

 sys-apps/portage/Manifest             |   1 +
 sys-apps/portage/portage-3.0.6.ebuild | 265 ++++++++++++++++++++++++++++++++++
 2 files changed, 266 insertions(+)