Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 740774 - games-strategy/0ad-0.0.23b_alpha calls ranlib directly
Summary: games-strategy/0ad-0.0.23b_alpha calls ranlib directly
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Deadline: 2020-10-09
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords: PMASKED
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-09-07 06:01 UTC by Agostino Sarubbo
Modified: 2021-02-12 20:20 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.xz (build.log.xz,75.55 KB, application/x-xz)
2020-09-07 06:01 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-09-07 06:01:38 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: games-strategy/0ad-0.0.23b_alpha calls ranlib directly.
Discovered on: amd64 (internal ref: ci)

NOTE:
As per QA policy, toolchain tools must not be called directly because they can cause issue in cross-compiling and because is not possible use a different RANLIB implementation (like llvm-ranlib). To reproduce, please use sys-devel/gcc-config[-native-symlinks], sys-devel/binutils-config[-native-symlinks] and set the RANLIB variable to x86_64-pc-linux-gnu-ranlib.
Comment 1 Agostino Sarubbo gentoo-dev 2020-09-07 06:01:41 UTC
Created attachment 658864 [details]
build.log.xz

build log and emerge --info (compressed because it exceeds attachment limit, use 'xzless' to read it)
Comment 2 Sam James archtester gentoo-dev Security 2021-02-12 20:20:14 UTC
Please retry with 0.0.24_alpha_pre20210116040036-r1.