Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 740190 - kde-plasma/plasma-nm-5.19.5: openconnect integration not working
Summary: kde-plasma/plasma-nm-5.19.5: openconnect integration not working
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-03 09:55 UTC by Erik Quaeghebeur
Modified: 2021-01-02 00:46 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build log plasma-nm (plasma-nm-5.18.5-r1:20200903-084908.log,448.21 KB, text/x-log)
2020-09-03 09:57 UTC, Erik Quaeghebeur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Quaeghebeur 2020-09-03 09:55:51 UTC
I need to connect to a VPN for which OpenConnect is needed. I want to configure and manage it using the plasma-nm applet. I have installed

  kde-plasma/plasma-nm-5.18.5-r1[openconnect]
  net-vpn/networkmanager-openconnect-1.2.6
  net-vpn/openconnect-8.09-r1[gnutls,nls]

However, no OpenConnect options appear in the list of configurable VPNs.

I installed Gnome's nm-applet

  gnome-extra/nm-applet[1.18.0]

and with that applet, I can add OpenConnect VPNs. After that, it also appears in the plasma-nm applet. However, its configuration there is unworkably limited.

I can bring up the VPN with nm-applet, but not with plasma-nm (“vpn plugin not installed”). I can bring down the VPN with both nm-applet and plasma-nm.

It seems as if the OpenConnect integration is not present in plasma-nm, despite my activation of its openconnect use flag.

Reproducible: Always
Comment 1 Erik Quaeghebeur 2020-09-03 09:57:17 UTC
Created attachment 658090 [details]
build log plasma-nm
Comment 2 Andreas Sturmlechner gentoo-dev 2020-09-03 11:49:25 UTC
It works fine for me with net-vpn/openvpn installed, but I'm by no means an expert with VPNs.
Comment 3 Erik Quaeghebeur 2020-09-03 11:59:06 UTC
(In reply to Andreas Sturmlechner from comment #2)
> It works fine for me with net-vpn/openvpn installed, […].
This is OpenConnect-specific. I have many other VPNs of different types that work perfectly with plasma-nm.
Comment 4 Andreas Sturmlechner gentoo-dev 2020-09-03 12:12:24 UTC
Please test with 5.19.5, which is going to be the upcoming stable version.
Comment 5 Erik Quaeghebeur 2020-09-03 18:57:12 UTC
(In reply to Andreas Sturmlechner from comment #4)
> Please test with 5.19.5, which is going to be the upcoming stable version.
OK, I'll wait until stabilization to test. The effort to mark and deal with unstable is not worth it, given that I have a workaround.

In the mean time, if anyone is interested, they can test whether with 5.18 (5.19) they see OpenConnect VPN as a config option when they install plasma-nm with the openconnect use flag.
Comment 6 Andreas Sturmlechner gentoo-dev 2020-09-04 09:13:03 UTC
(In reply to Erik Quaeghebeur from comment #5)
> (In reply to Andreas Sturmlechner from comment #4)
> > Please test with 5.19.5, which is going to be the upcoming stable version.
> OK, I'll wait until stabilization to test. The effort to mark and deal with
> unstable is not worth it, given that I have a workaround.

Basically, two files:
https://gitweb.gentoo.org/proj/kde.git/tree/Documentation/package.accept_keywords/kde-frameworks-5.73.keywords
https://gitweb.gentoo.org/proj/kde.git/tree/Documentation/package.accept_keywords/kde-plasma-5.19.keywords
Comment 7 Erik Quaeghebeur 2020-09-05 19:47:51 UTC
(In reply to Andreas Sturmlechner from comment #6)
> (In reply to Erik Quaeghebeur from comment #5)
> > (In reply to Andreas Sturmlechner from comment #4)
> > > Please test with 5.19.5, which is going to be the upcoming stable version.
> > OK, I'll wait until stabilization to test. The effort to mark and deal with
> > unstable is not worth it, given that I have a workaround.
> 
> Basically, two files:
> […]
I appreciate providing the files to make it easy. Even so, I'm in a job transition and cannot take an increased risk of disturbance on my daily driver laptop.
Comment 8 Erik Quaeghebeur 2020-10-08 10:20:58 UTC
I'm now on 5.19.5 and the problem still exists. From the logs:

08.10.2020 11:53:18:158	plasmashell	plasma-nm: VPN "org.freedesktop.NetworkManager.openconnect" not found, skipping

I have

kde-plasma/plasma-nm-5.19.5[openconnect]

installed and my dependencies seem to be fine:

$ equery d openconnect
* These packages depend on openconnect:
kde-plasma/plasma-nm-5.19.5 (openconnect ? net-vpn/openconnect)
net-vpn/networkmanager-openconnect-1.2.6 (>=net-vpn/openconnect-3.02)
$ equery d networkmanager-openconnect
* These packages depend on networkmanager-openconnect:
kde-plasma/plasma-nm-5.19.5 (openconnect ? net-vpn/networkmanager-openconnect)

To test this issue for yourself, I do not think you need to even try to establish an openconnect VPN. OpenConnect is not even listed in the list of VPN options for me. (I defined it using the Gnome nm-applet and then it appears also in plasma-nm, but without all tabs present and without being functional.)
Comment 9 Erik Quaeghebeur 2020-10-25 10:17:21 UTC
I would be really grateful if someone could install plasma-nm with the openconnect use flag and check on their end whether they then have an option to define an openconnect VPN or not. That way, I know whether this is a general problem, or specific to my setup.
Comment 10 Mike Gilbert gentoo-dev 2020-11-22 19:31:08 UTC
I was able to get it mostly working on my system. I was able to create a VPN connection and get most of the way through the connection process.

The connection did fail to connect in the end, but I think that may be due to a policykit failure related to dbus-broker.
Comment 11 Erik Quaeghebeur 2020-11-22 19:48:12 UTC
(In reply to Mike Gilbert from comment #10)
> I was able to get it mostly working on my system. I was able to create a VPN
> connection and get most of the way through the connection process.
Thanks very much for doing the effort of testing this.

Tour positive result means that something is wrong/different on my system. What is the best way to find out what?
Comment 12 Andreas Sturmlechner gentoo-dev 2020-12-26 13:45:03 UTC
> $ USE=openconnect emerge -1v plasma-nm
...was enough for me to get the openconnect option shown. I do not have gnome-extra/nm-applet installed.

> [ebuild   R    ] net-vpn/openconnect-8.10-r1:0/5::gentoo  USE="gnutls nls -doc -gssapi -libproxy -lz4 -smartcard -stoken -test"
> [ebuild   R    ] net-vpn/networkmanager-openconnect-1.2.6::gentoo  USE="-gtk"
> [ebuild   R    ] net-misc/networkmanager-1.26.6::gentoo  USE="bluetooth elogind introspection modemmanager ncurses nss (policykit) ppp wext wifi -audit -connection-sharing -dhclient -dhcpcd -gnutls -iwd -json -ofono -ovs -resolvconf (-selinux) -systemd -teamd -test -vala"
> [ebuild   R    ] dev-qt/qtnetwork-5.15.2:5/5.15::gentoo  USE="networkmanager ssl -bindist -connman -debug -gssapi -libproxy -libressl -sctp -test"
> [ebuild   R    ] kde-plasma/plasma-nm-5.20.4  USE="openconnect -debug -modemmanager -teamd -test"
Comment 13 Erik Quaeghebeur 2020-12-26 14:53:35 UTC
(In reply to Andreas Sturmlechner from comment #12)
> > $ USE=openconnect emerge -1v plasma-nm
> ...was enough for me to get the openconnect option shown. I do not have
> gnome-extra/nm-applet installed.
Thanks a lot for trying.

There are some difference in use flags, but nothing that seems related. There are slight differences in minor version, but given Mike's report, it seems unlikely that is the cause. What on my system is the culprit is still a mystery. However, it seems appropriate that you close this as WORKSFORME.

(I'll be installing a new system in the new year. I hope it works there as that'll give me a comparison point.)
Comment 14 Andreas Sturmlechner gentoo-dev 2021-01-02 00:46:28 UTC
I'll close it for now, do reopen if you have any new findings.