Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 74017 - kdenetwork-3.3.2 always fails compile, just hangs building kopete
Summary: kdenetwork-3.3.2 always fails compile, just hangs building kopete
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High critical (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2004-12-10 09:37 UTC by Colin Tinker
Modified: 2005-01-22 15:41 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Colin Tinker 2004-12-10 09:37:50 UTC
-DHAVE_CONFIG_H -I. -I. -I../../..  -I./ui -I./ui -I../../../kopete/libkopete -I../../../kopete/libkopete/ui -I../../../kopete/libkopete/ui -I/usr/kde/3.3/include -I/usr/qt/3/include -I/usr/X11R6/include  -DQT_THREAD_SUPPORT  -D_REENTRANT-D_FILE_OFFSET_BITS=64  -Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -DNDEBUG -DNO_DEBUG -O2 -march=athlon-xp -O3 -pipe -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION  -c -o msnswitchboardsocket.lo msnswitchboardsocket.cpp
/bin/sh ../../../libtool --silent --mode=compile --tag=CXX i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../../..  -I./ui -I./ui -I../../../kopete/libkopete -I../../../kopete/libkopete/ui -I../../../kopete/libkopete/ui -I/usr/kde/3.3/include -I/usr/qt/3/include -I/usr/X11R6/include  -DQT_THREAD_SUPPORT  -D_REENTRANT-D_FILE_OFFSET_BITS=64  -Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -DNDEBUG -DNO_DEBUG -O2 -march=athlon-xp -O3 -pipe -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION  -c -o msnfiletransfersocket.lo msnfiletransfersocket.cpp
/bin/sh ../../../libtool --silent --mode=compile --tag=CXX i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../../..  -I./ui -I./ui -I../../../kopete/libkopete -I../../../kopete/libkopete/ui -I../../../kopete/libkopete/ui -I/usr/kde/3.3/include -I/usr/qt/3/include -I/usr/X11R6/include  -DQT_THREAD_SUPPORT  -D_REENTRANT-D_FILE_OFFSET_BITS=64  -Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -DNDEBUG -DNO_DEBUG -O2 -march=athlon-xp -O3 -pipe -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION  -c -o msnp2p.lo msnp2p.cpp

It just stops at this point every time it is compiled.

Reproducible: Always
Steps to Reproduce:
1.emerge kdenetwork

Actual Results:  
fails on copile as above  

Expected Results:  
compile install kdenetwork 

emerge info 
Portage 2.0.51-r8 (default-linux/x86/2004.3, gcc-3.4.3, 
glibc-, 2.6.9-gentoo-r9 i686) 
System uname: 2.6.9-gentoo-r9 i686 AMD Athlon(tm) processor 
Gentoo Base System version 1.6.7 
Python:              dev-lang/python-2.3.4 [2.3.4 (#1, Oct 23 2004, 18:09:24)] 
ccache version 2.3 [enabled] 
dev-lang/python:     2.3.4 
sys-devel/autoconf:  2.59-r6, 2.13 
sys-devel/automake:  1.8.5-r2, 1.5, 1.4_p6, 1.9.3, 1.6.3, 1.7.9 
sys-devel/libtool:   1.5.2-r7 
CFLAGS="-march=athlon-xp -O3 -pipe" 
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/share/config /var/qmail/control" 
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d" 
CXXFLAGS="-march=athlon-xp -O3 -pipe" 
FEATURES="autoaddcvs autoconfig buildpkg ccache clean distcc distlocks 
fixpackages sandbox sfperms userpriv usersandbox" 
USE="3dnow 3dnowex X X509 aac aalib acl acpi acpi4linux aim alsa apm aredmem 
arts audiofile avantgo avi ba-completion berkdb bidi bitmap-fonts bluetooth 
bonobobootspla cddb cdparanoia cdr chroot codecs crypt css ctype cups curl dga 
dhcp dio directfb divx4linux dvb dvd dvdr dvdread eds encode esd ethereal evo 
exif ext-zlib extensions f77 faac faad fam fbcon fftw flac foomaticdb fortran 
freetype gd gdbm gif gimp gimpprint gmail gnokii gnome gphoto2 gpm gstreamer 
gtk gtk2 gtkhtml icq idea ieee1394 imagemagick imlib imlib2 innodb ipv6 irda 
irmc ithreads jabber java joystick jpeg jpeg2k junit justify kde ldap libg++ 
libwww live lm_sensors lzo lzw-tiff mad mikmod mime mmx mmx2 mng monkey motif 
mozcalendar mozp3p mozsvg mozxmlterm mpeg mpeg4 msn mysql nas ncurses network 
nls no-old-linux nocd nptl nvidia offensive oggvorbis ooo-kde opengl opie oscar 
oss pam pcap pcre pda pdflib perl pic pie png postgres prelink pthreads python 
qt quicktime readline real ruby samba scanner sdl silc skey slang smime sms 
snmp sockets sox speedo speex spell sse ssl svg svga t1lib tcltk tcpd tga 
theora threads tiff transcode truetype truetype-fonts type1-fonts usb 
userlocales uudeview v4l v4l2 vim-with-x wifi wmf x86 xanim xfs xine xml xml2 
xmms xosd xprint xscreensaver xv xvid yahoo zlib zvbi linguas_en_GB"
Comment 1 Alejandro Diaz Caro 2004-12-10 12:37:56 UTC
and during the configure, leaves this WARNING:

configure: WARNING: net/if_ppp.h: present but cannot be compiled
configure: WARNING: net/if_ppp.h:     check for missing prerequisite headers?
configure: WARNING: net/if_ppp.h: see the Autoconf documentation
configure: WARNING: net/if_ppp.h:     section "Present But Cannot Be Compiled"
configure: WARNING: net/if_ppp.h: proceeding with the preprocessor's result
configure: WARNING: net/if_ppp.h: in the future, the compiler will take precedence
configure: WARNING:     ## ------------------------------------------ ##
configure: WARNING:     ## Report this to the AC_PACKAGE_NAME lists.  ##
configure: WARNING:     ## ------------------------------------------ ##
Comment 2 Simone Gotti (RETIRED) gentoo-dev 2004-12-11 01:48:49 UTC
For how much time have you waited?
Have you tried with another gcc version or with different cflags?
Have you tried disabling ccache (FEATURES="-ccache")?
Comment 3 Colin Tinker 2004-12-11 03:33:09 UTC
I have waited 12 hours on one compile and it still sat there.

I have tried gcc 3.4.3 and gcc 3.3.4 with 3.3.4 it failed to compile just after it had configured.

I have disabled ccache and distcc it made no difference.

I have tried to compile with CFLAGS="-march=athlon-xp -O3 -pipe" , CFLAGS="-march=athlon-xp -O2", CFLAGS="-march= pentium3 -O3 -pipe" and CFLAGS="-march= pentium3 -O2"

It always hangs the compile at this point.  The rest of kde-3.3.2 has built fine as does any other app.
Comment 4 Colin Tinker 2004-12-11 06:26:43 UTC
Comiles fine with CFLAGS="-O1" but surely it should compile with CFLAGS="-march=athlon-xp -O3 -pipe", the rest of kde is fine with these flags as have been all previous releases I have compiled.
Comment 5 Simone Gotti (RETIRED) gentoo-dev 2004-12-11 06:35:06 UTC
I'm not sure and expert. Can it be gcc bug that the kopete code triggers?
Comment 6 Caleb Tennis (RETIRED) gentoo-dev 2005-01-22 15:41:05 UTC
It builds okay for me with -O3 and -march=pentium4, but it sounds very much like a gcc bug.

I'm going to close this as a CANTFIX, as I don't know what we can do for you, but if there is a bug and we can provide a fix, please reopen.