Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 739898 - dev-libs/light-1.2-r1 w/ gcc-10: multiple definition of `light_loglevel'
Summary: dev-libs/light-1.2-r1 w/ gcc-10: multiple definition of `light_loglevel'
Status: RESOLVED DUPLICATE of bug 709636
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Aaron Bauman
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2020-09-01 14:48 UTC by Petr Zima
Modified: 2020-09-02 17:47 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch fixing the problem (light-1.2-gcc-10.patch,793 bytes, patch)
2020-09-01 14:49 UTC, Petr Zima
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Zima 2020-09-01 14:48:40 UTC
Fails to compile with gcc-10 which defaults to -fno-common, cf.:

https://gcc.gnu.org/gcc-10/porting_to.html

A possible workaround for this type of bugs is CFLAGS=-fno-common. A patch with proper fix will follow.

Reproducible: Always
Comment 1 Petr Zima 2020-09-01 14:49:23 UTC
Created attachment 657758 [details, diff]
patch fixing the problem
Comment 2 Jonas Stein gentoo-dev 2020-09-02 17:43:54 UTC
was the patch reported upstream too? If yes, please add a link here.
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2020-09-02 17:47:50 UTC

*** This bug has been marked as a duplicate of bug 709636 ***