Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 739062 - net-dns/bind-9.16.6: Build fails with //usr/lib/libdb-5.3.so: error adding symbols: file in wrong format
Summary: net-dns/bind-9.16.6: Build fails with //usr/lib/libdb-5.3.so: error adding sy...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mikle Kolyada
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks: no-symlink-lib
  Show dependency tree
 
Reported: 2020-08-26 09:13 UTC by Stefan Huber
Modified: 2021-03-09 19:26 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge info (emerge-info.txt.xz,3.28 KB, application/x-xz)
2020-08-26 09:17 UTC, Stefan Huber
Details
build log (build.log.gz,32.48 KB, application/gzip)
2020-08-26 10:42 UTC, Stefan Huber
Details
LDAP library path patch for multilib Gentoo machines (0001-net-dns-bind-fix-LDAP-library-path-on-multilib-machi.patch,754 bytes, patch)
2020-09-04 20:43 UTC, Jan Ziak (atomsymbol)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Huber 2020-08-26 09:13:40 UTC
Build of by now stable bind-9.16.6 fails with linker error:
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: //usr/lib/libdb-5.3.so: error adding symbols: file in wrong format

The bug appears to be similar to bug #646380

I have tried to re-emerge sys-libs/db, which owns libdb-5.3.so, but it did not help. However, the problem rather seems to be that it should link againt /usr/lib64/libdb-5.3.so, as /usr/lib/libdb-5.3.so is an i386 binary.

Reproducible: Always
Comment 1 Stefan Huber 2020-08-26 09:17:12 UTC
Created attachment 656832 [details]
emerge info
Comment 2 Stefan Huber 2020-08-26 09:22:33 UTC
No luck in adding build.log due to Internal Server Error. When I receive response from webmaster, I will try again.
Comment 3 Stefan Huber 2020-08-26 10:42:15 UTC
Created attachment 656836 [details]
build log
Comment 4 Ionen Wolkens gentoo-dev 2020-08-26 13:39:30 UTC
Had a quick look at this.

First tried to reproduce on my ~amd64 system by installing USE=abi_x86_32 sys-libs/db:5.3 then building bind with USE="berkdb caps dlz zlib", but that went fine. My build log is filled with -L/usr/lib64 while the above one has -L/usr/lib.

So I tried some other USEs and with USE="berkdb caps dlz ldap zlib", there it is, -L/usr/lib, and wrong format. Not that I looked into why it's happening with ldap but hopefully it's a start.
Comment 5 Stefan Huber 2020-08-26 17:28:09 UTC
I can confirm that changing use flags from "dlz" to "dlz -ldap" solves the build issue for me.
Comment 6 BobbyK 2020-09-04 14:25:21 UTC
net-dns/bind-9.16.6::gentoo  USE="berkdb caps dlz ldap xml zlib"

merged without error here - though, as iamben noted, that may be because sys-libs/db has ABI_X86="64 -32 -x32" (i.e. there's no /usr/lib/libdb.so ...)
Comment 7 Jan Ziak (atomsymbol) 2020-09-04 20:43:16 UTC
Created attachment 658416 [details, diff]
LDAP library path patch for multilib Gentoo machines
Comment 8 Larry the Git Cow gentoo-dev 2020-09-18 19:23:47 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=956c96ce1bac9fcd9e792f9d64215da236d282f9

commit 956c96ce1bac9fcd9e792f9d64215da236d282f9
Author:     Jan Ziak <0xe2.0x9a.0x9b@gmail.com>
AuthorDate: 2020-09-04 20:56:02 +0000
Commit:     Patrick McLean <chutzpah@gentoo.org>
CommitDate: 2020-09-18 19:22:37 +0000

    net-dns/bind-9.16.6-r2: Revbump, USE=ldap on multilib (bug #739062)
    
    Closes: https://bugs.gentoo.org/739062
    Signed-off-by: Jan Ziak <0xe2.0x9a.0x9b@gmail.com>
    Closes: https://github.com/gentoo/gentoo/pull/17419
    Signed-off-by: Patrick McLean <chutzpah@gentoo.org>

 .../bind/{bind-9.16.6-r1.ebuild => bind-9.16.6-r2.ebuild}   |  2 ++
 .../bind/files/ldap-library-path-on-multilib-machines.patch | 13 +++++++++++++
 2 files changed, 15 insertions(+)