Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 739028 - dev-vcs/rsvndump-0.6-r1 fails to compile with lld for profile 17.1
Summary: dev-vcs/rsvndump-0.6-r1 fails to compile with lld for profile 17.1
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sebastian Pipping
URL:
Whiteboard:
Keywords:
: 730820 (view as bug list)
Depends on:
Blocks: LD-is-lld
  Show dependency tree
 
Reported: 2020-08-26 05:15 UTC by Agostino Sarubbo
Modified: 2021-01-31 19:46 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,10.48 KB, text/plain)
2020-08-26 05:15 UTC, Agostino Sarubbo
Details
1-autoconf.out (1-autoconf.out,115 bytes, text/plain)
2020-08-26 05:15 UTC, Agostino Sarubbo
Details
1-config.log (1-config.log,42.87 KB, text/plain)
2020-08-26 05:15 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-08-26 05:15:50 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: dev-vcs/rsvndump-0.6-r1 fails to compile.
Discovered on: amd64 (internal ref: tinderbox)

NOTE:
This machine uses a clang/LLVM toolchain.
If you think that this issue is strictly related to clang/LLVM please block bug 408963. If you think that this issue is strictly related to the LLD linker, please block bug 731004.
This machine uses also GLIBC-2.32. If you think that this issue is strictly related to GLIBC please block bug 736174.
Comment 1 Agostino Sarubbo gentoo-dev 2020-08-26 05:15:53 UTC
Created attachment 656762 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2020-08-26 05:15:54 UTC
Created attachment 656764 [details]
1-autoconf.out

1-autoconf.out
Comment 3 Agostino Sarubbo gentoo-dev 2020-08-26 05:15:55 UTC
Created attachment 656766 [details]
1-config.log

1-config.log
Comment 4 Sebastian Pipping gentoo-dev 2021-01-31 19:21:18 UTC
Confirming issue for build command:

  CC=clang CXX=clang++ LD=ld.lld LDFLAGS=-fuse-ld=lld ebuild rsvndump-0.6-r1.ebuild manifest clean compile
Comment 5 Larry the Git Cow gentoo-dev 2021-01-31 19:42:28 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=079a52b67179ed58b9cdfa022179e36c7ae81cb9

commit 079a52b67179ed58b9cdfa022179e36c7ae81cb9
Author:     Sebastian Pipping <sping@gentoo.org>
AuthorDate: 2021-01-31 19:41:09 +0000
Commit:     Sebastian Pipping <sping@gentoo.org>
CommitDate: 2021-01-31 19:41:58 +0000

    dev-vcs/rsvndump: Fix linking with lld for profile 17.1
    
    Closes: https://bugs.gentoo.org/739028
    Signed-off-by: Sebastian Pipping <sping@gentoo.org>
    Package-Manager: Portage-3.0.14, Repoman-3.0.2

 dev-vcs/rsvndump/rsvndump-0.6-r1.ebuild | 14 +++++++++++++-
 dev-vcs/rsvndump/rsvndump-0.6.ebuild    | 27 ---------------------------
 2 files changed, 13 insertions(+), 28 deletions(-)
Comment 6 Sebastian Pipping gentoo-dev 2021-01-31 19:46:57 UTC
*** Bug 730820 has been marked as a duplicate of this bug. ***