Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 73872 - Make Evolution (Data Server) optional
Summary: Make Evolution (Data Server) optional
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-12-09 00:02 UTC by Sebastian Bergmann (RETIRED)
Modified: 2004-12-09 01:41 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Bergmann (RETIRED) gentoo-dev 2004-12-09 00:02:58 UTC
I would like to propose the following change to the gnome.ebuild:

    eds? ( >=gnome-extra/evolution-data-server-1.0.2 )
    evo? (
        >=mail-client/evolution-2.0.2
        >=gnome-extra/evolution-webcal-2.0.1
        >=gnome-extra/gal-2.2.3
        >=gnome-extra/libgtkhtml-3.2.3 )

This would make the installation of Evolution and Evolution Data Server depend on the evo and eds USE flags respectively.

I know that there is a gnome-light ebuild but I would rather have one gnome meta ebuild that can be configured using USE flags.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Joe McCann (RETIRED) gentoo-dev 2004-12-09 00:10:05 UTC
evolution requires evolution-data-server, so there is no point to adding another use flag. If you just want eds, it is already available as a use option by the packages that make use of it.
Comment 2 Sebastian Bergmann (RETIRED) gentoo-dev 2004-12-09 00:25:19 UTC
I want to USE="-evo" to not build Evolution.
Comment 3 Joe McCann (RETIRED) gentoo-dev 2004-12-09 00:53:08 UTC
policy for the gnome metabuild is that it installs a stock gnome desktop no questions asked. The only reason it has the use flags now are because of the hardware/kernel/physical  impairment requirements that come along with those packages.  If you don't want something in this package, then you don't want to use the upstream desktop setup and shouldn't be using the gnome metabuild. This is the exact reason the gnome-light build was created. Sorry, I know that wasn't the answer you wanted to hear.
Comment 4 Sebastian Bergmann (RETIRED) gentoo-dev 2004-12-09 01:04:30 UTC
I understand that the default behaviour (ie. default USE flags) reflect the upstream/stock desktop. But what would be the harm of making it flexible?

And, no, I am not egoistic here. I just want to understand the reasoning.
Comment 5 Joe McCann (RETIRED) gentoo-dev 2004-12-09 01:24:44 UTC
You aren't losing any flexibility since the metabuild isn't a requirement. As I said before, the only purpose of the gnome metabuild is to mirror the stock upstream gnome desktop, nothing more. Extra options for extra flexibility go beyond the scope of the build. If you want, gentoo lets you be as flexible as possible. We offer the gnome-light build, or the option to not use a metabuild at all. You can even have your own gnome metabuild in a overlay with all the packages you feel make up a decent desktop. 

This conversation has already been had a bunch of times, but for what its worth there is every other gnome dev saying the same thing at bug 36027
Comment 6 Sebastian Bergmann (RETIRED) gentoo-dev 2004-12-09 01:41:12 UTC
Okay, sorry for bothering.