Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 737420 - net-analyzer/net-snmp-5.9 does not respect CFLAGS/LDFLAGS
Summary: net-analyzer/net-snmp-5.9 does not respect CFLAGS/LDFLAGS
Status: RESOLVED DUPLICATE of bug 737280
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: qa-cflags ldflags
  Show dependency tree
 
Reported: 2020-08-16 10:14 UTC by Agostino Sarubbo
Modified: 2020-08-16 10:23 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,532.08 KB, text/plain)
2020-08-16 10:15 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-08-16 10:14:59 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: net-analyzer/net-snmp-5.9 does not respect CFLAGS/LDFLAGS.
Discovered on: amd64 (internal ref: ci)

NOTE:
To reproduce this issue you may want to add "-frecord-gcc-switches" to CFLAGS/CXXFLAGS/FFLAGS/FCFLAGS and LDFLAGS="${LDFLAGS} -Wl,--defsym=__gentoo_check_ldflags__=0". If this is not something about c/c++ see this bug as an hint to hide the QA warning (with QA_FLAGS_IGNORED) where is not possible to respect CFLAGS/LDFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2020-08-16 10:15:02 UTC
Created attachment 654932 [details]
build.log

build log and emerge --info
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2020-08-16 10:23:50 UTC

*** This bug has been marked as a duplicate of bug 737280 ***