Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 737388 - media-gfx/blender: needs 3.8 port (was: 3.7)
Summary: media-gfx/blender: needs 3.8 port (was: 3.7)
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Adrian
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: python3.8-compat
  Show dependency tree
 
Reported: 2020-08-16 09:49 UTC by Michał Górny
Modified: 2020-09-05 06:07 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2020-08-16 09:49:20 UTC
The packages are stuck on py3.6 which means they will be pain once we switch to 3.7.  Please test them on 3.7 *and* 3.8 (so we don't to revisit this in a few months), and update PYTHON_COMPAT appropriately.  If it doesn't work, please either fix it, remove Python or issue last rites.  Please consider this urgent.
Comment 1 Larry the Git Cow gentoo-dev 2020-08-24 13:42:25 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=cca9b716491a91b496106a19df4e5f554b6a1717

commit cca9b716491a91b496106a19df4e5f554b6a1717
Author:     Adrian Grigo <agrigo2001@yahoo.com.au>
AuthorDate: 2020-08-22 01:08:55 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2020-08-24 13:41:55 +0000

    media-gfx/blender: Version bump to 2.83.4
    
    Blender 2.83.4 works with python 3.7. It may compile with 3.8, but
    blender only supports 3.7 officially as it follows the VFX Reference
    Platform to ensure that user add ons are not broken in the process.
    They plan to introduce 3.8 support in 2021.
    
    New features include a new interface, the realtime eevee renderer,
    and importing openvdb files created by other packages among others.
    Game engine and Blender Player were removed in 2.80.
    
    Bug fixes in this version are alembic support, upstream fixes for
    opencollada, requiring openjpeg:2 to avoid security issues, and
    mimeinfo cache is correctly updated. Where these issues remain in
    blender 2.79b, the bug is linked but should be closed only when
    blender 2.79b is removed.
    
    On my system the docs do not currently compile,
    and the polyfill2d test still fails like 2.79b.
    
    Blender 2.83 support for draco, embree, oidn, usd and openxr is not yet
    implemented pending development of ebuilds for these packages.
    
    Signed-off-by: Adrian Grigo <agrigo2001@yahoo.com.au>
    Bug: https://bugs.gentoo.org/667352
    Bug: https://bugs.gentoo.org/735590
    Bug: https://bugs.gentoo.org/718772
    Closes: https://bugs.gentoo.org/737388
    Closes: https://bugs.gentoo.org/689740
    Package-Manager: Portage-2.3.103, Repoman-2.3.23
    Signed-off-by: Sam James <sam@gentoo.org>

 media-gfx/blender/Manifest                         |   1 +
 media-gfx/blender/blender-2.83.4.ebuild            | 316 +++++++++++++++++++++
 .../blender/files/blender-fix-install-rules.patch  |  16 --
 media-gfx/blender/metadata.xml                     |  22 ++
 4 files changed, 339 insertions(+), 16 deletions(-)
Comment 2 Sam James archtester gentoo-dev Security 2020-08-24 13:55:43 UTC
Python 3.8 for this is a bit complicated but I'm going to be keeping an eye on it.