Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 73732 - Gnucash fails to get quotes, says update-finance-quotes needs run. It is up-to-date,...
Summary: Gnucash fails to get quotes, says update-finance-quotes needs run. It is up-t...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Seemant Kulleen (RETIRED)
Depends on:
Reported: 2004-12-07 16:17 UTC by Decibels
Modified: 2004-12-26 09:07 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Decibels 2004-12-07 16:17:29 UTC
Gnucash-1.8.9 version.

Until emerged the latest libperl-5.8.5 and perl-5.8.5-r2 Gnucash worked fine. You select Tools/Price Editor/Get Quotes button and would update quotes on stocks. Now comes up with pop-up saying "You are missing some needed Perl Libraries. Run 'update-finance-quote' as root to install them."
Run 'update-finance-quote' and all goes well it seems. But Gnucash still won't get quotes. 

Infact it locks up right after selecting the Price Editor and the pop-up message telling you to run 'update-finance-quote'. You have to kill the Price Editor window. That happened twice, doesn't seem to lock up now, just doesn't get the quotes and still says need to run update-finance-quote. Seems this issue pop's up every so often over the years been using Gnucash. The only issue ever had over the time is with update-finance-quote and missing perl libs.

Ran update-finance-quote again and says up to date:
Installing /usr/bin/lwp-download
Writing /usr/lib/perl5/site_perl/5.8.5/i686-linux/auto/libwww-perl/.packlist
Appending installation info to /usr/lib/perl5/5.8.5/i686-linux/perllocal.pod
  /usr/bin/make install  -- OK
Date::Manip is up to date.
HTML::Parser is up to date.
Finance::Quote is up to date.
Have also logged out and back in and rebooted and still nogo. Nothing comes up about it if run from terminal either.

Checking on some of the previous problems over the years with this had checked these:
libwww-perl-5.79  installed
DEPS: (meet these according to ebuild)

Couple other packages Gnucash needs:
DateManip-5.42a-r1 installed.
Remerged that and now instead of getting the popup saying need to run update-finance-quote, get popup saying "There was a system error while retrieving the price quotes".
Finance-Quote-1.08 installed.
Remerge that and still getting the 'system error' message now.
Remerging libwww-perl didn't help either. Still get the 'system error' message.

Check an account to see if prefs changed. Found 'Price Quote Source' Grayed out. Still check and with options, but disabled. Result or Source of problem not sure. There were some other problems with the gui look in there also, like the combobox arrows. 

Running /usr/portage/dev-lang/perl/files/libperl_rebuilder right now. Going to see where that takes this problem. Looks like going to take awhile so will report back when done.

My CFLAGS: CFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"

Reproducible: Always
Steps to Reproduce:
1. Start gnucash
2. Select Tools/Price/Get Quotes button
3. First got error about running update-finance-quote, now get system error.

Actual Results:  
Doesn't get quotes. Complains of missing perl libs or system error.

Expected Results:  
Get quotes to update prices in Gnucash.
Comment 1 Decibels 2004-12-07 19:03:08 UTC
/usr/portage/dev-lang/perl/files/libperl_rebuilder took quite awhile, but after done ran Gnucash and getting quotes is working again. 
Comment 2 Decibels 2004-12-07 19:31:16 UTC
Also, just for info on why this might have happened. I was upgrading from
libperl-5.8.4-r1 to libperl-5.8.5
and perl-5.8.5-r2 to perl-5.8.4-r1
Comment 3 Decibels 2004-12-07 19:32:43 UTC
Oops, got the perl backwards, should read:

Also, just for info on why this might have happened. I was upgrading from
libperl-5.8.4-r1 to libperl-5.8.5
and perl-5.8.4-r1 to perl-5.8.5-r2
Comment 4 Seemant Kulleen (RETIRED) gentoo-dev 2004-12-26 09:07:27 UTC
this issue happens whenever you upgrade perl.  Please make sure to check which packages have installed anything in /usr/lib/perl5/${old_version} and remerge every single one of those perl modules.  Essentially, every time you do a perl upgrade, remerge every single perl module would be good practise. libperl_rebuilder should do this automatically for you, though it doesn't hurt to double check its work.