Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 737 - unexpected EOF while looking for matching `''
Summary: unexpected EOF while looking for matching `''
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Martin Schlemmer (RETIRED)
: 472 (view as bug list)
Depends on:
Reported: 2002-02-17 14:56 UTC by mikepolniak
Modified: 2003-02-04 19:42 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description mikepolniak 2002-02-17 14:56:47 UTC
whenever i run rc-update i get this error :
 * Caching service dependencies...
/etc/init.d/ command substitution: line 1: unexpected EOF while looking for 
matching `''
/etc/init.d/ command substitution: line 2: syntax error: unexpected end of file      
                                                          [ ok ]
 * rc-update complete.

Looking in my init scripts (baselayout-1.7.1)   i did add a missing ' after the } in this line:

/etc/init.d/xdm: case "`echo $DISPLAYMANAGER | awk '{ print toupper($1) }'`" in

but i still get the same error message.
Comment 1 Daniel Robbins (RETIRED) gentoo-dev 2002-02-19 23:44:38 UTC
This is caused by some some syntax error in one of your scripts.  I'm forwarding
this to azarah to see if he can add some kind of generic functionality to track
down these problems easily rather than guessing.
Comment 2 Martin Schlemmer (RETIRED) gentoo-dev 2002-02-24 11:39:18 UTC
*** Bug 472 has been marked as a duplicate of this bug. ***
Comment 3 Martin Schlemmer (RETIRED) gentoo-dev 2002-03-03 14:06:47 UTC
Id like to say this will be resolved in the latest baselayout which should be
out in a few hours.