Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 735666 - dev-ruby/nokogumbo-2.0.2 : [BUG]<snip> Segmentation fault at <snip>
Summary: dev-ruby/nokogumbo-2.0.2 : [BUG]<snip> Segmentation fault at <snip>
Status: RESOLVED DUPLICATE of bug 737024
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-03 08:44 UTC by Toralf Förster
Modified: 2020-08-15 09:20 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.05 KB, text/plain)
2020-08-03 08:44 UTC, Toralf Förster
Details
dev-ruby:nokogumbo-2.0.2:20200803-084305.log (dev-ruby:nokogumbo-2.0.2:20200803-084305.log,21.28 KB, text/plain)
2020-08-03 08:44 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,88.16 KB, text/plain)
2020-08-03 08:44 UTC, Toralf Förster
Details
environment (environment,78.39 KB, text/plain)
2020-08-03 08:44 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,15.37 KB, application/x-bzip)
2020-08-03 08:44 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,1.59 KB, application/x-bzip)
2020-08-03 08:44 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-08-03 08:44:22 UTC
checking for nokogiri.h in /usr/lib64/ruby/gems/2.5.0/gems/nokogiri-1.10.4/ext/nokogiri... yes
creating Makefile
[BUG] Segmentation fault at 0x0000000000000498
ruby 2.5.8p224 (2020-03-31 revision 67882) [x86_64-linux]

-- Machine register context ------------------------------------------------

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1-libressl-20200801-144300

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-10.2.0 *
clang version 10.0.1 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/10/bin
/usr/lib/llvm/10
10.0.1
Available Python interpreters, in order of preference:
  [1]   python3.7
  [2]   python3.9 (fallback)
  [3]   python3.8 (fallback)
  [4]   python3.6 (fallback)
  [5]   python2.7 (fallback)
  [6]   pypy3 (fallback)
Available Ruby profiles:
  [1]   ruby25 (with Rubygems) *
The Glorious Glasgow Haskell Compilation System, version 8.8.4

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Mon Aug  3 08:05:27 AM UTC 2020
/var/db/repos/libressl	Fri Jul 24 09:42:51 PM UTC 2020

emerge -qpvO dev-ruby/nokogumbo
[ebuild  N    ] dev-ruby/nokogumbo-2.0.2  USE="-doc -test" RUBY_TARGETS="ruby25 (-ruby24) -ruby26 -ruby27"
Comment 1 Toralf Förster gentoo-dev 2020-08-03 08:44:25 UTC
Created attachment 652570 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-08-03 08:44:28 UTC
Created attachment 652572 [details]
dev-ruby:nokogumbo-2.0.2:20200803-084305.log
Comment 3 Toralf Förster gentoo-dev 2020-08-03 08:44:31 UTC
Created attachment 652574 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2020-08-03 08:44:35 UTC
Created attachment 652576 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2020-08-03 08:44:38 UTC
Created attachment 652578 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-08-03 08:44:40 UTC
Created attachment 652580 [details]
logs.tbz2
Comment 7 Hans de Graaff gentoo-dev 2020-08-15 09:20:12 UTC

*** This bug has been marked as a duplicate of bug 737024 ***