Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 734356 - dev-qt/qtwebengine-5.15.0 with sys-devel/bison-3.7 : /.../xpath_grammar.cc: fatal error: xpath_grammar.hh: No such file or directory
Summary: dev-qt/qtwebengine-5.15.0 with sys-devel/bison-3.7 : /.../xpath_grammar.cc: f...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Qt Bug Alias
URL: https://bugreports.qt.io/browse/QTBUG...
Whiteboard:
Keywords: PullRequest, UPSTREAM
: 738314 (view as bug list)
Depends on:
Blocks: bison-3.7 734600
  Show dependency tree
 
Reported: 2020-07-29 07:59 UTC by Toralf Förster
Modified: 2020-09-05 22:15 UTC (History)
16 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.93 KB, text/plain)
2020-07-29 07:59 UTC, Toralf Förster
Details
dev-qt:qtwebengine-5.15.0:20200728-171810.log.bz2 (dev-qt:qtwebengine-5.15.0:20200728-171810.log.bz2,192.28 KB, application/x-bzip)
2020-07-29 07:59 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,90.25 KB, text/plain)
2020-07-29 07:59 UTC, Toralf Förster
Details
environment (environment,132.21 KB, text/plain)
2020-07-29 07:59 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,12.00 KB, application/x-bzip)
2020-07-29 07:59 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,77.23 KB, application/x-bzip)
2020-07-29 07:59 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,223.14 KB, application/x-bzip)
2020-07-29 07:59 UTC, Toralf Förster
Details
don't delete the include file during the build (bison-3.7 problem) (qtwebengine-chromium-80-based-bison-3.7-build.patch,568 bytes, patch)
2020-08-01 13:12 UTC, milan hodoscek
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-07-29 07:59:10 UTC
In file included from gen/third_party/blink/renderer/core/core_generated_jumbo_11.cc:9:
/var/tmp/portage/dev-qt/qtwebengine-5.15.0/work/qtwebengine-everywhere-src-5.15.0_build/src/core/release/gen/third_party/blink/renderer/core/xpath_grammar.cc:124:10: fatal error: xpath_grammar.hh: No such file or directory
  124 | #include "xpath_grammar.hh"
      |          ^~~~~~~~~~~~~~~~~~
compilation terminated.

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop_plasma-libressl-20200726-131939

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-8.3.1
 [2] x86_64-pc-linux-gnu-10.2.0 *
/usr/lib/llvm/10
10.0.1
Available Python interpreters, in order of preference:
  [1]   python3.7
  [2]   python3.9 (fallback)
  [3]   python3.8 (fallback)
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby25 (with Rubygems) *
The following VMs are available for generation-2:
*)	IcedTea JDK 3.16.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.0.2

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Tue Jul 28 04:05:31 PM UTC 2020
/var/db/repos/libressl	Fri Jul 24 09:42:51 PM UTC 2020

emerge -qpvO dev-qt/qtwebengine
[ebuild  N    ] dev-qt/qtwebengine-5.15.0  USE="alsa jumbo-build system-ffmpeg system-icu widgets -bindist -debug -designer -geolocation -kerberos -pulseaudio -test"
Comment 1 Toralf Förster gentoo-dev 2020-07-29 07:59:13 UTC
Created attachment 651380 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-07-29 07:59:15 UTC
Created attachment 651382 [details]
dev-qt:qtwebengine-5.15.0:20200728-171810.log.bz2
Comment 3 Toralf Förster gentoo-dev 2020-07-29 07:59:18 UTC
Created attachment 651384 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2020-07-29 07:59:21 UTC
Created attachment 651386 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2020-07-29 07:59:24 UTC
Created attachment 651388 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-07-29 07:59:27 UTC
Created attachment 651390 [details]
logs.tbz2
Comment 7 Toralf Förster gentoo-dev 2020-07-29 07:59:30 UTC
Created attachment 651392 [details]
temp.tbz2
Comment 8 Ultratux 2020-07-29 18:26:02 UTC
I have the same issue here.

Timestamp of repository gentoo: Wed, 29 Jul 2020 13:30:01 +0000
ACCEPT_KEYWORDS="amd64 ~amd64"
Comment 9 YOSHIOKA Takuma 2020-07-31 17:09:07 UTC
It seems that the qtwebengine compiles successfully with =sys-devel/bison-3.6.4, and fails with =sys-devel/bison-3.7.

As a temporary workaround, you can `emerge -1v =sys-devel/bison-3.6.4` and then emerge qtwebengine-5.15.0.
Comment 10 Chiitoo gentoo-dev 2020-08-01 03:12:17 UTC
(In reply to YOSHIOKA Takuma from comment #9)
> It seems that the qtwebengine compiles successfully with
> =sys-devel/bison-3.6.4, and fails with =sys-devel/bison-3.7.

Thanks!

Indeed, it seems it's due to the change in how header files are included [1][2].  Before the contents would be copied and inserted into a file, but now the files can be included directly (by default as '"header-basename"'), which means the file that used to get the contents of the 'xpath_grammar.hh', now only gets an '#include "xpath_grammar.hh"', but this file is removed during the build, and... well we all know the rest.

I filed a Qt bug, with my probably less than proper patch to work around this.

1. https://lists.gnu.org/archive/html/info-gnu/2020-07/msg00006.html
2. https://www.gnu.org/software/bison/manual/html_node/_0025define-Summary.html
Comment 11 milan hodoscek 2020-08-01 13:12:38 UTC
Created attachment 652054 [details, diff]
don't delete the include file during the build (bison-3.7 problem)
Comment 12 milan hodoscek 2020-08-01 13:15:00 UTC
the patch from comment 10 worked for me, so I attached it in the form that it can be applied automatically from /etc/portage/patches/dev-qt/qtwebengine-5.15.0
Comment 13 jason 2020-08-10 23:58:18 UTC
I ran into the same problem. qtwebengine failed to build with bison-3.7.1. Downgrading bison to 3.6.4 fixed the problem.
Comment 14 Omer Fadil Usta 2020-08-18 21:18:18 UTC
https://codereview.qt-project.org/c/qt/qtwebengine/+/310620
merged to 5.15 branch of qt
Comment 15 Omer Fadil Usta 2020-08-18 23:59:51 UTC
nope , it looks like that commit doesnt fixes the problem
Comment 16 Larry the Git Cow gentoo-dev 2020-08-19 19:39:56 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=43bc7ef7394255dc27b58a6b5e0dab005a8ea89b

commit 43bc7ef7394255dc27b58a6b5e0dab005a8ea89b
Author:     Jimi Huotari <chiitoo@gentoo.org>
AuthorDate: 2020-08-19 12:59:19 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2020-08-19 19:39:43 +0000

    dev-qt/qtwebengine: fix build with >=bison-3.7
    
    Backport commit from Qt upstream [1].
    
    1. https://code.qt.io/cgit/qt/qtwebengine-chromium.git/commit/?h=80-based&id=1a53f599
    
    Reported-by: Toralf Förster <toralf@gentoo.org>
    Thanks-to: YOSHIOKA Takuma <lo73741824@hard-wi.red>
    Closes: https://bugs.gentoo.org/734356
    Package-Manager: Portage-3.0.3, Repoman-3.0.0
    Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
    Closes: https://github.com/gentoo/gentoo/pull/17171
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 .../files/qtwebengine-5.15.0-bison-3.7-build.patch | 54 ++++++++++++++++++++++
 dev-qt/qtwebengine/qtwebengine-5.15.0.ebuild       |  1 +
 2 files changed, 55 insertions(+)
Comment 17 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2020-08-21 06:29:56 UTC
*** Bug 738314 has been marked as a duplicate of this bug. ***
Comment 18 burunduk3 2020-09-05 10:53:11 UTC
I have the similar issue with dev-qt/qtwebengine-5.14.2. Of course, I'll try workaround with sys-devel/bison-3.6.4, but looks like that stable branch is now broken, since only dev-qt/qtwebengine-5.15.0 is fixed and it's in ~.