Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 734320 - =dev-java/openjdk-8.262_p10: filesize/checksum mismatch
Summary: =dev-java/openjdk-8.262_p10: filesize/checksum mismatch
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Georgy Yakovlev
URL: https://hg.openjdk.java.net/jdk8u/jdk...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-28 19:58 UTC by Hypoon
Modified: 2020-08-04 23:38 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hypoon 2020-07-28 19:58:49 UTC
The ebuild fetches this archive:
https://hg.openjdk.java.net/jdk8u/jdk8u/archive/jdk8u262-ga.tar.bz2
as this file:
openjdk-jdk-8.262_p10.tar.bz2
but the filesize check fails. The checksums do not match the manifest either.

Additionally, I checked jdk8u262-b10.tar.bz2 from the website. That has a different checksum and also doesn't match, despite corresponding to the same changeset.

From the manifest:
DIST openjdk-8.262_p10.tar.bz2 455868 BLAKE2B 22637a8ecd2af97b8cdc335fff5d4a14c56f53a26f0fe1ccb61f7f6542961126f4a2dadfc596ae561ea27cfdbc5f23fb10350d1533f43f1740540367565cb160 SHA512 196e201cbbd53132a78f276df7407346ba611798d813272c68cd3d654f34b84874009cda1df62e51fd5e33c5bc4aa4bdda6bd0ef7cac9857c609fcdb3fa3fd53

and here's what I observe from the "-ga" file I downloaded:
filesize: 455742
sha512sum: da48f48e48ff75715bc7a39bb5b9c5228ea67461ef23e53b50e5a5f0dedfd8c731185276c6f3d0310a9ba97a47b3cbef45ab67ed7679ac2ea48e65d85ff7a97f

Reproducible: Always
Comment 1 Hypoon 2020-07-30 00:04:05 UTC
It looks like the distfiles acquired from a gentoo mirror do match the manifest.

I'm guessing that the files on hg.openjdk.java.net have been updated, but I haven't any idea why.
Comment 2 Georgy Yakovlev gentoo-dev 2020-07-30 05:01:09 UTC
I’m not sure if hg tarballs are stable.
Try comparing 2. Downloaded from mirrors and downloaded upstream. diff -u will work on unpacked directories.
I’ll compare a bit later out of curiosity.
Comment 3 Georgy Yakovlev gentoo-dev 2020-07-30 09:57:31 UTC
there's no real file difference, looks like while generating new release something went wrong and new nag was added to old -ga changeset.

Not a big deal, because bump to 8.265 (ga) happens tomorrow.

> diff -r -u gentoo-tarball hg
> diff -r -u gentoo-tarball/.hg_archival.txt hg/.hg_archival.txt
> --- gentoo-tarball/.hg_archival.txt     2020-06-27 15:21:42.000000000 -0700
> +++ hg/.hg_archival.txt 2020-06-27 15:21:42.000000000 -0700
> @@ -3,3 +3,4 @@
>  branch: default
>  tag: jdk8u262-b10
>  tag: jdk8u262-ga
> +tag: jdk8u265-b00
Comment 4 Hypoon 2020-08-03 17:34:26 UTC
Is 8.265 being stabilized soon, or must I switch to ~amd64?
Comment 5 Georgy Yakovlev gentoo-dev 2020-08-03 21:20:23 UTC
in progress.
https://bugs.gentoo.org/732624

you can already add keywords just for that new version.
Comment 6 Hypoon 2020-08-04 21:48:38 UTC
Yes, I knew I could keyword just the one package version, but I was a little confused by the idea of leaving a broken ebuild in portage. With 265 stabilized, I assume 262 will be dropped soon, which is why it's not worth fixing, is that correct?

Thank you for preparing and stabilizing 265!
Comment 7 Larry the Git Cow gentoo-dev 2020-08-04 21:58:48 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b2e262024d4c564b29a7da88732e2c422234549e

commit b2e262024d4c564b29a7da88732e2c422234549e
Author:     Georgy Yakovlev <gyakovlev@gentoo.org>
AuthorDate: 2020-08-04 21:44:55 +0000
Commit:     Georgy Yakovlev <gyakovlev@gentoo.org>
CommitDate: 2020-08-04 21:58:23 +0000

    dev-java/openjdk: drop old
    
    Bug: https://bugs.gentoo.org/732624
    Closes: https://bugs.gentoo.org/734320
    Closes: https://bugs.gentoo.org/706012
    Closes: https://bugs.gentoo.org/713180
    Closes: https://bugs.gentoo.org/706638
    Package-Manager: Portage-3.0.1, Repoman-2.3.23
    Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>

 dev-java/openjdk/Manifest                          |  17 --
 .../openjdk/files/openjdk-11.0.7_p10-sigsegv.patch |  55 ----
 .../openjdk/files/openjdk-8-detect-gcc10.patch     |  49 ----
 dev-java/openjdk/openjdk-11.0.7_p10.ebuild         | 280 ---------------------
 dev-java/openjdk/openjdk-8.252_p09.ebuild          | 231 -----------------
 dev-java/openjdk/openjdk-8.262_p10.ebuild          | 226 -----------------
 6 files changed, 858 deletions(-)
Comment 8 Georgy Yakovlev gentoo-dev 2020-08-04 22:25:09 UTC
yeah, did not want to keep it, and tarballs are still accessible via mirrors, so it was not completely broken.

fetching tarballs from HG is highly not recommended.
is there a reason you used direct fetch instead of mirrors?
Comment 9 Hypoon 2020-08-04 22:33:31 UTC
Oh, I didn't realize I was unusual in not using the Gentoo mirrors. I think I was frustrated by unreliability and slow download speeds from the mirrors I had originally chosen.

If using the Gentoo mirrors is so strongly encouraged, I'll turn them back on now.

Thanks again!
Comment 10 Georgy Yakovlev gentoo-dev 2020-08-04 23:38:03 UTC
depends on region. for me mirrors actually help. especially with openjdk.

app-portage/mirrorselect can be a bit useful

but I'd just manually select 1-2 mirrors from that list and test manually with wget to see if speed works for you.

https://www.gentoo.org/downloads/mirrors/