Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 733894 - net-analyzer/openvas-scanner-7.0.1 should depend on net-analyzer/net-snmp:=
Summary: net-analyzer/openvas-scanner-7.0.1 should depend on net-analyzer/net-snmp:=
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: jonas.licht
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-25 15:46 UTC by Daniel M. Weeks
Modified: 2021-02-06 21:35 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel M. Weeks 2020-07-25 15:46:52 UTC
>>> package: net-analyzer/net-snmp-5.8.1_rc1
 *  - /usr/lib64/libnetsnmp.so.35
 *  - /usr/lib64/libnetsnmp.so.35.0.1
 *      used by /usr/lib64/libopenvas_nasl.so.11.0.1~git (net-analyzer/openvas-scanner-7.0.1)
 *      used by /usr/lib64/libopenvas_nasl.so.11.0.1~git (net-analyzer/openvas-scanner-7.0.1)

Reproducible: Always
Comment 1 jonas.licht 2020-07-30 12:21:58 UTC
net-snmp is not a required dependency.
I could add a useflag, which simply inherit the dependency.
Comment 2 Sam James archtester gentoo-dev Security 2021-02-06 21:35:07 UTC
(In reply to jonas.licht from comment #1)
> net-snmp is not a required dependency.
> I could add a useflag, which simply inherit the dependency.

If it links against the library, it needs to be a dependency (optional or not, up to you, depending on upstream constraints).