Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 733296 - www-client/chromium[ozone,wayland] crashes with invalid ozone platform: tty
Summary: www-client/chromium[ozone,wayland] crashes with invalid ozone platform: tty
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Chromium Project
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks:
 
Reported: 2020-07-20 08:38 UTC by Alex Buell
Modified: 2020-07-30 09:47 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Buell 2020-07-20 08:38:14 UTC
Chromium crashes every time I attempt to run the binary. After running it from a gnome terminal, I discovered the following: 

alex@titanium ~ $ chromium 
[6106:6106:0720/093052.868247:FATAL:platform_selection.cc(45)] Invalid ozone platform: tty
#0 0x55a4ee581629 (/usr/lib64/chromium-browser/chrome+0x557f628)
#1 0x55a4ee4c12a6 (/usr/lib64/chromium-browser/chrome+0x54bf2a5)
#2 0x55a4ee4d3a2c (/usr/lib64/chromium-browser/chrome+0x54d1a2b)
#3 0x55a4eabc1b69 (/usr/lib64/chromium-browser/chrome+0x1bbfb68)
#4 0x55a4eabc2c62 (/usr/lib64/chromium-browser/chrome+0x1bc0c61)
#5 0x55a4eabc2a2c (/usr/lib64/chromium-browser/chrome+0x1bc0a2b)
#6 0x55a4eabc2b8e (/usr/lib64/chromium-browser/chrome+0x1bc0b8d)
#7 0x55a4ef8cc2e9 (/usr/lib64/chromium-browser/chrome+0x68ca2e8)
#8 0x55a4ef8cc3a3 (/usr/lib64/chromium-browser/chrome+0x68ca3a2)
#9 0x55a4eb817723 (/usr/lib64/chromium-browser/chrome+0x2815722)
#10 0x55a4eb81974b (/usr/lib64/chromium-browser/chrome+0x281774a)
#11 0x55a4eb814787 (/usr/lib64/chromium-browser/chrome+0x2812786)
#12 0x55a4edd46a95 (/usr/lib64/chromium-browser/chrome+0x4d44a94)
#13 0x55a4edd46b6c (/usr/lib64/chromium-browser/chrome+0x4d44b6b)
#14 0x55a4edd481c6 (/usr/lib64/chromium-browser/chrome+0x4d461c5)
#15 0x55a4edf8e472 (/usr/lib64/chromium-browser/chrome+0x4f8c471)
#16 0x55a4edd46546 (/usr/lib64/chromium-browser/chrome+0x4d44545)
#17 0x55a4e9ff1cd5 ChromeMain
#18 0x7fd09edbbe2b __libc_start_main
#19 0x55a4e9ff1afa _start

Received signal 6
#0 0x55a4ee581629 (/usr/lib64/chromium-browser/chrome+0x557f628)
#1 0x55a4ee4c12a6 (/usr/lib64/chromium-browser/chrome+0x54bf2a5)
#2 0x55a4ee580fcb (/usr/lib64/chromium-browser/chrome+0x557efca)
#3 0x55a4ee5815be (/usr/lib64/chromium-browser/chrome+0x557f5bd)
#4 0x7fd0a2b1d5b0 (/lib64/libpthread-2.30.so+0x135af)
#5 0x7fd09edd0ac1 gsignal
#6 0x7fd09edba55b abort
#7 0x55a4ee580b75 (/usr/lib64/chromium-browser/chrome+0x557eb74)
#8 0x55a4ee4d3ea5 (/usr/lib64/chromium-browser/chrome+0x54d1ea4)
#9 0x55a4eabc1b69 (/usr/lib64/chromium-browser/chrome+0x1bbfb68)
#10 0x55a4eabc2c62 (/usr/lib64/chromium-browser/chrome+0x1bc0c61)
#11 0x55a4eabc2a2c (/usr/lib64/chromium-browser/chrome+0x1bc0a2b)
#12 0x55a4eabc2b8e (/usr/lib64/chromium-browser/chrome+0x1bc0b8d)
#13 0x55a4ef8cc2e9 (/usr/lib64/chromium-browser/chrome+0x68ca2e8)
#14 0x55a4ef8cc3a3 (/usr/lib64/chromium-browser/chrome+0x68ca3a2)
#15 0x55a4eb817723 (/usr/lib64/chromium-browser/chrome+0x2815722)
#16 0x55a4eb81974b (/usr/lib64/chromium-browser/chrome+0x281774a)
#17 0x55a4eb814787 (/usr/lib64/chromium-browser/chrome+0x2812786)
#18 0x55a4edd46a95 (/usr/lib64/chromium-browser/chrome+0x4d44a94)
#19 0x55a4edd46b6c (/usr/lib64/chromium-browser/chrome+0x4d44b6b)
#20 0x55a4edd481c6 (/usr/lib64/chromium-browser/chrome+0x4d461c5)
#21 0x55a4edf8e472 (/usr/lib64/chromium-browser/chrome+0x4f8c471)
#22 0x55a4edd46546 (/usr/lib64/chromium-browser/chrome+0x4d44545)
#23 0x55a4e9ff1cd5 ChromeMain
#24 0x7fd09edbbe2b __libc_start_main
#25 0x55a4e9ff1afa _start
  r8: 0000000000000000  r9: 00007ffe9a1af5e0 r10: 0000000000000008 r11: 0000000000000246
 r12: 00007ffe9a1b0840 r13: 00007ffe9a1b0850 r14: 00007ffe9a1b0860 r15: 00007ffe9a1b0ce0
  di: 0000000000000002  si: 00007ffe9a1af5e0  bp: 00007ffe9a1af830  bx: 00007fd09ad6ea40
  dx: 0000000000000000  ax: 0000000000000000  cx: 00007fd09edd0ac1  sp: 00007ffe9a1af5e0
  ip: 00007fd09edd0ac1 efl: 0000000000000246 cgf: 002b000000000033 erf: 0000000000000000
 trp: 0000000000000000 msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]
Calling _exit(1). Core file will not be generated.


Reproducible: Always



Expected Results:  
Chromium should appear on the Gnome desktop

Portage 2.3.103 (python 3.7.8-final-0, default/linux/amd64/17.1/desktop/gnome, gcc-9.3.0, glibc-2.30-r8, 5.7.0-gentoo x86_64)
=================================================================
System uname: Linux-5.7.0-gentoo-x86_64-AMD_Ryzen_Threadripper_1920X_12-Core_Processor-with-gentoo-2.6
KiB Mem:    65947712 total,  30894992 free
KiB Swap:    2094076 total,   2094076 free
Timestamp of repository gentoo: Mon, 20 Jul 2020 08:00:01 +0000
Head commit of repository gentoo: 642f1bc0dad7b7cc060be1f9eed43aa3efa97099
sh bash 5.0_p17
ld GNU ld (Gentoo 2.33.1 p2) 2.33.1
distcc 3.3.3 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          5.0_p17::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.30.3::gentoo
dev-lang/python:          2.7.18-r1::gentoo, 3.6.11-r2::gentoo, 3.7.8-r2::gentoo, 3.8.4-r1::gentoo
dev-util/cmake:           3.16.5::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.12.6-r2::gentoo, 1.13.4-r2::gentoo, 1.14.1-r2::gentoo, 1.15.1-r2::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.33.1-r1::gentoo
sys-devel/gcc:            9.3.0-r1::gentoo
sys-devel/gcc-config:     2.3::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.4-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.30-r8::gentoo
Repositories:

gentoo
    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-extra-opts: -4
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-max-age: 24

The-Buell
    location: /var/lib/layman/thebuell
    masters: gentoo
    priority: 1

rion
    location: /var/lib/layman/rion
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=znver1 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.4/ext-active/ /etc/php/cgi-php7.4/ext-active/ /etc/php/cli-php7.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=znver1 -O2 -pipe"
DISTDIR="/var/cache/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.bytemark.co.uk/gentoo/"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_GB"
MAKEOPTS="-j20"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="-4"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac aacs acl acpi aio alsa amd64 apache2 apng avx bdplus berkdb bluetooth bluray branding bzip2 cairo cdda cdr clang cleartype cli colord corefonts crypt cups dbus dconf declarative dri drm dts dvd dvdr eds egl elogind emboss encode evo exif faac faad farstream fat ffmpeg flac fortran fpm g3dvl gallium gbm gd gdbm gdu gif glamor glslang gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk gudev hddtemp hwdb iconv icu introspection ipv6 java javafx jpeg keymap lapack lcms ldap libglvnd libnotify libsecret libtirpc lldb mad matroska melt mesa minizip mmx mmxext mng mp3 mp4 mpeg mtp multilib mysql mysqli nautilus ncurses networkmanager nls nptl ntfs objc ogg opencl opengl openmp openssl opus otr ozone pam pango pcre pdf playlist plugdev png policykit postproc ppds pulseaudio python qt5 readline rpc script scripttools sdl seccomp semantic-desktop session smpeg spell split-usr sql sqlite ssl ssse3 startup-notification svg system-ffmpeg system-libvpx tcpd theora threads tiff tinfo tracker truetype udev udisks unicode upnp upower usb vaapi vala vdpau vorbis vulkan wayland webkit widgets wxwidgets x264 x265 xa xattr xcb xkb xml xmp xv xvid zlib" ABI_X86="64 32" ADA_TARGET="gnat_2018" ALSA_CARDS="hda_intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sha sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc efi-64 multiboot" INPUT_DEVICES="evdev" KERNEL="linux" L10N="en-GB" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LLVM_TARGETS="X86 AMDGPU" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2 php7-3" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_7" PYTHON_TARGETS="python2_7 python3_7" QEMU_SOFTMMU_TARGETS="arm x86_64 riscv64" QEMU_USER_TARGETS="arm x86_64 riscv64" RUBY_TARGETS="ruby25" USERLAND="GNU" VIDEO_CARDS="amdgpu radeonsi radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 1 Alex Buell 2020-07-20 08:39:25 UTC
I can work around it by using:

chromium --ozone-platform=x11

It evidently defaults to something that makes it crash in Gnome.
Comment 2 Alex Buell 2020-07-20 08:41:11 UTC
My USE flags:

titanium ~ # emerge -pv chromium

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] www-client/chromium-84.0.4147.89::gentoo  USE="closure-compile cups hangouts ozone (pic) proprietary-codecs pulseaudio suid system-ffmpeg system-icu tcmalloc wayland (-component-build) -custom-cflags (-headless) -kerberos (-selinux) (-system-libvpx) -widevine" L10N="en-GB -am -ar -bg -bn -ca -cs -da -de -el -es -es-419 -et -fa -fi -fil -fr -gu -he -hi -hr -hu -id -it -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt-BR -pt-PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh-CN -zh-TW" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB
Comment 3 Alex Buell 2020-07-20 08:49:19 UTC
It appears that USE flag Wayland forces on the USE flag ozone, which I suspect is the cause of the issue. 

Overriding this with --ozone-platform=x11 works for me.
Comment 4 Stephan Hartmann gentoo-dev 2020-07-20 09:51:37 UTC
(In reply to Alex Buell from comment #3)
> It appears that USE flag Wayland forces on the USE flag ozone, which I
> suspect is the cause of the issue. 
> 
> Overriding this with --ozone-platform=x11 works for me.

Your desktop is configured to use Wayland? What is the value of XDG_SESSION_TYPE and WAYLAND_DISPLAY environment variables?
Comment 5 Alex Buell 2020-07-20 10:31:52 UTC
alex@titanium ~ $ echo $XDG_SESSION_TYPE
tty
alex@titanium ~ $ echo $WAYLAND_DISPLAY

alex@titanium ~ $ more .xinitrc
export XDG_MENU_PREFIX=gnome-
exec gnome-session

I think that's probably the issue. I start my session from the console prompt, I don't have it starting up X11/Wayland on boot. 

what should I be using in .xinitrc? 

Thanks,
Alex
Comment 6 Stephan Hartmann gentoo-dev 2020-07-20 11:01:39 UTC
(In reply to Alex Buell from comment #5)
> alex@titanium ~ $ echo $XDG_SESSION_TYPE
> tty
> alex@titanium ~ $ echo $WAYLAND_DISPLAY
> 
> alex@titanium ~ $ more .xinitrc
> export XDG_MENU_PREFIX=gnome-
> exec gnome-session
> 
> I think that's probably the issue. I start my session from the console
> prompt, I don't have it starting up X11/Wayland on boot. 
> 
> what should I be using in .xinitrc? 
> 
> Thanks,
> Alex

Ok, that case is not handled at the moment. Can you try to run 'XDG_SESSION_TYPE=wayland chromium' in a terminal and see if it starts up correctly?
Comment 7 Alex Buell 2020-07-20 11:41:34 UTC
OK it looks like Wayland isn't being started when I run startx, so I guess I need to sort that, but right now I don't know what the correct invocation to use.

Once I start weston, using XDG_SESSION_TYPE=wayland chromium works just fine.

I think it needs to know which ozone backend to use.
Comment 8 Alex Buell 2020-07-20 19:57:19 UTC
Chromium now works once I figured out Wayland needed to be started. X is not configured to start on boot as I prefer to start it from the VT. 

The following works for me:
XDG_SESSION_TYPE=wayland dbus-run-session gnome-session
Comment 9 Arfrever Frehtes Taifersar Arahesis 2020-07-20 20:54:37 UTC
Also, in chromium-launcher-r4.sh, instead of passing ${XDG_SESSION_TYPE} in arguments directly, it might be better to verify ${XDG_SESSION_TYPE} value:

>   else
>     platform=
>     if [[ ${XDG_SESSION_TYPE} == x11 ]]; then
>       platform=x11
>     elif [[ ${XDG_SESSION_TYPE} == wayland ]]; then
>       platform=wayland
>     else
>       echo "$0: Invalid XDG_SESSION_TYPE: \"${XDG_SESSION_TYPE}\"" >&2
>       exit 1
>     fi
>     CHROMIUM_FLAGS="--ozone-platform=${platform} ${CHROMIUM_FLAGS}"
>   fi
Comment 10 Arfrever Frehtes Taifersar Arahesis 2020-07-20 20:57:36 UTC
(In reply to Arfrever Frehtes Taifersar Arahesis from comment #9)

Or instead of "Invalid", maybe better "Unsupported".
Comment 11 Stephan Hartmann gentoo-dev 2020-07-21 15:37:37 UTC
(In reply to Arfrever Frehtes Taifersar Arahesis from comment #9)
> Also, in chromium-launcher-r4.sh, instead of passing ${XDG_SESSION_TYPE} in
> arguments directly, it might be better to verify ${XDG_SESSION_TYPE} value:
> 
> >   else
> >     platform=
> >     if [[ ${XDG_SESSION_TYPE} == x11 ]]; then
> >       platform=x11
> >     elif [[ ${XDG_SESSION_TYPE} == wayland ]]; then
> >       platform=wayland
> >     else
> >       echo "$0: Invalid XDG_SESSION_TYPE: \"${XDG_SESSION_TYPE}\"" >&2
> >       exit 1
> >     fi
> >     CHROMIUM_FLAGS="--ozone-platform=${platform} ${CHROMIUM_FLAGS}"
> >   fi

That was I was thinking of too. Error message is probably missed by most users, because they don't start chromium via command-line.
Another option is to only use DISPLAY and WAYLAND_DISPLAY env variables to select ozone backend.
Comment 12 Larry the Git Cow gentoo-dev 2020-07-26 16:42:54 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=1b229dd19792f4d0e63f94ab248c16a6a2b927bd

commit 1b229dd19792f4d0e63f94ab248c16a6a2b927bd
Author:     Stephan Hartmann <stha09@googlemail.com>
AuthorDate: 2020-07-24 17:42:24 +0000
Commit:     Mike Gilbert <floppym@gentoo.org>
CommitDate: 2020-07-26 16:42:38 +0000

    www-client/chromium: beta channel bump to 85.0.4183.39
    
    Bug: https://bugs.gentoo.org/733296
    Package-Manager: Portage-2.3.99, Repoman-2.3.23
    Signed-off-by: Stephan Hartmann <stha09@googlemail.com>
    Signed-off-by: Mike Gilbert <floppym@gentoo.org>

 www-client/chromium/Manifest                       |  2 +-
 ...4183.26.ebuild => chromium-85.0.4183.39.ebuild} |  5 +-
 www-client/chromium/files/chromium-launcher-r5.sh  | 56 ++++++++++++++++++++++
 3 files changed, 61 insertions(+), 2 deletions(-)
Comment 13 Larry the Git Cow gentoo-dev 2020-07-28 17:10:19 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=697bf97c6340368e959d5ac2d2c7ce58c7c49ef5

commit 697bf97c6340368e959d5ac2d2c7ce58c7c49ef5
Author:     Stephan Hartmann <stha09@googlemail.com>
AuthorDate: 2020-07-28 07:52:25 +0000
Commit:     Mike Gilbert <floppym@gentoo.org>
CommitDate: 2020-07-28 17:09:32 +0000

    www-client/chromium: stable channel bump to 84.0.4147.105
    
    Bug: https://bugs.gentoo.org/734150
    Bug: https://bugs.gentoo.org/733296
    Package-Manager: Portage-2.3.99, Repoman-2.3.23
    Signed-off-by: Stephan Hartmann <stha09@googlemail.com>
    Signed-off-by: Mike Gilbert <floppym@gentoo.org>
    Closes: https://github.com/gentoo/gentoo/pull/16867

 www-client/chromium/Manifest                      |   1 +
 www-client/chromium/chromium-84.0.4147.105.ebuild | 864 ++++++++++++++++++++++
 2 files changed, 865 insertions(+)
Comment 14 Larry the Git Cow gentoo-dev 2020-07-29 18:01:59 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=8aae47a9d865a4aa6445511b196a77a621016256

commit 8aae47a9d865a4aa6445511b196a77a621016256
Author:     Stephan Hartmann <stha09@googlemail.com>
AuthorDate: 2020-07-29 17:29:31 +0000
Commit:     Mike Gilbert <floppym@gentoo.org>
CommitDate: 2020-07-29 18:01:52 +0000

    www-client/chromium: security cleanup
    
    Closes: https://bugs.gentoo.org/734150
    Closes: https://bugs.gentoo.org/733296
    Package-Manager: Portage-2.3.99, Repoman-2.3.23
    Signed-off-by: Stephan Hartmann <stha09@googlemail.com>
    Signed-off-by: Mike Gilbert <floppym@gentoo.org>
    Closes: https://github.com/gentoo/gentoo/pull/16899

 www-client/chromium/Manifest                      |   1 -
 www-client/chromium/chromium-84.0.4147.89.ebuild  | 864 ----------------------
 www-client/chromium/files/chromium-launcher-r4.sh |  52 --
 3 files changed, 917 deletions(-)
Comment 15 Alex Buell 2020-07-30 09:47:30 UTC
Many thanks for your hard work, I can confirm the fix works perfectly and I can again launch the browser without needing anything else.