Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 733258 - dev-java/lucene-8.7.0: version bump
Summary: dev-java/lucene-8.7.0: version bump
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Java team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-20 02:10 UTC by John Helmert III
Modified: 2021-03-22 11:26 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Helmert III gentoo-dev Security 2020-07-20 02:10:14 UTC
Latest in tree is 3.6.2 which appears to have been released in about 2013 according to the dates here[1]. Latest upstream is 8.6.0, released this month (July 2020). After going through all of the changelogs since 3.6.2, there are many potential crashes and data loss problems that have been fixed since 3.6.2, but I'm unsure if much of that affects the versions we have in-tree.

[1] https://archive.apache.org/dist/lucene/java/
Comment 1 Larry the Git Cow gentoo-dev 2021-03-21 12:38:09 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/proj/sci.git/commit/?id=e78efb63107558c492825f9aaa0a35f61b29a2a9

commit e78efb63107558c492825f9aaa0a35f61b29a2a9
Author:     Andrew Ammerlaan <andrewammerlaan@riseup.net>
AuthorDate: 2021-03-21 12:35:36 +0000
Commit:     Andrew Ammerlaan <andrewammerlaan@riseup.net>
CommitDate: 2021-03-21 12:35:36 +0000

    dev-java/lucene: add new lucene versions for scilab
    
    At the moment this only builds with USE="-modules"
    because we are missing a dependency. Will add the
    keywords if/when I get the dependency working
    
    Also added a fixed ebuild for version 3.6.2,
    the one in ::gentoo fails with USE="contrib"
    see linked bug
    
    Bug: https://bugs.gentoo.org/733258
    Bug: https://bugs.gentoo.org/579086
    Package-Manager: Portage-3.0.17, Repoman-3.0.2
    Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>

 dev-java/lucene/Manifest                           |   3 +
 dev-java/lucene/files/lucene-3.6.2-ant-1.10.patch  |  24 +++
 .../lucene/files/lucene_contrib_icu4j_v50.patch    |  20 +++
 dev-java/lucene/lucene-3.6.2-r2.ebuild             | 162 +++++++++++++++++++
 dev-java/lucene/lucene-5.2.1.ebuild                | 165 +++++++++++++++++++
 dev-java/lucene/lucene-8.4.0.ebuild                | 180 +++++++++++++++++++++
 dev-java/lucene/metadata.xml                       |  12 ++
 7 files changed, 566 insertions(+)
Comment 2 Larry the Git Cow gentoo-dev 2021-03-22 11:26:24 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/proj/sci.git/commit/?id=5b2adbc1e60ab3673e33c1301b16fba07e83f6f1

commit 5b2adbc1e60ab3673e33c1301b16fba07e83f6f1
Author:     Andrew Ammerlaan <andrewammerlaan@riseup.net>
AuthorDate: 2021-03-22 11:26:13 +0000
Commit:     Andrew Ammerlaan <andrewammerlaan@riseup.net>
CommitDate: 2021-03-22 11:26:13 +0000

    dev-java/lucene: fix USE="modules"
    
    Disabled the modules that we are missing deps for.
    Most of them work though, added keywords
    
    Bug: https://bugs.gentoo.org/733258
    Package-Manager: Portage-3.0.17, Repoman-3.0.2
    Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>

 dev-java/lucene/lucene-5.2.1.ebuild | 70 ++++++++++++++++++++++++++++++-------
 dev-java/lucene/lucene-8.4.0.ebuild | 67 ++++++++++++++++++++++++++++-------
 2 files changed, 111 insertions(+), 26 deletions(-)