Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 733166 - dev-util/bless-0.6.2-r1 - System.TypeLoadException: Could not load type of field 'BlessMain:DataViewBox' (0) due to: Could not load file or assembly 'gtk-sharp, Version=2.12.0.0, Culture=neutral, PublicKeyToken=35e10195dab3c99f' or one of its dependencies
Summary: dev-util/bless-0.6.2-r1 - System.TypeLoadException: Could not load type of fi...
Status: RESOLVED DUPLICATE of bug 645786
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mike Auty
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-18 20:10 UTC by John Blbec
Modified: 2020-08-11 09:23 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge_info.txt,5.60 KB, text/plain)
2020-07-19 16:13 UTC, John Blbec
Details
emerge --info dev-util/bless (emerge_info_bless.txt,6.34 KB, text/plain)
2020-07-19 16:16 UTC, John Blbec
Details
dev-util/bless full build log (build failed) (bless_build.log,17.52 KB, text/x-log)
2020-07-19 16:23 UTC, John Blbec
Details
build log (build success) (dev-util:bless-0.6.2-r1:20200804-165910.log,34.51 KB, text/x-log)
2020-08-04 17:03 UTC, John Blbec
Details
qlist gtk-sharp (qlist_gtk-sharp.txt,9.72 KB, text/plain)
2020-08-05 04:54 UTC, John Blbec
Details
qacutil -l (qacutil.txt,13.18 KB, text/plain)
2020-08-05 04:54 UTC, John Blbec
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Blbec 2020-07-18 20:10:55 UTC
$ bless

Unhandled Exception:
System.TypeLoadException: Could not load type of field 'BlessMain:DataViewBox' (0) due to: Could not load file or assembly 'gtk-sharp, Version=2.12.0.0, Culture=neutral, PublicKeyToken=35e10195dab3c99f' or one of its dependencies.
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeLoadException: Could not load type of field 'BlessMain:DataViewBox' (0) due to: Could not load file or assembly 'gtk-sharp, Version=2.12.0.0, Culture=neutral, PublicKeyToken=35e10195dab3c99f' or one of its dependencies.


my "emerge --info" output is here http://dpaste.com/3RS8YYH
Comment 1 Jonas Stein gentoo-dev 2020-07-19 15:32:01 UTC
Thank you for the report. We need to have all information at hand before ticket assignment. That is why I ask you to 
* attach the logs and 
* paste the emerge info 
as described on https://wiki.gentoo.org/wiki/Attach_the_logs_to_the_bug_ticket
Please reopen this ticket (Status:UNCONFIRMED) afterwards.
Comment 2 John Blbec 2020-07-19 16:13:58 UTC
Created attachment 649868 [details]
emerge --info
Comment 3 John Blbec 2020-07-19 16:16:48 UTC
Created attachment 649870 [details]
emerge --info dev-util/bless
Comment 4 John Blbec 2020-07-19 16:23:31 UTC
Created attachment 649872 [details]
dev-util/bless full build log (build failed)
Comment 5 John Blbec 2020-07-19 16:24:21 UTC
i wanted to add a full build log but the build always fails, unfortunately...
Comment 6 Jeroen Roovers (RETIRED) gentoo-dev 2020-07-30 10:24:18 UTC
(In reply to Jonas Stein from comment #1)
> Please reopen this ticket (Status:UNCONFIRMED) afterwards.

Pleeeease stop closing bug reports like this, especially when you fail to follow up quickly even while you're CC'd. It's been sitting here for almost two weeks now.
Comment 7 Larry the Git Cow gentoo-dev 2020-08-04 14:14:23 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=35e74a126cee1741c98a8324ea272ee53395e20f

commit 35e74a126cee1741c98a8324ea272ee53395e20f
Author:     Mike Auty <ikelos@gentoo.org>
AuthorDate: 2020-08-04 14:11:09 +0000
Commit:     Mike Auty <ikelos@gentoo.org>
CommitDate: 2020-08-04 14:13:34 +0000

    dev-util/bless: Disambiguate Range
    
    Also removes very old versions of bless
    
    Closes: https://bugs.gentoo.org/733166
    Signed-off-by: Mike Auty <ikelos@gentoo.org>

 dev-util/bless/Manifest                            |   1 -
 dev-util/bless/bless-0.6.0-r3.ebuild               |  52 ------
 dev-util/bless/bless-0.6.0-r4.ebuild               |  52 ------
 dev-util/bless/bless-0.6.2-r1.ebuild               |   3 +-
 dev-util/bless/files/bless-0.6.0-docpath.patch     |  71 --------
 dev-util/bless/files/bless-0.6.0-mono-4.patch      |  36 ----
 dev-util/bless/files/bless-0.6.0-pixmap.patch      |  20 --
 .../files/bless-0.6.2-range-disambiguation.patch   | 202 +++++++++++++++++++++
 8 files changed, 204 insertions(+), 233 deletions(-)
Comment 8 Mike Auty gentoo-dev 2020-08-04 14:15:58 UTC
Thanks, this should fix the build issue you were encountering, but the issue you mentioned when running bless makes it sound as though gtk-sharp-2.12 isn't installed on your system?  If you're still experiencing issues after the rebuild (or the rebuild fails for any reason) please reopen this bug and I'll ask some more questions to try and figure out exactly what's going wrong...  5:)
Comment 9 John Blbec 2020-08-04 16:52:36 UTC
gtk-sharp is installed...

$ eix gtk-sharp
[I] dev-dotnet/gtk-sharp
     Available versions:  (2) 2.12.21^t
       {debug}
     Installed versions:  2.12.21(2)^t(05:03:48 PM 12/05/2017)(-debug)
     Homepage:            http://www.mono-project.com/GtkSharp
     Description:         gtk bindings for mono
Comment 10 John Blbec 2020-08-04 17:01:19 UTC
i've recompiled bless-0.6.2-r1 but the issue hasn't been solved. i still can't execute it so reopen the bug again.
Comment 11 John Blbec 2020-08-04 17:03:42 UTC
Created attachment 652936 [details]
build log (build success)
Comment 12 Mike Auty gentoo-dev 2020-08-05 02:20:36 UTC
Ok, I'm glad the compilation now works.  5:)

The gtk-sharp not being detected is a tricky one, and might actually suggest a gtk-sharp bug rather than a bless bug, but we'll try to figure out what's going on.  I know that gtk-sharp used to install its gac files in an unusual location (there was some confusion over whether the code was architecture specific, so some got installed in lib64 and some got install in just lib).

Could you please install portage-utils and then attach the output of "qlist gtk-sharp".  This should show where all the files installed by gtk-sharp live, and we can then verify where they live under the gac.

Also, please could you attach the output from "gacutil -l" which shows all the assemblies available in the global assembly catalog, so we can check whether the gac believes that gtk-sharp has been installed...
Comment 13 John Blbec 2020-08-05 04:54:20 UTC
Created attachment 653168 [details]
qlist gtk-sharp
Comment 14 John Blbec 2020-08-05 04:54:43 UTC
Created attachment 653170 [details]
qacutil -l
Comment 15 Mike Auty gentoo-dev 2020-08-05 09:06:25 UTC
Awwww, I knew I'd run into.  Unfortunately I ran into it many years ago, and it appears our dotnet team don't really exist (or haven't done anything about the bug in many years).  5:(

A quick solution appears to be either symlinking the /usr/lib64/mono/gac/ directory to /usr/lib/mono/gac/ so that the gac picks up those packages, or adding the ikelos overlay which removes the dotnet_multilib-comply call but that's neither is an ideal solution...

*** This bug has been marked as a duplicate of bug 645786 ***
Comment 16 John Blbec 2020-08-05 16:28:17 UTC
@mike, you mean to link a content of directory /usr/lib/mono/gac/* (147 directories) to the /usr/lib64/mono/gac/ ?
Comment 17 John Blbec 2020-08-05 16:29:57 UTC
(In reply to John Blbec from comment #16)
> @mike, you mean to link a content of directory /usr/lib/mono/gac/* (147
> directories) to the /usr/lib64/mono/gac/ ?

sorry a threw a source directory with a target directory, of course
Comment 18 John Blbec 2020-08-05 16:41:46 UTC
and yes i can confirm that work-around works :-)
Comment 19 John Blbec 2020-08-05 16:42:27 UTC
work-around:

# cd /usr/lib/mono/gac
# for d in /usr/lib64/mono/gac/*; do ln -s $d .; done
Comment 20 Mike Auty gentoo-dev 2020-08-11 09:23:47 UTC
Yep, sorry for the late reply.  Unfortunately until the mono team develops a better solution, that's the best work around we've got I'm afraid.  5:(