Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 73312 - dillo-0.8.3-r2 fails to install, seems due to wrong path in Makefile
Summary: dillo-0.8.3-r2 fails to install, seems due to wrong path in Makefile
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Mamoru KOMACHI (RETIRED)
Depends on:
Reported: 2004-12-04 01:53 UTC by Rumen Yotov
Modified: 2004-12-08 12:19 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Rumen Yotov 2004-12-04 01:53:10 UTC
Just upgraded dillo to 0.8.3-r2, but before that had an error while installing.
Here's the error log:
mkdir /var/tmp/portage/dillo-0.8.3-r2/image/usr/lib/dillo/dpi/hello
  /bin/install -c hello.filter.dpi 
/bin/sh ../mkinstalldirs /var/tmp/portage/dillo-0.8.3-r2/image//usr/lib/dillo/dpi/https
mkdir /var/tmp/portage/dillo-0.8.3-r2/image/usr/lib/dillo/dpi/https
  /bin/install -c https.filter.dpi 
make[2]: Leaving directory `/var/tmp/portage/dillo-0.8.3-r2/work/dillo-0.8.3/dpi'
make[1]: Leaving directory `/var/tmp/portage/dillo-0.8.3-r2/work/dillo-0.8.3/dpi'
Making install in config
make[1]: Entering directory `/var/tmp/portage/dillo-0.8.3-r2/work/dillo-0.8.3/config'
make[2]: Entering directory `/var/tmp/portage/dillo-0.8.3-r2/work/dillo-0.8.3/config'
/bin/sh ../mkinstalldirs /var/tmp/portage/dillo-0.8.3-r2/image//usr/bin
  /bin/install -c dillocfg /var/tmp/portage/dillo-0.8.3-r2/image//usr/bin/dillocfg
make[2]: Nothing to be done for `install-data-am'.
make[2]: Leaving directory `/var/tmp/portage/dillo-0.8.3-r2/work/dillo-0.8.3/config'
make[1]: Leaving directory `/var/tmp/portage/dillo-0.8.3-r2/work/dillo-0.8.3/config'
Making install in po
make[1]: Entering directory `/var/tmp/portage/dillo-0.8.3-r2/work/dillo-0.8.3/po'
/bin/sh ./mkinstalldirs /var/tmp/portage/dillo-0.8.3-r2/image//usr/share
/bin/sh: ./mkinstalldirs: No such file or directory
make[1]: *** [install-data-yes] Error 127
make[1]: Leaving directory `/var/tmp/portage/dillo-0.8.3-r2/work/dillo-0.8.3/po'
make: *** [install-recursive] Error 1

!!! ERROR: www-client/dillo-0.8.3-r2 failed.
!!! Function src_install, Line 86, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.

Following line looked like the culpit to me:
/bin/sh ../mkinstalldirs /var/tmp/portage/dillo-0.8.3-r2/image//usr/bin
two slashes in a path.
So went to work dir, backed up Makefile to
Looked at the Makefile end changed two lines:
mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
#mkinstalldirs = $(SHELL) `case "$(MKINSTALLDIRS)" in /*) echo "$(MKINSTALLDIRS)" ;; *) echo "$(top_builddir)/$(MKINSTALLDIRS)" ;; esac`
# mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
mkinstalldirs = $(SHELL) `case "$(MKINSTALLDIRS)" in /*) echo "$(MKINSTALLDIRS)" ;; *) echo "$(top_builddir)/$(MKINSTALLDIRS)" ;; esac`
Just switching the two lines, comment first uncomment second.
Then run: ebuild /var/portage/....../dillo-0.8.3-r2.ebuild install then qmerge.
All OK.
Unmerged the old dillo-0.8.3-r1 and tried the new dillo - it works.
That's all.
Here's the output of diff -au Makefile
--- Makefile	2004-12-04 11:15:04.233983848 +0200
+++	2004-12-04 11:14:07.643586896 +0200
@@ -27,8 +27,8 @@
 INSTALL = /bin/install -c
 MKINSTALLDIRS = ./mkinstalldirs
-# mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
-mkinstalldirs = $(SHELL) `case "$(MKINSTALLDIRS)" in /*) echo "$(MKINSTALLDIRS)" ;; *) echo "$(top_builddir)/$(MKINSTALLDIRS)" ;; esac`
+mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
+#mkinstalldirs = $(SHELL) `case "$(MKINSTALLDIRS)" in /*) echo "$(MKINSTALLDIRS)" ;; *) echo "$(top_builddir)/$(MKINSTALLDIRS)" ;; esac`
 GMSGFMT = /usr/bin/gmsgfmt
 MSGFMT = /usr/bin/msgfmt

Reproducible: Always
Steps to Reproduce:

Gentoo Base System version 1.6.7
Portage 2.0.51-r8 (default-linux/x86/2004.2/gcc34/2.6, gcc-3.4.3,
glibc-, 2.6.7-hardened-r16 i686)
System uname: 2.6.7-hardened-r16 i686 AMD Athlon(tm) XP 2200+
Python:              dev-lang/python-2.3.4 [2.3.4 (#1, Aug 23 2004, 17:25:16)]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.4
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.8.5-r2, 1.5, 1.4_p6, 1.6.3, 1.7.9, 1.9.3
sys-devel/libtool:   1.5.10
CFLAGS="-march=i686 -O2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown
/usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=i686 -O2 -pipe -fomit-frame-pointer"
FEATURES="autoaddcvs autoconfig ccache collision-protect distlocks gpg sandbox
USE="3dnow X X509 aalib acl acpi apache2 avi berkdb bitmap-fonts bonobo caps cdr
chroot clamav crypt cups curl dedicated directfb dvd dvdr encode esd evo f77 fam
ffmpeg flac foomaticdb fortran freetype gd gdbm gif gnome gpm gstreamer gtk gtk2
gtkhtml guile hardened hardenedphp imagemagick imap imlib ipv6 java javascript
jpeg junit kde ldap libg++ libwww mad maildir matroska mikmod mmx motif mozilla
mpeg mpeg4 mysql ncurses nls nptl nvidia oggvorbis opengl oss pam pdflib perl
png postgres ppds prelude python qt quicktime readline samba sdl skey slang snmp
speex spell sse ssl svg svga tcltk tcpd tetex theora tiff transcode truetype
unicode usb x86 xml xml2 xmms xv xvid zlib linguas_bg linguas_en"
Comment 1 Daniel Webert 2004-12-04 08:00:41 UTC
same problem overhere
Comment 2 Mike Gardiner (RETIRED) gentoo-dev 2004-12-06 08:12:27 UTC
@reporter Daniel: please provide your emerge info.

@reporter Rumen: Unfortunately, I don't think that's the problem - two slashes has no effect on paths, and if it actually was a shell error like that - the problem would be occuring for everyone, and it doesn't occur for me.

Can you please try without ccache?
Also, are you using hardened?
Comment 3 Mike Gardiner (RETIRED) gentoo-dev 2004-12-06 08:20:21 UTC
I may be being dense, but I can't see where your patch would apply?
Comment 4 Daniel Webert 2004-12-06 08:24:27 UTC
Portage 2.0.51-r8 (default-linux/x86/2004.3, gcc-3.4.3, glibc-, 2.6.9-cko3 i686)
System uname: 2.6.9-cko3 i686 Intel(R) Pentium(R) 4 CPU 1.60GHz
Gentoo Base System version 1.6.7
Python:              dev-lang/python-2.3.4 [2.3.4 (#1, Nov 27 2004, 09:03:13)]
distcc 2.18.2 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.4
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.9.3, 1.8.5-r2, 1.4_p6, 1.5, 1.6.3, 1.7.9
sys-devel/libtool:   1.5.2-r7
CFLAGS="-march=pentium4 -O2 -pipe -fomit-frame-pointer -fforce-mem -fforce-addr -falign-functions=4 -fprefetch-loop-arrays -ffast-math"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium4 -O2 -pipe -fomit-frame-pointer -fforce-mem -fforce-addr -falign-functions=4 -fprefetch-loop-arrays -ffast-math"
FEATURES="autoaddcvs autoconfig candy ccache distlocks loadpolicy sandbox sfperms userpriv usersandbox"
USE="GAPING_SECURITY_HOLE X X509 Xaw3d aac aalib acl adns aim aliaschain alsa amd apache2 apm arts artswrappersuid async audiofile avi bash-completion bcmath berkdb bidi bitmap-fonts bmp bonobo bzlib calendar cddb cdparanoia cdr cdrom chroot clamav clanJavaScript clanVoice client cnamefix codecs cpdflib crypt css ctype cups curl curlwrappers dba dedicated devmap dillo dio disablekernelsupport distcache distribution divx4linux dnd dts dv dvd dvdr dvdread edl encode erandom escreen esd estraier ethereal etwin evms2 exif f77 faac faad fam fbcon ffmpeg flac flash flatfile flood fmod font-server foomaticdb fortran fpx freetype fs ftp ftruncate fusion fwdzone gb gd gdbm geoip ggi gif gimp gkrellm glut gmail gmp gphoto2 gpm gps gs gtk gtk2 gtkhtml hardenedphp hbci hub iconv icq ieee1394 imagemagick imap imlib imlib2 immqt-bc inifile innodb intl ipv6 ipv6arpa ithreads jabber java javascript jbig jce jikes jp2 jpeg jpeg2k junit jython kadu-modules kadu-voice lcd lcms ldap libcaca libg++ libsamplerate libwww live lm_sensors ltsp lua lufsusermount lzo lzw lzw-tiff mad maildir maildrop mailwrapper matroska mbox mcal md5sum memlimit mhash mikmod mime ming mixer mmx mmx2 mng motif moznocompose moznoirc moznomail mozp3p mozsvg mozxmlterm mp3 mpeg mpeg4 mplayer msn multipleip mysql nas ncurses net network neural nis nls nntp nowin nptl ntlm nvidia nviz oav offensive ofx oggvorbis openal opengl oscar oss pam passfile pcap pcre pdflib perl php physfs pic pie png postgres prelude procmail python qt quicktime quotes readline real rplay rtc sdl semanticfix server session sftplogging silc silverxp skey slang smartcard smime sndfile snmp soap sockets socks5 softmmu speex spell sse sse2 ssl stats streamzap stroke subject-rewrite svg svga szip tcltk tcpd tga theora threads thumbnail tidy tiff timidity tokenizer transcode transparent-proxy truetype truetype-fonts type1-fonts uml unicode uptimed usb userlocales uudeview v4l v4l2 vda vhosts vim-with-x virus-scan wmf wsconvert x86 xanim xchatdccserver xchattext xface xfs xgetdefault xine xinerama xml xml2 xmlrpc xmms xosd xpm xrandr xsl xv xvid xvmc yahoo yv12 zlib linguas_en linguas_de linguas_es"
Comment 5 Rumen Yotov 2004-12-06 08:44:45 UTC
Yes i'm using hardened also all system ~x86 - see 'emerge info' in comment #1.
The diff wasn't intended as a patch just tried the diff output and options, if sometime need to make a patch ;-).
i also think it's not due to the two slashes present but solved the problem for me and don't have other ideas. you wanna me recompile again w/o ccache?
OK done, dillo-0.8.3-r2 compiles w/o errors even with ccache (same config).
As in the last two days several times emerged different versions of automake, upgrading and downgrading, may be this was a problem with autoconf/automake.
Comment 6 Mike Gardiner (RETIRED) gentoo-dev 2004-12-06 08:53:57 UTC
It's fine as a patch, but I can't see where it would patch the line:
#mkinstalldirs = $(SHELL) `case "$(MKINSTALLDIRS)" in /*) echo "$(MKINSTALLDIRS)" ;; *) echo "$(top_builddir)/$(MKINSTALLDIRS)" ;; 

Which Makefile are you patching? (ie which directory)
Comment 7 Rumen Yotov 2004-12-06 10:03:56 UTC
Frankly i didn't actually patched it, just edited it by hand, did the diff afterwards.
All this did in dillo's work directory (/var/tmp/portage/dillo-0.8.3-r2/work...), the file was "Makefile".
Assumed it's a bug in Makefile so checked, there were two lines pointing to this path, one commented, the other uncommented so reversed them as the commented seemed to do the things. At this time thought the author wanted to change something but forgot to finish it.
Now as dillo emerged clearly on the second try (w/o editing, patch etc), think it was something to do with errors in autoconf/automake generating the Makefile in question.
Comment 8 Neil Bothwick 2004-12-06 10:59:55 UTC
I'm getting the same, with or without ccache

Portage 2.0.51-r8 (default-linux/amd64/2004.3, gcc-3.4.3, glibc-, 2.6.9-gentoo-r9 x86_64)
System uname: 2.6.9-gentoo-r9 x86_64 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System version 1.6.7
Python:              dev-lang/python-2.3.4 [2.3.4 (#1, Nov  8 2004, 18:23:06)]
distcc 2.18.2 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.4
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.8.5-r2, 1.5, 1.4_p6, 1.6.3, 1.7.9, 1.9.3
sys-devel/libtool:   1.5.2-r7
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=athlon64 -O2 -pipe -fomit-frame-pointer -funit-at-a-time"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon64 -O2 -pipe -fomit-frame-pointer -funit-at-a-time"
FEATURES="autoaddcvs autoconfig buildpkg ccache distlocks sandbox"
PORTDIR_OVERLAY="/mnt/portage/local /mnt/portage/bmg-main"
USE="amd64 X aalib acpi alsa apache2 arts artswrappersuid avi berkdb bitmap-fonts bonobo cdr crypt cups directfb divx4linux dv dvd dvdr encode esd f77 fam flac foomaticdb fortran gdbm gif gimpprint gphoto2 gpm gstreamer gtk gtk2 gtkhtml guile imagemagick imlib jabber java jbig jp2 jpeg junit kde ldap lesstif libwww lzw lzw-tiff mad mailwrapper mikmod mozilla mpeg multilib mysql ncurses nls nptl oggvorbis opengl oss pam pdflib perl png ppds python qt quicktime readline samba scanner sdl slang slp spell sqlite ssl tcltk tcpd tifftruetype usb userlocales xfs xml xml2 xmms xpm xprint xrandr xv xvid zlib video_cards_nvidia linguas_en_GB"

Comment 9 Ferris McCormick (RETIRED) gentoo-dev 2004-12-06 11:39:02 UTC
I don't know if we're voting here, or keeping score, or what, but I'll weigh in.
On sparc, I also see the problem (without ccache, if it matters):

make[1]: Entering directory `/var/tmp/portage/dillo-0.8.3-r2/work/dillo-0.8.3/po'
/bin/sh ./mkinstalldirs /var/tmp/portage/dillo-0.8.3-r2/image//usr/share
./mkinstalldirs: ./mkinstalldirs: No such file or directory
make[1]: *** [install-data-yes] Error 127
make[1]: Leaving directory `/var/tmp/portage/dillo-0.8.3-r2/work/dillo-0.8.3/po'
make: *** [install-recursive] Error 1

!!! ERROR: www-client/dillo-0.8.3-r2 failed.
!!! Function src_install, Line 86, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.

For what it is worth, this system is hardened.
Comment 10 Daniel Karlsson 2004-12-06 17:26:15 UTC
I suspect the problem arises from dillo-0.8.3-i18n-misc-20041201.diff.bz2 which has used automake 1.7.9 to generate parts of the patch, while automake 1.9.2 was used for dillo-0.8.3-i18n-misc-20041118.diff.bz2(used in dillo-0.8.3-r1).

Thus adding somthing like:
	autoconf || die
	aclocal || die
	automake || die
to src_compile() in the ebuild, would fix the problem.
Comment 11 Mike Gardiner (RETIRED) gentoo-dev 2004-12-07 01:32:23 UTC
Heya Usata, 

Seems we've found the bug, good luck.
Comment 12 Mamoru KOMACHI (RETIRED) gentoo-dev 2004-12-07 04:12:49 UTC
This bug is not reproduceable to me on four of
my Gentoo boxen (x86 and alpha), but I add
"sh || die" to dillo-0.8.3-r3.ebuild
so it should be solved now. People who had
a problem with -r2, please test -r3.
Comment 13 Yuri Vasilevski (RETIRED) gentoo-dev 2004-12-07 07:56:48 UTC
-r3 worked fine on all my 3 boxes (all x86) -r2 didn't emerged.

Comment 14 Neil Bothwick 2004-12-07 08:58:54 UTC
r3 works on my AMD64 desktop, r2 didn't. But r2 did work on my P4 laptop.
Comment 15 Rumen Yotov 2004-12-07 10:01:59 UTC
Tried to compile dillo-0.8.3-r3 and receive a config error, see below:
>>> md5 src_uri ;-) dillo-0.8.3.tar.bz2
>>> md5 src_uri ;-) dillo-gentoo-extras-patch4.tar.bz2
>>> md5 src_uri ;-) dillo-0.8.3-i18n-misc-20041206.diff.bz2
>>> root -sandbox(setup)
>>> root +sandbox(unpack)
>>> Unpacking source...
>>> Unpacking dillo-0.8.3.tar.bz2 to /var/tmp/portage/dillo-0.8.3-r3/work
>>> Unpacking dillo-gentoo-extras-patch4.tar.bz2 to /var/tmp/portage/dillo-0.8.3-r3/work
>>> Unpacking dillo-0.8.3-i18n-misc-20041206.diff.bz2 to /var/tmp/portage/dillo-0.8.3-r3/work
 * Applying dillo-0.8.3-i18n-misc-20041206.diff ...
[ ok ] * Using default Dillo icon set

aclocal         NOT found
autoheader      found
autoconf        found
automake        NOT found

ERROR: to run this program you need the following installed
       aclocal autoheader autoconf automake

!!! ERROR: www-client/dillo-0.8.3-r3 failed.
!!! Function src_unpack, Line 68, Exitcode 1
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.
i have: SLOTED
Early today checked with glsa-check and applied (again ;-) some changed to automake, now it says that the same vuln. is present and want to apply a different things it seems.
Nothing for 'aclocal' in portage, what's this?
Comment 16 Daniel Karlsson 2004-12-07 11:13:33 UTC
Rumen: Do you have automake-wrapper installed?
Comment 17 Rumen Yotov 2004-12-07 11:35:54 UTC
Yes, just rebuild it.
But something is certainly broken in my system as now glsa-check run for some time with output and then gives an error. Another error 'automake not found' before that - so automake IS broken.
i'll try again when fix my system.
Comment 18 Rumen Yotov 2004-12-07 20:42:04 UTC
Things are fixed for me too. Just rebuild all SLOTS of automake.
dillo-0.8.3-r3 builds OK.
Comment 19 Rumen Yotov 2004-12-08 12:19:11 UTC
Think this bug should be closed.
Seems it's solved for all.