Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 733036 - media-libs/libglvnd fails tests
Summary: media-libs/libglvnd fails tests
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-17 08:21 UTC by Agostino Sarubbo
Modified: 2020-10-07 18:23 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,109.68 KB, text/plain)
2020-07-17 08:21 UTC, Agostino Sarubbo
Details
testlog.txt (testlog.txt,34.80 KB, text/plain)
2020-07-26 00:12 UTC, Alexey
Details
build.log (build.log,194.18 KB, text/x-log)
2020-07-26 00:13 UTC, Alexey
Details
emerge --info (file_733036.txt,19.86 KB, text/plain)
2020-07-26 00:14 UTC, Alexey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-07-17 08:21:17 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: media-libs/libglvnd fails tests.
Discovered on: amd64 (internal ref: amd64_at)
Comment 1 Agostino Sarubbo gentoo-dev 2020-07-17 08:21:23 UTC
Created attachment 649668 [details]
build.log

build log and emerge --info
Comment 2 Matt Turner gentoo-dev 2020-07-17 22:12:52 UTC
Please include the test log from /var/tmp/portage/media-libs/libglvnd-1.3.2/work/libglvnd-v1.3.2-abi_x86_64.amd64/meson-logs/testlog.txt
Comment 3 Agostino Sarubbo gentoo-dev 2020-07-19 07:39:33 UTC
I can't reproduce anymore. I'd say to remove the blocker and keep it open for further verifications
Comment 4 Alexey 2020-07-26 00:12:19 UTC
libglvnd-1.3.2 fails for me too.
Comment 5 Alexey 2020-07-26 00:12:39 UTC
Created attachment 650768 [details]
testlog.txt
Comment 6 Alexey 2020-07-26 00:13:25 UTC
Created attachment 650770 [details]
build.log
Comment 7 Alexey 2020-07-26 00:14:01 UTC
Created attachment 650772 [details]
emerge --info
Comment 8 Matt Turner gentoo-dev 2020-07-30 20:14:43 UTC
(In reply to Alexey from comment #4)
> libglvnd-1.3.2 fails for me too.

Consistently?

Your error is

> No display! Please re-test with a running X server
> and the DISPLAY environment variable set appropriately.

But we're running tests under virtx with USE=X so I don't understand how that can happen.

	if use X; then
		virtx meson_src_test
	else
		meson_src_test
	fi

So I need someone who can reproduce this to do a little digging.
Comment 9 Alexey 2020-08-04 23:22:53 UTC
Nope, not consistently :(