Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 73254 - media-video/mplayer-1.0_pre4-r7 failed
Summary: media-video/mplayer-1.0_pre4-r7 failed
Status: RESOLVED DUPLICATE of bug 51853
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Chris White (RETIRED)
: 73578 74132 79767 (view as bug list)
Depends on:
Reported: 2004-12-03 12:42 UTC by Ruben Schollaert
Modified: 2005-07-17 13:06 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Ruben Schollaert 2004-12-03 12:42:27 UTC
When I try to emerge mplayer, I get errors about 3dnow

Reproducible: Always
Steps to Reproduce:
1. Open console
2. su
3. emerge mplayer

Actual Results:  
Emerge error..

Expected Results:  

Portage 2.0.51-r3 (default-linux/x86/2004.2, gcc-3.3.4, glibc-,
2.4.26-gentoo-r9 i686)
System uname: 2.4.26-gentoo-r9 i686 Intel(R) Pentium(R) 4 CPU 2.40GHz
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-
Headers:  sys-kernel/linux-headers-2.4.21-r1
Libtools: sys-devel/libtool-1.5.2-r7
CFLAGS="-mcpu=i686 -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown
/usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-mcpu=i686 -fomit-frame-pointer"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
USE="X aalib alsa apm avi berkdb bitmap-fonts cdr crypt cups encode esd f77 fam
flac foomaticdb fortran gdbm gif gnome gpm gtk gtk2 imagemagick imlib java jpeg
junit kde ldap libg++ libwww mad mikmod motif mozilla mpeg ncurses nls oggvorbis
opengl oss pam pdflib perl png python qt quicktime readline sdl slang spell ssl
svga tcltk tcpd tiff truetype x86 xml xml2 xmms xv zlib"
Comment 1 Carsten Lohrke (RETIRED) gentoo-dev 2004-12-03 13:05:05 UTC
Ruben: please be a bit more specific in your summary and paste the lines, where the error occurs.

gcc -c  -I../libvo/ -I../../libvo -mcpu=i686 -fomit-frame-pointer -fno-stack-protector -D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include  -o imdct.o imdct.c
In file included from imdct.c:757:
imdct_3dnow.h: In function `fft_asmb_3dnow':
imdct_3dnow.h:241: error: can't find a register in class `GENERAL_REGS' while reloading `asm'
imdct.c: In function `imdct_do_512_sse':
imdct.c:937: warning: use of memory input without lvalue in asm operand 1 is deprecated
imdct.c:937: warning: use of memory input without lvalue in asm operand 2 is deprecated
make[1]: *** [imdct.o] Error 1
make[1]: Leaving directory `/var/tmp/portage/mplayer-1.0_pre4-r7/work/MPlayer-1.0pre4/liba52'
make: *** [liba52/liba52.a] Error 2
Comment 2 Carsten Lohrke (RETIRED) gentoo-dev 2004-12-06 12:45:33 UTC
*** Bug 73578 has been marked as a duplicate of this bug. ***
Comment 3 Carsten Lohrke (RETIRED) gentoo-dev 2004-12-11 14:10:54 UTC
*** Bug 74132 has been marked as a duplicate of this bug. ***
Comment 4 Alex 2005-01-04 22:50:31 UTC
mplayer-1.0_pre6 failes with the same error on two different systems (pentium m/athlon xp)- still no solution...
Comment 5 Carsten Lohrke (RETIRED) gentoo-dev 2005-01-27 14:36:54 UTC
*** Bug 79767 has been marked as a duplicate of this bug. ***
Comment 6 Chris White (RETIRED) gentoo-dev 2005-02-05 07:36:25 UTC

*** This bug has been marked as a duplicate of 51853 ***