Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 732152 - dev-texlive/texlive-formatsextra-2020-r1 file collisions with dev-tex/xmltex-1.9-r3
Summary: dev-texlive/texlive-formatsextra-2020-r1 file collisions with dev-tex/xmltex-...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mikle Kolyada
URL:
Whiteboard:
Keywords:
: 732228 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-07-11 01:09 UTC by nivedita
Modified: 2020-07-11 21:32 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,85.44 KB, text/plain)
2020-07-11 03:22 UTC, email200202
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nivedita 2020-07-11 01:09:46 UTC
https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=50ff4379b10413cf5c683644eae0c58748350a22

This commit added xmltex, and has created file conflicts with dev-tex/xmltex.

 * Messages for package dev-texlive/texlive-formatsextra-2020-r1:

 * This package will overwrite one or more files that may belong to other
 * packages (see list below). You can use a command such as `portageq
 * owners / <filename>` to identify the installed package that owns a
 * file. If portageq reports that only one package owns a file then do
 * NOT file a bug report. A bug report is only useful if it identifies at
 * least two or more packages that are known to install the same file(s).
 * If a collision occurs and you can not explain where the file came from
 * then you should simply ignore the collision since there is not enough
 * information to determine if a real problem exists. Please do NOT file
 * a bug report at https://bugs.gentoo.org/ unless you report exactly
 * which two packages install the same file(s). See
 * https://wiki.gentoo.org/wiki/Knowledge_Base:Blockers for tips on how
 * to solve the problem. And once again, please do NOT file a bug report
 * unless you have completely understood the above message.
 * 
 * Detected file collision(s):
 * 
 *      /var/lib/texmf/web2c/pdftex/xmltex.log
 *      /var/lib/texmf/web2c/pdftex/xmltex.fmt
 *      /var/lib/texmf/web2c/pdftex/pdfxmltex.log
 *      /var/lib/texmf/web2c/pdftex/pdfxmltex.fmt
 *      /usr/bin/pdfxmltex
 *      /usr/bin/xmltex
 * 
 * Searching all installed packages for file collisions...
 * 
 * Press Ctrl-C to Stop
 * 
 * dev-tex/xmltex-1.9-r3:0::gentoo
 *      /usr/bin/pdfxmltex
 *      /usr/bin/xmltex
 * 
 * Package 'dev-texlive/texlive-formatsextra-2020-r1' NOT merged due to
 * file collisions. If necessary, refer to your elog messages for the
 * whole content of the above message.
Comment 1 email200202 2020-07-11 03:19:06 UTC
Same here.
Comment 2 email200202 2020-07-11 03:22:44 UTC
Created attachment 648840 [details]
build.log
Comment 3 email200202 2020-07-11 03:39:44 UTC
After uninstalling dev-tex/xmltex, the emerge of dev-texlive/texlive-formatsextra finished successfully.

# emerge -av --depclean dev-tex/xmltex

Calculating dependencies... done!
>>> Calculating removal order...

>>> These are the packages that would be unmerged:

 dev-tex/xmltex
    selected: 1.9-r3 
   protected: none 
     omitted: none 

All selected packages: =dev-tex/xmltex-1.9-r3

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

Would you like to unmerge these packages? [Yes/No]
Comment 4 Georgy Yakovlev gentoo-dev 2020-07-11 03:46:33 UTC
workaround is 

emerge -C xmltex

and then install this package.
Comment 5 Larry the Git Cow gentoo-dev 2020-07-11 07:39:59 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2851fc95129fafbf8ae837f677fcc13faf0dd603

commit 2851fc95129fafbf8ae837f677fcc13faf0dd603
Author:     Ulrich Müller <ulm@gentoo.org>
AuthorDate: 2020-07-11 07:39:13 +0000
Commit:     Ulrich Müller <ulm@gentoo.org>
CommitDate: 2020-07-11 07:39:13 +0000

    dev-texlive/texlive-formatsextra: Block against dev-tex/xmltex.
    
    Closes: https://bugs.gentoo.org/732152
    Package-Manager: Portage-2.3.103, Repoman-2.3.23
    Signed-off-by: Ulrich Müller <ulm@gentoo.org>

 dev-texlive/texlive-formatsextra/texlive-formatsextra-2020-r1.ebuild | 1 +
 1 file changed, 1 insertion(+)
Comment 6 Ulrich Müller gentoo-dev 2020-07-11 07:55:38 UTC
The blocker won't always help for the files under /var/lib/texmf:

(In reply to nivedita from comment #0)
>  *      /var/lib/texmf/web2c/pdftex/xmltex.log
>  *      /var/lib/texmf/web2c/pdftex/xmltex.fmt
>  *      /var/lib/texmf/web2c/pdftex/pdfxmltex.log
>  *      /var/lib/texmf/web2c/pdftex/pdfxmltex.fmt

Users with "collision-protect" in FEATURES will have to remove them manually. (Should be fine with "protect-owned", however.)
Comment 7 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2020-07-11 21:32:05 UTC
*** Bug 732228 has been marked as a duplicate of this bug. ***