Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 73156 - emerge grub-0.95-20040823 fails from automake version mismatch
Summary: emerge grub-0.95-20040823 fails from automake version mismatch
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Robert Moss (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-12-02 11:31 UTC by Henry Baxter
Modified: 2004-12-20 12:00 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Henry Baxter 2004-12-02 11:31:42 UTC
When I emerge grub (make.conf ACCEPT_KEYWORDS="~x86") it fails with 'version mismatch. This is Automake 1.7.9 but the definition used by this AM_INIT_AUTOMAKE comes from Automake 1.8.5. You should recreate aclocal.m4 with aclocal and run automake again.' <-- this is in configure.ac:19

I can stop this happening by changing the ebuild on line 61 from WANT_AUTOMAKE=1.7 to WANT_AUTOMAKE=1.8 BUT I don't know if that's the 'real fix'

Reproducible: Always
Steps to Reproduce:
1.emerge grub
2.
3.

Actual Results:  
Calculating dependencies ...done!
>>> emerge (1 of 1) sys-boot/grub-0.95.20040823 to /
mv: cannot stat `/var/tmp/portage/grub-0.95.20040823/temp/environment': No such
file or directory
>>> md5 src_uri ;-) grub-0.95.20040823.tar.gz
>>> md5 src_uri ;-) grub-0.95.20040823-splash.patch.bz2
>>> Checking grub-0.95.20040823.tar.gz's mtime...
>>> Checking grub-0.95.20040823-splash.patch.bz2's mtime...
>>> WORKDIR is up-to-date, keeping...
/usr/share/aclocal/wxwin.m4:36: warning: underquoted definition of
AM_OPTIONS_WXCONFIG
  run info '(automake)Extending aclocal'
  or see http://sources.redhat.com/automake/automake.html#Extending%20aclocal
/usr/share/aclocal/wxwin.m4:59: warning: underquoted definition of AM_PATH_WXCONFIG
/usr/share/aclocal/smpeg.m4:13: warning: underquoted definition of AM_PATH_SMPEG
/usr/share/aclocal/pkg.m4:5: warning: underquoted definition of PKG_CHECK_MODULES
/usr/share/aclocal/libmikmod.m4:11: warning: underquoted definition of
AM_PATH_LIBMIKMOD
/usr/share/aclocal/libmcrypt.m4:17: warning: underquoted definition of
AM_PATH_LIBMCRYPT
/usr/share/aclocal/libglade.m4:7: warning: underquoted definition of
AM_PATH_LIBGLADE
/usr/share/aclocal/libgcrypt.m4:23: warning: underquoted definition of
AM_PATH_LIBGCRYPT
/usr/share/aclocal/libfame.m4:6: warning: underquoted definition of AM_PATH_LIBFAME
/usr/share/aclocal/libart.m4:11: warning: underquoted definition of AM_PATH_LIBART
/usr/share/aclocal/libIDL.m4:6: warning: underquoted definition of AM_PATH_LIBIDL
/usr/share/aclocal/imlib.m4:9: warning: underquoted definition of AM_PATH_IMLIB
/usr/share/aclocal/imlib.m4:167: warning: underquoted definition of
AM_PATH_GDK_IMLIB
/usr/share/aclocal/gtkgl.m4:4: warning: underquoted definition of AM_PATH_GTKGL
/usr/share/aclocal/gtk.m4:7: warning: underquoted definition of AM_PATH_GTK
/usr/share/aclocal/glib.m4:8: warning: underquoted definition of AM_PATH_GLIB
/usr/share/aclocal/gdk-pixbuf.m4:12: warning: underquoted definition of
AM_PATH_GDK_PIXBUF
/usr/share/aclocal/freetype2.m4:7: warning: underquoted definition of AC_CHECK_FT2
/usr/share/aclocal/audiofile.m4:12: warning: underquoted definition of
AM_PATH_AUDIOFILE
/usr/share/aclocal/ao.m4:9: warning: underquoted definition of XIPH_PATH_AO
/usr/share/aclocal/ORBit.m4:4: warning: underquoted definition of AM_PATH_ORBIT
configure.ac:19: version mismatch.  This is Automake 1.7.9,
configure.ac:19: but the definition used by this AM_INIT_AUTOMAKE
configure.ac:19: comes from Automake 1.8.5.  You should recreate
configure.ac:19: aclocal.m4 with aclocal and run automake again.

!!! ERROR: sys-boot/grub-0.95.20040823 failed.
!!! Function src_compile, Line 61, Exitcode 1
!!! automake failed
!!! If you need support, post the topmost build error, NOT this status message.


Expected Results:  
updated grub! but i managed to get it to work, so i'm not unhappy

Portage 2.0.51-r7 (default-linux/x86/2004.3, gcc-3.3.4, glibc-2.3.4.20041102-r0,
2.6.9-gentoo-r1 i686)
=================================================================
System uname: 2.6.9-gentoo-r1 i686 Intel(R) Pentium(R) 4 CPU 2.40GHz
Gentoo Base System version 1.6.6
Python:              dev-lang/python-2.3.4 [2.3.4 (#1, Dec  1 2004, 01:31:32)]
distcc 2.18.2 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.4
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.8.5-r2, 1.5, 1.4_p6, 1.6.3, 1.7.9, 1.9.3
sys-devel/binutils:  2.15.92.0.2-r1
sys-devel/libtool:   1.5.10
virtual/os-headers:  2.4.22
ACCEPT_KEYWORDS="x86 ~x86"
CFLAGS="-O3 -march=pentium4 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=pentium4 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distcc distlocks keeptemp keepwork
nostrip sandbox sfperms"
GENTOO_MIRRORS="http://distfiles.gentoo.org
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X alsa apm avi berkdb bitmap-fonts cdr crypt cups doc dvd dvd4linux
dvdr dvdread encode esd f77 fam flac foomaticdb fortran gdbm gif gpm imagemagick
imap imlib java jikes jpeg libg++ libwww mad mikmod mmx mmx2 motif mpeg msn
mysql ncurses nls odbc oggvorbis opengl pam pdflib perl php png python quicktime
readline samba sdl simplexml slang spell sse sse2 ssl svga tcltk tcpd tiff
truetype usb wmf x86 xinerama xml xml2 xmms xsl xv xvid zlib"
Comment 1 David Kaplowitz 2004-12-04 09:52:06 UTC
I'm having this error too. I guess I'm enough of a newbie not to know how to edit the ebuild b/c every time I do and try to emerge grub it changes back to WANT_AUTOMAKE=1.7 ...I'll figure it out.

I'm having tons of problems with automake, however, emerging gtk+ deps from emul10k1 (also wanted automake 1.7) and also while emerging fluxbox. I capitulated and installed automake-1.7, but it hasn't helped me with fluxbox, or grub (says "version mismatch. This is Automake 1.7.9, but the definition used by this AM_INIT_AUTOMAKE comes from Automake 1.8.5. You should recreate aclocal.m4 with aclocal and run automake again." I'll go to the forums with help on the details.
Comment 2 David Kaplowitz 2004-12-04 09:53:15 UTC
I'm having this error too. I guess I'm enough of a newbie not to know how to edit the ebuild b/c every time I do and try to emerge grub it changes back to WANT_AUTOMAKE=1.7 ...I'll figure it out.

I'm having tons of problems with automake, however, emerging gtk+ deps from emul10k1 (also wanted automake 1.7) and also while emerging fluxbox. I capitulated and installed automake-1.7, but it hasn't helped me with fluxbox, or grub (says "version mismatch. This is Automake 1.7.9, but the definition used by this AM_INIT_AUTOMAKE comes from Automake 1.8.5. You should recreate aclocal.m4 with aclocal and run automake again." I'll go to the forums with help on the details.
Comment 3 Alexandre Rostovtsev (RETIRED) gentoo-dev 2004-12-04 23:00:22 UTC
It appears that ~x86 has just switched to automake-wrapper. This was not well-thought-through, because in many cases, the upgrade would unmerge automake-1.8, breaking many ebuilds. So if you've recently upgraded automake, I advise you to 
ACCEPT_KEYWORDS=~x86 emerge -av '<automake-1.9'
which should emerge the latest version of automake-1.8. Then, you can emerge grub or whatever.
Comment 4 Alexandre Rostovtsev (RETIRED) gentoo-dev 2004-12-04 23:02:15 UTC
Oops, sorry, I meant '<automake-1.8' , which should emerge the latest version of automake-1.7 (I personally was having problems with 1.8 being unmerged...)
Comment 5 Mihai Limbasan 2004-12-08 02:37:55 UTC
Copy the ebuild and the patches to your overlay and change WANT_AUTOMAKE=1.7 to WANT_AUTOMAKE=1.8 - that will solve things.
If you don't know how to do that, make sure that PORTDIR_OVERLAY is set in your make.conf (edit it and uncomment the corresponding line) then enter the following commands in sequence:

source /etc/make.conf
mkdir -p ${PORTDIR_OVERLAY}/sys-boot/grub/files
sed -e "s:WANT_AUTOMAKE=1.7:WANT_AUTOMAKE=1.8:g" < ${PORTDIR}/sys-boot/grub/grub-0.95.20040823.ebuild > ${PORTDIR_OVERLAY}/sys-boot/grub/grub-0.95.20040823.ebuild
cp ${PORTDIR}/sys-boot/grub/files/grub-0.95.20040823-warnings.patch ${PORTDIR_OVERLAY}/sys-boot/grub/files
cp ${PORTDIR}/sys-boot/grub/files/splash.xpm.gz ${PORTDIR_OVERLAY}/sys-boot/grub/files
sed -e 
ebuild ${PORTDIR_OVERLAY}/sys-boot/grub/grub-0.95.20040823.ebuild digest

That will fix the automake problems and will allow you to emerge grub 0.95 just fine.
Comment 6 Mihai Limbasan 2004-12-08 02:38:50 UTC
Argh. Ignore the second sed -e line above. I should doublecheck things before pushing buttons...
Comment 7 Jory A. Pratt 2004-12-12 15:03:13 UTC
this is terrible the community is going to hell this bug is verified and has the resolution sitting here instead of in the portage tree. devs need to really step up and start updating the tree so ppl dont have to hunt for fixes I have seen these problems the last few weeks all cause devs are not updating like they need to be I think it is time we find some bug devs to find bugs that should be resolved and add to portage so ppl dont have to hunt down a fix like this in the middle of there installs.
Comment 8 steveb 2004-12-12 21:54:26 UTC
Jory A. Pratt: Stop complaining! If you realy want to help, then please request to add you as a Gentoo developer and then help them out with your time and your knowledge to get things faster done.
Comment 9 Simon Stelling (RETIRED) gentoo-dev 2004-12-20 12:00:36 UTC
fixed now.

reply to comment #7:

i'm sure everybody is doing his best, but there are lots of bugs, not only this one. also, many devs have other things to do (family, work, whatever) so please be insightful. and never forget: you didn't pay a single cent, so you can't expect anything. that doesn't mean you're not welcome to give useful information about bugs and/or solutions

as steveb said, if you think those stupid devs aren't doing their homework, become one and change your mind ;)