Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 730846 - mail-filter/procmail calls cc directly
Summary: mail-filter/procmail calls cc directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mikle Kolyada
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-07-05 08:27 UTC by Agostino Sarubbo
Modified: 2020-07-16 08:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,9.72 KB, text/plain)
2020-07-05 08:27 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-07-05 08:27:00 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: mail-filter/procmail calls cc directly.
Discovered on: amd64

NOTE:
As per QA policy, toolchain tools must not be called directly because they can cause issue in cross-compiling and because is not possible use a different CC implementation (like clang). To reproduce, please use sys-devel/gcc-config[-native-symlinks], sys-devel/binutils-config[-native-symlinks] and set the CC variable to x86_64-pc-linux-gnu-gcc.
Comment 1 Agostino Sarubbo gentoo-dev 2020-07-05 08:27:13 UTC
Created attachment 647722 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-07-16 08:45:26 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a62b633c5c4c9963162355f1be96c7c28ced1f9b

commit a62b633c5c4c9963162355f1be96c7c28ced1f9b
Author:     Stephan Hartmann <stha09@googlemail.com>
AuthorDate: 2020-07-05 11:38:20 +0000
Commit:     Mikle Kolyada <zlogene@gentoo.org>
CommitDate: 2020-07-16 08:45:21 +0000

    mail-filter/procmail: fix building with clang
    
    Closes: https://bugs.gentoo.org/730846
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Stephan Hartmann <stha09@googlemail.com>
    Closes: https://github.com/gentoo/gentoo/pull/16595
    Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>

 mail-filter/procmail/procmail-3.22-r14.ebuild | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)