Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 730456 - =dev-java/ant-1.10.8 version bump
Summary: =dev-java/ant-1.10.8 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Java team
URL:
Whiteboard:
Keywords: EBUILD, PATCH
Depends on:
Blocks:
 
Reported: 2020-07-02 15:34 UTC by Alex Barker
Modified: 2020-07-20 08:53 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ant-1.10.8-gentoo.tar.bz2 (ant-1.10.8-gentoo.tar.bz2,6.37 KB, application/x-bzip)
2020-07-02 15:35 UTC, Alex Barker
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Barker 2020-07-02 15:34:16 UTC
New minor revision update for Apache Ant.  Updated ebuilds available at https://github.com/kwhat/gentoo-what4-java-overlay

I made a small patch update to the launcher.  Currently it warns about tools.jar missing on JDK 11.

Reproducible: Always
Comment 1 Alex Barker 2020-07-02 15:35:55 UTC
Created attachment 647362 [details]
ant-1.10.8-gentoo.tar.bz2
Comment 2 Miroslav Šulc gentoo-dev 2020-07-05 11:17:20 UTC
i'm just doing the bump. what is the purpose of deleting that elif branch? i suppose it still should be there for any jdk:8 in case it fails for some reason.
Comment 3 Larry the Git Cow gentoo-dev 2020-07-05 11:20:48 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=f5fa3822cbaabb45aead683272e47c4f87d9a72b

commit f5fa3822cbaabb45aead683272e47c4f87d9a72b
Author:     Miroslav Šulc <fordfrog@gentoo.org>
AuthorDate: 2020-07-05 11:05:33 +0000
Commit:     Miroslav Šulc <fordfrog@gentoo.org>
CommitDate: 2020-07-05 11:20:27 +0000

    dev-java/ant: bump to 1.10.8
    
    Bug: https://bugs.gentoo.org/730456
    Package-Manager: Portage-2.3.103, Repoman-2.3.23
    Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>

 dev-java/ant/ant-1.10.8.ebuild | 47 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 47 insertions(+)
Comment 4 Alex Barker 2020-07-06 15:16:53 UTC
(In reply to Miroslav Šulc from comment #2)
> i'm just doing the bump. what is the purpose of deleting that elif branch? i
> suppose it still should be there for any jdk:8 in case it fails for some
> reason.

Hi,

The elif stuff seems to be a gentoo addition that doesn't apply to JDK >= 9.  It could be loosened up instead of removed, just not sure how we want to do that.
Comment 5 Alex Barker 2020-07-06 17:00:43 UTC
It looks like you already bumped 1.10.8 and removed that warning so this can be closed along with 682136.  Thanks!
Comment 6 Miroslav Šulc gentoo-dev 2020-07-06 17:13:50 UTC
i really did the bump to 1.10.8 but i did not remove the warning and that's the reason i left this bug open. this is the code from ant script:

if [[ -n "${TOOLS_JAR}" ]] ; then
  LOCALCLASSPATH="$LOCALCLASSPATH:${TOOLS_JAR}"
elif [[ $(java-config -f) != apple-jdk-bin* ]] ; then
  echo "Warning: Unable to determine tools.jar location."
  echo "  If build fails because sun.* classes could not be found,"
  echo "  Make sure you are using a JDK, not JRE as your user/system VM."
  echo "  and that you have java-config version 2.0.30 or above installed."
fi

if i get it right, it will still show the warning for jdk:11. not sure if that's how it should be or not. maybe we just need to restrict the check to jdk:8, but i need a confirmation from someone who knows it for sure :-)
Comment 7 Miroslav Šulc gentoo-dev 2020-07-20 08:53:24 UTC
bump is done and now already stable. for the warning message please file a new bug if needed