Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 730176 - gnome-base/libglade-2.6.4-r3 stabilization (drop python2_7, EAPI-6)
Summary: gnome-base/libglade-2.6.4-r3 stabilization (drop python2_7, EAPI-6)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: CC-ARCHES, PullRequest
Depends on:
Blocks: py3-tracker, python-3-incompatible EAPI5Removal
  Show dependency tree
 
Reported: 2020-06-29 19:37 UTC by Azamat H. Hackimov
Modified: 2020-08-05 14:18 UTC (History)
0 users

See Also:
Package list:
gnome-base/libglade-2.6.4-r3
Runtime testing required: ---
nattka: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Azamat H. Hackimov 2020-06-29 19:37:07 UTC
gnome-base/libglade requires python2_7 only for ancient libglade-convert tool that required only for very old packages that not migrated to gnome-base/libglade-2. No need to keep it in ebuild. Any package that depends on gnome-base/libglade[tools], should be updated or treecleaned.

Reproducible: Always
Comment 1 Andreas Sturmlechner gentoo-dev 2020-06-29 19:56:41 UTC
$ grep -R libglade.*tools

Apparently there are none.
Comment 2 Andreas Sturmlechner gentoo-dev 2020-06-29 20:40:32 UTC
Actually whole package (ebuild and upstream) looks a bit crusty. Do we need another tracker? ;)
Comment 3 Azamat H. Hackimov 2020-06-29 21:05:28 UTC
Yeah, I'm worked on deleting of python2 and totally rewrote whole ebuild...
Anyway, here PR https://github.com/gentoo/gentoo/pull/16498
Comment 4 Andreas Sturmlechner gentoo-dev 2020-06-30 07:25:46 UTC
(In reply to Azamat H. Hackimov from comment #3)
> Anyway, here PR https://github.com/gentoo/gentoo/pull/16498
No DEPEND?

I also see no revdeps on it, so IUSE=static-libs could be dropped, but it needs to be acked by gnome proj...
Comment 5 Azamat H. Hackimov 2020-06-30 15:25:42 UTC
Added DEPEND.

Not sure about static-libs.
Comment 6 Larry the Git Cow gentoo-dev 2020-07-29 19:56:50 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=9aa6c8609b1e4635399ff79c297058bee72842a4

commit 9aa6c8609b1e4635399ff79c297058bee72842a4
Author:     Mart Raudsepp <leio@gentoo.org>
AuthorDate: 2020-07-29 19:45:53 +0000
Commit:     Mart Raudsepp <leio@gentoo.org>
CommitDate: 2020-07-29 19:56:29 +0000

    gnome-base/libglade: drop legacy IUSE=tools, EAPI-6 bump
    
    * USE=tools was for libglade-convert, which was about converting from
      an ancient libglade UI file to a big less ancient format UI file.
      It uses python2 and isn't useful for conversion to GtkBuilder, so
      just drop it.
    * Port to EAPI-6
    * Use GNOME2_EAUTORECONF to not need AT_NOELIBTOOLIZE=yes hacks
    * Drop DISABLE_DEPRECATED sedding - gnome2.eclass takes care of it
    * Move configure.in to configure.ac to silence QA warning
    * Add missing gtk-doc-am depend, needed due to eautoreconf; it was
      probably fine, as the tarball contains a copy, but better to ensure
      up to date is available on system.
    
    Bug: https://bugs.gentoo.org/730176
    Package-Manager: Portage-2.3.84, Repoman-2.3.20
    Signed-off-by: Mart Raudsepp <leio@gentoo.org>

 gnome-base/libglade/libglade-2.6.4-r3.ebuild | 91 ++++++++++++++++++++++++++++
 1 file changed, 91 insertions(+)
Comment 7 Sam James archtester gentoo-dev Security 2020-07-30 04:40:02 UTC
arm64 stable
Comment 8 Sam James archtester gentoo-dev Security 2020-07-30 19:51:36 UTC
amd64 stable
Comment 9 Sam James archtester gentoo-dev Security 2020-07-30 20:11:15 UTC
arm stable
Comment 10 Rolf Eike Beer archtester 2020-08-01 19:25:21 UTC
sparc stable
Comment 11 Agostino Sarubbo gentoo-dev 2020-08-05 14:02:52 UTC
ppc stable
Comment 12 Agostino Sarubbo gentoo-dev 2020-08-05 14:04:32 UTC
ppc64 stable
Comment 13 Agostino Sarubbo gentoo-dev 2020-08-05 14:18:50 UTC
x86 stable. Closing.