Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 730006 - dev-texlive/texlive-luatex-2020-r1 : file collision with dev-texlive/texlive-fontsrecommended-2020
Summary: dev-texlive/texlive-luatex-2020-r1 : file collision with dev-texlive/texlive-...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 3 votes (vote)
Assignee: Alexis Ballier
URL:
Whiteboard:
Keywords:
: 729994 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-06-28 12:15 UTC by Toralf Förster
Modified: 2020-06-29 16:37 UTC (History)
22 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.43 KB, text/plain)
2020-06-28 12:15 UTC, Toralf Förster
Details
dev-texlive:texlive-luatex-2020-r1:20200628-111900.log (dev-texlive:texlive-luatex-2020-r1:20200628-111900.log,79.59 KB, text/plain)
2020-06-28 12:15 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,247.58 KB, text/plain)
2020-06-28 12:15 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,18.49 KB, application/x-bzip)
2020-06-28 12:15 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,8.32 KB, application/x-bzip)
2020-06-28 12:15 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-06-28 12:15:22 UTC
  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop_gnome_systemd-20200621-221934

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-8.3.1
 [2] x86_64-pc-linux-gnu-10.1.0 *
clang version 10.0.0 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/10/bin
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.7
  [2]   python3.9 (fallback)
  [3]   python3.8 (fallback)
  [4]   python3.6 (fallback)
  [5]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.44.1 *
The following VMs are available for generation-2:
*)	IcedTea JDK 3.16.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.0.2

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Sun 28 Jun 2020 11:05:21 AM UTC

emerge -qpvO dev-texlive/texlive-luatex
[ebuild  N    ] dev-texlive/texlive-luatex-2020-r1  USE="-doc -source"
Comment 1 Toralf Förster gentoo-dev 2020-06-28 12:15:25 UTC
Created attachment 646944 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-06-28 12:15:28 UTC
Created attachment 646946 [details]
dev-texlive:texlive-luatex-2020-r1:20200628-111900.log
Comment 3 Toralf Förster gentoo-dev 2020-06-28 12:15:31 UTC
Created attachment 646948 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2020-06-28 12:15:33 UTC
Created attachment 646950 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-06-28 12:15:36 UTC
Created attachment 646952 [details]
logs.tbz2
Comment 6 Dennis Schridde 2020-06-28 12:37:55 UTC
Duplicate of bug #729994.
Comment 7 Andreas Sturmlechner gentoo-dev 2020-06-28 19:08:45 UTC
*** Bug 729994 has been marked as a duplicate of this bug. ***
Comment 8 Till Schäfer 2020-06-29 07:41:53 UTC
this also affects stable and previous luatex was removed form tree. Thus, there is no easy workaround.
Comment 9 Michelangelo Scopelliti 2020-06-29 08:45:15 UTC
(In reply to Till Schäfer from comment #8)
> this also affects stable and previous luatex was removed form tree. Thus,
> there is no easy workaround.

'lm' is already in TEXLIVE_MODULE_CONTENTS of texlive-fontsrecommended, hence the collision.
Comment 10 Gleb 2020-06-29 08:48:50 UTC
Yeah, the issue was introduced  in this commit:
https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=27015991968734cc06e2c3f18ce4730f46dfeef0

Can someone revert it?
Comment 11 jamesjames 2020-06-29 08:49:28 UTC
as a quick workaround

1) nano /usr/portage/dev-texlive/texlive-luatex/texlive-luatex-2020-r1.ebuild

2) in TEXLIVE_MODULE_CONTENTS  delete " lm "   

3) ebuild /usr/portage/dev-texlive/texlive-luatex/texlive-luatex-2020-r1.ebuild digest

4) emerge dev-texlive/texlive-luatex
Comment 12 Larry the Git Cow gentoo-dev 2020-06-29 09:34:46 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=1b3e9353ac014fb3601b7351d89accf3e73d1321

commit 1b3e9353ac014fb3601b7351d89accf3e73d1321
Author:     Mikle Kolyada <zlogene@gentoo.org>
AuthorDate: 2020-06-29 09:33:10 +0000
Commit:     Mikle Kolyada <zlogene@gentoo.org>
CommitDate: 2020-06-29 09:34:41 +0000

    dev-texlive/texlive-luatex: add fontsrecommended dep
    
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=730006
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>

 dev-texlive/texlive-luatex/Manifest                                    | 1 -
 .../{texlive-luatex-2020-r1.ebuild => texlive-luatex-2020-r2.ebuild}   | 3 ++-
 2 files changed, 2 insertions(+), 2 deletions(-)
Comment 13 Larry the Git Cow gentoo-dev 2020-06-29 09:36:26 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=73f8e6f7a42d87884a3946d5a97e7195001b72a3

commit 73f8e6f7a42d87884a3946d5a97e7195001b72a3
Author:     Ulrich Müller <ulm@gentoo.org>
AuthorDate: 2020-06-29 09:35:10 +0000
Commit:     Ulrich Müller <ulm@gentoo.org>
CommitDate: 2020-06-29 09:36:03 +0000

    dev-texlive/texlive-luatex: [QA] Fix collision with fontsrecommended.
    
    Bug: https://bugs.gentoo.org/727334
    Closes: https://bugs.gentoo.org/730006
    Package-Manager: Portage-2.3.103, Repoman-2.3.23
    Signed-off-by: Ulrich Müller <ulm@gentoo.org>

 dev-texlive/texlive-luatex/texlive-luatex-2020-r2.ebuild | 1 +
 1 file changed, 1 insertion(+)
Comment 14 Till Schäfer 2020-06-29 12:31:25 UTC
(In reply to Larry the Git Cow from comment #13)
> The bug has been closed via the following commit(s):
> 
> https://gitweb.gentoo.org/repo/gentoo.git/commit/
> ?id=73f8e6f7a42d87884a3946d5a97e7195001b72a3
> 
> commit 73f8e6f7a42d87884a3946d5a97e7195001b72a3
> Author:     Ulrich Müller <ulm@gentoo.org>
> AuthorDate: 2020-06-29 09:35:10 +0000
> Commit:     Ulrich Müller <ulm@gentoo.org>
> CommitDate: 2020-06-29 09:36:03 +0000
> 
>     dev-texlive/texlive-luatex: [QA] Fix collision with fontsrecommended.
>     
>     Bug: https://bugs.gentoo.org/727334
>     Closes: https://bugs.gentoo.org/730006
>     Package-Manager: Portage-2.3.103, Repoman-2.3.23
>     Signed-off-by: Ulrich Müller <ulm@gentoo.org>
> 
>  dev-texlive/texlive-luatex/texlive-luatex-2020-r2.ebuild | 1 +
>  1 file changed, 1 insertion(+)

The dependency is now present two times in RDEPEND


 DEPEND=">=dev-texlive/texlive-basic-2020
+>=dev-texlive/texlive-fontsrecommended-2020
 "
 RDEPEND="${DEPEND} dev-texlive/texlive-latexrecommended
 dev-texlive/texlive-fontsrecommended