Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 729530 - app-text/cuneiform-1.1.0-r3: ordered comparison between pointer and zero ('CEDSection *' and 'int')
Summary: app-text/cuneiform-1.1.0-r3: ordered comparison between pointer and zero ('CE...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-25 07:59 UTC by Agostino Sarubbo
Modified: 2021-02-12 13:44 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,362.01 KB, text/plain)
2020-06-25 07:59 UTC, Agostino Sarubbo
Details
other.tar.bz2 (other.tar.bz2,4.23 KB, application/x-bzip-compressed-tar)
2020-06-25 07:59 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-06-25 07:59:12 UTC
@@This is an auto-filed bug@@
Feel free to change the summary at your convenience.

Issue: app-text/cuneiform fails to compile.
Discovered on: amd64

NOTE:
If yout think this issue is related to clang/llvm toolchain, please block bug 408963. If you need further logs, feel free to ask.
Comment 1 Agostino Sarubbo gentoo-dev 2020-06-25 07:59:17 UTC
Created attachment 646244 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2020-06-25 07:59:19 UTC
Created attachment 646246 [details]
other.tar.bz2

other logs
Comment 3 Jonas Stein gentoo-dev 2020-12-20 13:25:44 UTC
is it a duplicate of 707636?
Comment 4 Jakov Smolic 2021-01-25 07:54:38 UTC
(In reply to Jonas Stein from comment #3)
> is it a duplicate of 707636?

No, this seems to be a different issue
Comment 5 Larry the Git Cow gentoo-dev 2021-02-12 13:44:57 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=e81771fa9ff1f899e22c045f20cb724815db8a43

commit e81771fa9ff1f899e22c045f20cb724815db8a43
Author:     Jakov Smolic <jakov.smolic@sartura.hr>
AuthorDate: 2021-02-11 19:34:23 +0000
Commit:     Ben Kohler <bkohler@gentoo.org>
CommitDate: 2021-02-12 13:44:36 +0000

    app-text/cuneiform: Port to EAPI 7
    
    * Apply gcc-10 workaround (dead upstream)
    
    Closes: https://bugs.gentoo.org/729530
    Closes: https://bugs.gentoo.org/760830
    Closes: https://bugs.gentoo.org/707636
    Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr>
    Signed-off-by: Ben Kohler <bkohler@gentoo.org>

 app-text/cuneiform/cuneiform-1.1.0-r3.ebuild       | 40 ++++++++++++----------
 ...-assert.diff => cuneiform-1.1.0-c-assert.patch} |  6 +---
 .../cuneiform-1.1.0-fix_buffer_overflow.patch      |  3 --
 .../cuneiform-1.1.0-fix_buffer_overflow_2.patch    |  9 ++---
 .../cuneiform/files/cuneiform-1.1.0-gcc6.patch     |  1 -
 .../cuneiform/files/cuneiform-1.1.0-gcc7.patch     | 25 ++++++--------
 ...k.diff => cuneiform-1.1.0-graphicsmagick.patch} |  3 --
 .../{libm.diff => cuneiform-1.1.0-libm.patch}      |  3 --
 .../cuneiform/files/cuneiform-1.1.0-typos.patch    |  1 -
 9 files changed, 35 insertions(+), 56 deletions(-)