Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 729510 - sys-libs/db fails to compile with lld
Summary: sys-libs/db fails to compile with lld
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks: systemwide-clang
  Show dependency tree
 
Reported: 2020-06-25 07:55 UTC by Agostino Sarubbo
Modified: 2021-01-24 17:41 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,12.77 KB, text/plain)
2020-06-25 07:55 UTC, Agostino Sarubbo
Details
other.tar.bz2 (other.tar.bz2,4.38 KB, application/x-bzip-compressed-tar)
2020-06-25 07:55 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-06-25 07:55:45 UTC
@@This is an auto-filed bug@@
Feel free to change the summary at your convenience.

Issue: sys-libs/db fails to compile.
Discovered on: amd64

NOTE:
If yout think this issue is related to clang/llvm toolchain, please block bug 408963. If you need further logs, feel free to ask.
Comment 1 Agostino Sarubbo gentoo-dev 2020-06-25 07:55:51 UTC
Created attachment 646216 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2020-06-25 07:55:53 UTC
Created attachment 646218 [details]
other.tar.bz2

other logs
Comment 3 Theo Anderson 2021-01-18 05:07:58 UTC
Duplicate of https://bugs.gentoo.org/595108
Comment 4 Larry the Git Cow gentoo-dev 2021-01-24 17:41:23 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=811c7e411281c4c911890175b7615cb1971851a7

commit 811c7e411281c4c911890175b7615cb1971851a7
Author:     Theo Anderson <telans@posteo.de>
AuthorDate: 2021-01-23 10:24:20 +0000
Commit:     Mike Gilbert <floppym@gentoo.org>
CommitDate: 2021-01-24 17:39:42 +0000

    sys-libs/db: use tc-ld-force-bfd instead of tc-ld-disable-gold
    
    ld.bfd is forced due to sys-libs/db requiring
    the --default-symver ldflag, which is not present in either
    ld.gold or ld.lld
    
    Closes: https://bugs.gentoo.org/595108
    Closes: https://bugs.gentoo.org/729510
    Package-Manager: Portage-3.0.14, Repoman-3.0.2
    Signed-off-by: Theo Anderson <telans@posteo.de>
    Signed-off-by: Mike Gilbert <floppym@gentoo.org>
    Closes: https://github.com/gentoo/gentoo/pull/19171

 sys-libs/db/db-18.1.32.ebuild   | 4 ++--
 sys-libs/db/db-18.1.40.ebuild   | 4 ++--
 sys-libs/db/db-4.8.30-r3.ebuild | 4 ++--
 sys-libs/db/db-4.8.30-r4.ebuild | 4 ++--
 sys-libs/db/db-5.1.29-r2.ebuild | 4 ++--
 sys-libs/db/db-5.3.28-r2.ebuild | 4 ++--
 sys-libs/db/db-5.3.28-r4.ebuild | 2 +-
 sys-libs/db/db-5.3.28-r5.ebuild | 4 ++--
 sys-libs/db/db-6.0.35-r2.ebuild | 4 ++--
 sys-libs/db/db-6.0.35-r3.ebuild | 4 ++--
 sys-libs/db/db-6.1.38.ebuild    | 4 ++--
 sys-libs/db/db-6.2.38.ebuild    | 2 +-
 12 files changed, 22 insertions(+), 22 deletions(-)