Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 729308 - ERROR: dev-libs/boost-1.73.0::gentoo failed (compile phase): * (no error message)
Summary: ERROR: dev-libs/boost-1.73.0::gentoo failed (compile phase): * (no error m...
Status: RESOLVED DUPLICATE of bug 724314
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: David Seifert
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-23 13:06 UTC by user.light.man
Modified: 2020-06-25 10:03 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/tmp/portage/dev-libs/boost-1.73.0/temp/build.log (logs.txt,341.37 KB, text/plain)
2020-06-23 13:11 UTC, user.light.man
Details

Note You need to log in before you can comment on or make changes to this bug.
Description user.light.man 2020-06-23 13:06:49 UTC
stack smashing detected ***: terminated
In file included from libs/serialization/src/xml_grammar.cpp:64:
libs/serialization/src/basic_xml_grammar.ipp: In constructor ‘boost::archive::basic_xml_grammar<CharType>::basic_xml_grammar() [with CharType = char]’:
libs/serialization/src/basic_xml_grammar.ipp:426:9: internal compiler error: Aborted

Reproducible: Always

Steps to Reproduce:
1.emerge -av boost
2.wait



emerge --info '=dev-libs/boost-1.73.0::gentoo'
Portage 2.3.100 (python 3.8.3-final-0, default/linux/amd64/17.1/desktop, gcc-10.1.0, glibc-2.31-r3, 5.6.15-gentoo-x86_64 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-5.6.15-gentoo-x86_64-x86_64-AMD_Ryzen_5_2500U_with_Radeon_Vega_Mobile_Gfx-with-glibc2.2.5
KiB Mem:     7082288 total,   1240372 free
KiB Swap:    2069824 total,   2067776 free
Timestamp of repository gentoo: Sun, 31 May 2020 11:00:01 +0000
Head commit of repository gentoo: f20ea9b282c4957ccfed9e31691d29fcb747219f
sh bash 5.0_p17
ld GNU ld (Gentoo 2.34 p4) 2.34.0
app-shells/bash:          5.0_p17::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.30.2-r2::gentoo
dev-lang/python:          2.7.18::gentoo, 3.6.10-r2::gentoo, 3.7.7-r2::gentoo, 3.8.3::gentoo, 3.9.0_beta1::gentoo
dev-util/cmake:           3.17.3::gentoo
sys-apps/baselayout:      2.7::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.16.2::gentoo
sys-devel/binutils:       2.34-r1::gentoo
sys-devel/gcc:            10.1.0::gentoo
sys-devel/gcc-config:     2.3::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.6::gentoo (virtual/os-headers)
sys-libs/glibc:           2.31-r3::gentoo
Repositories:

gentoo
    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts: 
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-jobs: 1

localrepo
    location: /var/db/repos/localrepo
    masters: gentoo

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/cache/distfiles"
EMERGE_DEFAULT_OPTS=" --jobs=8 --load-average=8"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-march=native -O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="https://gentoo-mirror.alexxy.name/ http://gentoo-mirror.alexxy.name/ http://gentoo.bloodhost.ru/ ftp://gentoo.bloodhost.ru/ rsync://gentoo.bloodhost.ru/gentoo-distfiles https://mirror.yandex.ru/gentoo-distfiles/ http://mirror.yandex.ru/gentoo-distfiles/ ftp://mirror.yandex.ru/gentoo-distfiles/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb branding bzip2 cairo cdda cdr cli crypt cups dbus dri dts dvd dvdr elogind emboss encode exif flac fortran gdbm gif gpm gtk iconv icu ipv6 jpeg lcms ldap libnotify libtirpc mad mng mp3 mp4 mpeg multilib ncurses nls nptl ogg openmp pam pango pcre pdf png policykit ppds qt5 readline sdl seccomp spell split-usr ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="64 32" ADA_TARGET="gnat_2018" ALSA_CARDS="hda_intel" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sha sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3" ELIBC="glibc" INPUT_DEVICES="synaptics mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_7" PYTHON_TARGETS="python3_7 python3_8" RUBY_TARGETS="ruby24 ruby25" USERLAND="GNU" VIDEO_CARDS="amdgpu radeonsi" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

dev-libs/boost-1.73.0::gentoo was built with the following:
USE="bzip2 icu nls threads zlib -context -debug -doc -lzma -mpi -numpy -python -static-libs -tools -zstd" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python3_6 python3_7 python3_8 -python2_7"
CXXFLAGS="-march=native -O2 -pipe -std=c++14"
Comment 1 user.light.man 2020-06-23 13:11:46 UTC
Created attachment 645854 [details]
/var/tmp/portage/dev-libs/boost-1.73.0/temp/build.log
Comment 2 josef.95 2020-06-23 13:17:51 UTC
Hi, I think it is probably a duplicate of bug 724314
Comment 3 user.light.man 2020-06-23 13:40:50 UTC
(In reply to josef.95 from comment #2)
> Hi, I think it is probably a duplicate of bug 724314

Hi, thanks!
Comment 4 Brian Evans Gentoo Infrastructure gentoo-dev 2020-06-23 13:52:55 UTC

*** This bug has been marked as a duplicate of bug 724314 ***
Comment 5 Sergei Trofimovich (RETIRED) gentoo-dev 2020-06-23 22:35:35 UTC
I'm still struggling to get the environment where I can reproduce the failure. Can you expand -march=native for me? The followig command should print the diff:

$ arch=znver1; for t in param target; do cmd="gcc -Q -O2 -march=$arch --help=$t"; diff -U0 <(LANG=C $cmd) <(LANG=C $cmd -march=native); done
Comment 6 user.light.man 2020-06-24 08:41:56 UTC
the output:

--- /dev/fd/63	2020-06-24 11:39:18.884010642 +0300
+++ /dev/fd/62	2020-06-24 11:39:18.884010642 +0300
@@ -70,2 +70,2 @@
-  --param=l1-cache-line-size= 		32
-  --param=l1-cache-size=      		64
+  --param=l1-cache-line-size= 		64
+  --param=l1-cache-size=      		32
--- /dev/fd/61	2020-06-24 11:39:18.901010642 +0300
+++ /dev/fd/60	2020-06-24 11:39:18.901010642 +0300
@@ -12 +12 @@
-  -mabm                       		[disabled]
+  -mabm                       		[enabled]
@@ -15,2 +15,2 @@
-  -madx                       		[disabled]
-  -maes                       		[disabled]
+  -madx                       		[enabled]
+  -maes                       		[enabled]
@@ -26,2 +26,2 @@
-  -mavx                       		[disabled]
-  -mavx2                      		[disabled]
+  -mavx                       		[enabled]
+  -mavx2                      		[enabled]
@@ -48,2 +48,2 @@
-  -mbmi                       		[disabled]
-  -mbmi2                      		[disabled]
+  -mbmi                       		[enabled]
+  -mbmi2                      		[enabled]
@@ -55 +55 @@
-  -mclflushopt                		[disabled]
+  -mclflushopt                		[enabled]
@@ -57 +57 @@
-  -mclzero                    		[disabled]
+  -mclzero                    		[enabled]
@@ -61 +61 @@
-  -mcx16                      		[disabled]
+  -mcx16                      		[enabled]
@@ -65 +65 @@
-  -mf16c                      		[disabled]
+  -mf16c                      		[enabled]
@@ -70 +70 @@
-  -mfma                       		[disabled]
+  -mfma                       		[enabled]
@@ -76 +76 @@
-  -mfsgsbase                  		[disabled]
+  -mfsgsbase                  		[enabled]
@@ -79 +79 @@
-  -mfxsr                      		[disabled]
+  -mfxsr                      		[enabled]
@@ -99 +99 @@
-  -mlzcnt                     		[disabled]
+  -mlzcnt                     		[enabled]
@@ -104,2 +104,2 @@
-  -mmmx                       		[disabled]
-  -mmovbe                     		[disabled]
+  -mmmx                       		[enabled]
+  -mmovbe                     		[enabled]
@@ -111 +111 @@
-  -mmwaitx                    		[disabled]
+  -mmwaitx                    		[enabled]
@@ -117 +117 @@
-  -mno-sse4                   		[enabled]
+  -mno-sse4                   		[disabled]
@@ -123 +123 @@
-  -mpclmul                    		[disabled]
+  -mpclmul                    		[enabled]
@@ -127 +127 @@
-  -mpopcnt                    		[disabled]
+  -mpopcnt                    		[enabled]
@@ -132 +132 @@
-  -mprfchw                    		[disabled]
+  -mprfchw                    		[enabled]
@@ -136,2 +136,2 @@
-  -mrdrnd                     		[disabled]
-  -mrdseed                    		[disabled]
+  -mrdrnd                     		[enabled]
+  -mrdseed                    		[enabled]
@@ -146 +146 @@
-  -msahf                      		[disabled]
+  -msahf                      		[enabled]
@@ -148 +148 @@
-  -msha                       		[disabled]
+  -msha                       		[enabled]
@@ -152,2 +152,2 @@
-  -msse                       		[disabled]
-  -msse2                      		[disabled]
+  -msse                       		[enabled]
+  -msse2                      		[enabled]
@@ -155,5 +155,5 @@
-  -msse3                      		[disabled]
-  -msse4                      		[disabled]
-  -msse4.1                    		[disabled]
-  -msse4.2                    		[disabled]
-  -msse4a                     		[disabled]
+  -msse3                      		[enabled]
+  -msse4                      		[enabled]
+  -msse4.1                    		[enabled]
+  -msse4.2                    		[enabled]
+  -msse4a                     		[enabled]
@@ -162 +162 @@
-  -mssse3                     		[disabled]
+  -mssse3                     		[enabled]
@@ -175 +175 @@
-  -mtune=                     		
+  -mtune=                     		znver1
@@ -186,4 +186,4 @@
-  -mxsave                     		[disabled]
-  -mxsavec                    		[disabled]
-  -mxsaveopt                  		[disabled]
-  -mxsaves                    		[disabled]
+  -mxsave                     		[enabled]
+  -mxsavec                    		[enabled]
+  -mxsaveopt                  		[enabled]
+  -mxsaves                    		[enabled]
Comment 7 Sergei Trofimovich (RETIRED) gentoo-dev 2020-06-24 21:13:36 UTC
(In reply to user.light.man from comment #6)
> the output:

Thank you! Yeah, the machine looks the same as in bug #724314. But the settings are different. It's both reassuring that bug is somehow specific to znver1 (and to kernel version or linker) and worrying that I can't reproduce it on znver2 no matter what I pass to C*FLAGS.
Comment 8 user.light.man 2020-06-25 10:03:03 UTC
I downgraded gcc to gcc --version
gcc (Gentoo 9.3.0-r1 p3) 9.3.0
and rebuilt boost successfully!
dev-libs/boost-1.73.0