Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 729294 - app-misc/g15daemon calls cc directly
Summary: app-misc/g15daemon calls cc directly
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Deadline: 2020-10-09
Assignee: Robin Johnson
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-06-23 11:47 UTC by Agostino Sarubbo
Modified: 2020-09-09 12:56 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,43.96 KB, text/plain)
2020-06-23 11:47 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-06-23 11:47:39 UTC
@@This is an auto-filed bug@@
If you think that a different summary clarifies the issue better, feel free to change it.

Issue: app-misc/g15daemon calls cc directly.
Discovered on: amd64

NOTE:
As per QA policy, toolchain tools must not be called directly because they can cause issue in cross-compiling and because is not possible use a different CC implementation (like clang). To reproduce, please use sys-devel/gcc-config[-native-symlinks], sys-devel/binutils-config[-native-symlinks] and set the CC variable to x86_64-pc-linux-gnu-gcc.
Comment 1 Agostino Sarubbo gentoo-dev 2020-06-23 11:47:45 UTC
Created attachment 645848 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-09-09 12:29:34 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=32f13dc9e4d6a8643ef98cc5f4fb6b45532dd7fd

commit 32f13dc9e4d6a8643ef98cc5f4fb6b45532dd7fd
Author:     Lars Wendler <polynomial-c@gentoo.org>
AuthorDate: 2020-09-09 11:12:50 +0000
Commit:     Lars Wendler <polynomial-c@gentoo.org>
CommitDate: 2020-09-09 12:29:21 +0000

    app-misc/g15daemon: Revbumps / ebuild overhauls
    
    - EAPI-7 bump
    - Added workaround for successful build with gcc-10 (#706712)
    - Fixed default config (#481454)
    - Fixed docdir
    - Attempt to fix direct call of CC (#729294)
    - Removed bashisms from configure
    
    Bug: https://bugs.gentoo.org/729294
    Bug: https://bugs.gentoo.org/741382
    Closes: https://bugs.gentoo.org/481454
    Closes: https://bugs.gentoo.org/706712
    Package-Manager: Portage-3.0.6, Repoman-3.0.1
    Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>

 app-misc/g15daemon/files/g15daemon-1.2.7.confd     |  2 +-
 .../files/g15daemon-1.9.5.3-avoid_bashisms.patch   | 20 ++++++++
 .../g15daemon/files/g15daemon-1.9.5.3-docdir.patch | 11 +++++
 .../g15daemon-1.9.5.3-forgotten-open-mode.patch    |  4 +-
 .../files/g15daemon-1.9.5.3-g510-keys.patch        |  5 +-
 .../files/g15daemon-1.9.5.3-overflow-fix.patch     |  4 +-
 ...5.3-r13.ebuild => g15daemon-1.9.5.3-r14.ebuild} | 48 ++++++++++---------
 app-misc/g15daemon/g15daemon-1.9.5.3-r21.ebuild    | 47 ++++++++++---------
 app-misc/g15daemon/g15daemon-9999.ebuild           | 54 +++++++++++-----------
 9 files changed, 119 insertions(+), 76 deletions(-)
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2020-09-09 12:32:33 UTC
Please test and report back if this is still happening.