Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 728500 - sci-geosciences/gmt-6.0.0 version bump
Summary: sci-geosciences/gmt-6.0.0 version bump
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sci-geo Project
URL:
Whiteboard:
Keywords: EBUILD
Depends on:
Blocks:
 
Reported: 2020-06-16 22:15 UTC by Daniel Peters
Modified: 2020-06-17 00:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
gmt-6.0.0 ebuild (gmt-6.0.0-r1.ebuild,2.97 KB, text/plain)
2020-06-16 22:15 UTC, Daniel Peters
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Peters 2020-06-16 22:15:39 UTC
Created attachment 645012 [details]
gmt-6.0.0 ebuild

sci-geosciences/gmt-6.0.0 is available. I include ebuild which works for me with following changes to previous version:
- Homepage moved to https://www.generic-mapping-tools.org/
- SLOT="6" (but conflicts with slot 5, not sure if slotting is even useful for anyone)
- add graphicsmagick use flag and dependency
- add glib dependency for threads use flag
- drop tutorial use flag and associated code (tutorials are part of htmldoc, tutorial data is no longer included in distribution but downloaded on demand)

Maybe we should add a post-upgrade message that gmt 6 offers a new "modern mode" of usage.