Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 728318 - cross-hppa1.1-unknown-linux-gnu/binutils-2.32-r1 - ld: bucomm.o:(.bss+0x0): multiple definition of `program_name'; coffdump.o:(.bss+0x0): first defined here
Summary: cross-hppa1.1-unknown-linux-gnu/binutils-2.32-r1 - ld: bucomm.o:(.bss+0x0): m...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-06-15 06:58 UTC by Jeroen Roovers
Modified: 2020-06-15 08:14 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
cross-hppa1.1-unknown-linux-gnu:binutils-2.32-r1:20200615-021734.log.xz (cross-hppa1.1-unknown-linux-gnu:binutils-2.32-r1:20200615-021734.log.xz,40.12 KB, application/x-xz)
2020-06-15 06:58 UTC, Jeroen Roovers
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers gentoo-dev 2020-06-15 06:58:28 UTC
Created attachment 644778 [details]
cross-hppa1.1-unknown-linux-gnu:binutils-2.32-r1:20200615-021734.log.xz

Mon 15 Jun 08:57:51 CEST 2020
emerge --info =cross-hppa1.1-unknown-linux-gnu/binutils-2.32-r1
Portage 2.3.100 (python 3.6.10-final-0, default/linux/hppa/17.0, gcc-10.1.0, glibc-2.31-r5, 5.7.0-JeR-14029-gb29482fde649 parisc64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-5.7.0-JeR-14029-gb29482fde649-parisc64-PA8800_-Mako-with-gentoo-2.7
KiB Mem:     8213044 total,    460656 free
KiB Swap:    2101676 total,   2085120 free
Timestamp of repository gentoo: Mon, 15 Jun 2020 02:30:01 +0000
Head commit of repository gentoo: 870f9a5ad572bc624cde4f1cce690d6e98bac2fa
sh bash 5.0_p17
ld GNU ld (Gentoo 2.34 p4) 2.34.0
distcc[4664] (dcc_mkdir) ERROR: mkdir '/dev/shm/distcc/root/state' failed: No such file or directory [disabled]
ccache version 3.7.9 [disabled]
app-shells/bash:          5.0_p17::gentoo
dev-lang/perl:            5.30.3-r1::gentoo
dev-lang/python:          2.7.18::gentoo, 3.5.9::gentoo, 3.6.10-r2::gentoo, 3.7.7-r2::gentoo, 3.8.3::gentoo, 3.9.0_alpha6::gentoo
dev-util/ccache:          3.7.9::gentoo
dev-util/cmake:           3.17.3::gentoo
sys-apps/baselayout:      2.7::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.20::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.9.6-r3::gentoo, 1.11.6-r3::gentoo, 1.12.6::gentoo, 1.13.4-r2::gentoo, 1.14.1::gentoo, 1.15.1-r2::gentoo, 1.16.2::gentoo
sys-devel/binutils:       2.32-r1::gentoo, 2.33.1-r1::gentoo, 2.34-r1::gentoo
sys-devel/gcc:            6.5.0-r2::gentoo, 7.3.0-r6::gentoo, 8.2.0-r6::gentoo, 8.3.0-r3::gentoo, 9.2.0-r4::gentoo, 9.3.0::gentoo, 10.1.0::gentoo
sys-devel/gcc-config:     2.3::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.7::gentoo (virtual/os-headers)
sys-libs/glibc:           2.31-r5::gentoo
Repositories:

gentoo
    location: /aches/gentoo/portage
    sync-type: rsync
    sync-uri: rsync://rsync.de.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: yes
    sync-rsync-extra-opts: 

JeR
    location: /aches/gentoo/local
    masters: gentoo
    priority: -100

ACCEPT_KEYWORDS="hppa ~hppa"
ACCEPT_LICENSE="*"
CBUILD="hppa2.0-unknown-linux-gnu"
CFLAGS="-mschedule=8000 -march=2.0 -ggdb -Wall -O2 -pipe -fno-common -Wno-comment"
CHOST="hppa2.0-unknown-linux-gnu"
CONFIG_PROTECT="/etc /etc/stunnel/stunnel.conf /usr/lib/distcc/bin /usr/share/easy-rsa /usr/share/gnupg/qualified.txt /var/bind /var/www/localhost/htdocs/wordpress/wp-config.php"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.1/ext-active/ /etc/php/apache2-php7.2/ext-active/ /etc/php/apache2-php7.3/ext-active/ /etc/php/apache2-php7.4/ext-active/ /etc/php/cgi-php7.1/ext-active/ /etc/php/cgi-php7.2/ext-active/ /etc/php/cgi-php7.3/ext-active/ /etc/php/cgi-php7.4/ext-active/ /etc/php/cli-php7.1/ext-active/ /etc/php/cli-php7.2/ext-active/ /etc/php/cli-php7.3/ext-active/ /etc/php/cli-php7.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-mschedule=8000 -march=2.0 -ggdb -Wall -O2 -pipe"
DISTDIR="/aches/gentoo/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n --autounmask=n --keep-going --ignore-built-slot-operator-deps=y"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS=""
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs binpkg-multi-instance buildpkg compressdebug config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync metadata-transfer multilib-strict network-sandbox news notitles parallel-fetch preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms splitdebug strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-mschedule=8000 -march=2.0 -ggdb -Wall -O2 -pipe"
GENTOO_MIRRORS=" 	https://ftp.snt.utwente.nl/pub/os/linux/gentoo 	https://mirror.leaseweb.com/gentoo/ 	https://mirror.netcologne.de/gentoo/ "
LANG="en_GB.utf8"
LC_ALL="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -Wl,--no-keep-memory"
LINGUAS=" 	de en es fa fr it ja lt nl sv tr zh "
MAKEOPTS="-j3"
PKGDIR="/aches/gentoo/packages/karsten"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="256-color X acl alsa amr anacron apng argyllcms audit bash-completion beautifulsoup3 berkdb bfio big-endian bittorrent boost botan bzip2 cairo canberra caps cli coverage crossdev crypt cups custom-cflags cxx dane dbus declarative dirac directfb distinct-l dlz dot dri elogind emacs eselect-ldso exceptions exif expat fbcon ffmpeg filecaps firefox firmware foomaticdb fortran frontend-optional g-sorcery gbm gdbm geoip geoloc glep gles1 gles2 gost gpg gpm gsm gstreamer gtk gudev guile hddtemp hppa http2 hwdb iconv icu idn imlib inotify introspection ipv6 jadetex javascript jingle jit jpeg jpeg2k json kdrive kmod ladspa lasi launch-frontend lensfun libcaca libcanberra libevent libidn2 libopts libsoxr libusb libwww lm-sensors lm_sensors lua lzma lzo mad mng mod modplug mp3 mtp multislot multitarget munge nagios nas natspec ncurses netlink nfs nghttp3 nls nptl objc objc++ objc-gc offensive ofono-headset openexr opengl openmp openrc openvg opus oqgraph osmesa oss pam pcre pcre16 php pic pie pkcs11 png pnm policykit python qt qt3support qt4 raw readline realtime regression-test rtmp rubytests samba sbc schroedinger sctp seccomp smi snappy socks5 speex spell spidermonkey split-usr sqlite ssl svg tcl tcpd tga theora threads tiff tk tokyocabinet truetype unicode unwind v4l vala vim-syntax vorbis vpx wcwidth x264 x265 xattr xcb xft xhtml xkb xvfb xvid zlib zstd" ADA_TARGET="gnat_2018" ALSA_CARDS="ad1889 usb-audio" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="openssl" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev joystick keyboard mouse acecad aiptek calcomp citron digitaledge dmc dynapro elo2300 elographics fpit hyperpen jamstudio magellan microtouch mutouch palmax penmount spaceorb summa tek4957 tslib ur98 virtualbox libinput void" KERNEL="linux" L10N="de en es fa fr it ja lt nl sv tr zh" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_7" PYTHON_TARGETS="python2_7 python3_6 python3_7" RUBY_TARGETS="ruby24 ruby25 ruby26 ruby27" USERLAND="GNU" VIDEO_CARDS="stifb dummy" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jeroen Roovers gentoo-dev 2020-06-15 07:02:31 UTC
It looks like this was already fixed in -r2.
Comment 2 Sergei Trofimovich gentoo-dev 2020-06-15 08:14:28 UTC
Yeah, should be fixed by https://gitweb.gentoo.org/repo/gentoo.git/commit/sys-devel/binutils/binutils-2.32-r2.ebuild?id=31ea5c5ef16889c000670d48d769294823fa1cd4

Also note that sys-devel/binutils:2.32 is masked (but mechanically mask does not extend to cross-*/binutils packages). You might want to switch to newer slot version.