Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 726910 - dev-lang/xsb does not respect CFLAGS
Summary: dev-lang/xsb does not respect CFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: prolog herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: cflags
  Show dependency tree
 
Reported: 2020-06-03 10:56 UTC by Agostino Sarubbo
Modified: 2020-07-18 14:32 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,40.97 KB, text/plain)
2020-06-03 10:56 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-06-03 10:56:47 UTC
This is an auto-filed bug because dev-lang/xsb does not respect CFLAGS.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to add "-frecord-gcc-switches" to CFLAGS/CXXFLAGS/FFLAGS/FCFLAGS. If this is not something about c/c++ context see this bug as an hint to hide the QA warning (with QA_FLAGS_IGNORED) where is not possible to respect CFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2020-06-03 10:56:53 UTC
Created attachment 643226 [details]
build.log

build log and emerge --info
Comment 2 Keri Harris gentoo-dev 2020-07-18 14:32:13 UTC
This is now fixed in git with xsb-3.8.0. Thanks for reporting this bug.