Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 72690 - errors when compiling mplayer (imgresample.c)
Summary: errors when compiling mplayer (imgresample.c)
Status: VERIFIED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-11-27 22:47 UTC by Dean Pierce
Modified: 2004-11-28 23:09 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dean Pierce 2004-11-27 22:47:49 UTC
When I try to emerge mplayer, about halfway through the compile, gcc starts saying "imgresample.c:379: error: can't convert between vector values of different size"

Reproducible: Always
Steps to Reproduce:
1. emerge mplayer

Actual Results:  
It starts with..

cc -I../libvo -I../../libvo -I/usr/X11R6/include -O3 -pipe -mcpu=750
-fsigned-char -mpowerpc-gfxopt -D_REENTRANT -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2
-I/usr/lib/glib/include -I/usr/X11R6/include -DHAVE_AV_CONFIG_H -I..
-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE -c -o imgresample.o
imgresample.c 
imgresample.c: In function `v_resample16_altivec':
imgresample.c:309: error: can't convert between vector values of different size
imgresample.c:309: error: can't convert between vector values of different size
imgresample.c:309: error: can't convert between vector values of different size
imgresample.c:309: error: can't convert between vector values of different size
imgresample.c:309: error: can't convert between vector values of different size
imgresample.c:309: error: can't convert between vector values of different size
imgresample.c:309: error: can't convert between vector values of different size
imgresample.c:309: error: can't convert between vector values of different size
imgresample.c:309: error: can't convert between vector values of different size
imgresample.c:309: error: can't convert between vector values of different size
imgresample.c:309: error: can't convert between vector values of different size
imgresample.c:309: error: can't convert between vector values of different size
imgresample.c:309: error: can't convert between vector values of different size
imgresample.c:309: error: can't convert between vector values of different size
imgresample.c:312: error: can't convert between vector values of different size
imgresample.c:313: error: incompatible types in assignment
imgresample.c:348: error: can't convert between vector values of different size
imgresample.c:348: error: can't convert between vector values of different size
imgresample.c:348: error: can't convert between vector values of different size
imgresample.c:348: error: can't convert between vector values of different size
imgresample.c:348: error: can't convert between vector values of different size
...

and does that a few thousand times more at various line numbers, and then the
build crashes out with

...
imgresample.c:379: error: can't convert between vector values of different size
imgresample.c:379: error: can't convert between vector values of different size
make[1]: *** [imgresample.o] Error 1
make[1]: Leaving directory
`/var/tmp/portage/mplayer-1.0_pre5-r4/work/MPlayer-1.0pre5/libavcodec'
make: *** [libavcodec/libavcodec.a] Error 2

!!! ERROR: media-video/mplayer-1.0_pre5-r4 failed.
!!! Function src_compile, Line 441, Exitcode 2
!!! Failed to build MPlayer!
!!! If you need support, post the topmost build error, NOT this status message.


Expected Results:  
It should have compiled properly and installed mplayer

## make.conf
CHOST="powerpc-unknown-linux-gnu"
CFLAGS="-O3 -pipe -mcpu=750 -fsigned-char -mpowerpc-gfxopt"
CXXFLAGS="${CFLAGS}"
ACCEPT_KEYWORDS="~ppc"

FETCHCOMMAND='/usr/bin/proz --timeout=5 -t 3 --retry-delay=1 --no-getch -r
${URI} -P ${DISTDIR}'
FEATURES="sandbox ccache"
USE="imap xmms xvid altivec gtk2 fbcon bitmap-fonts xprint gnutls java spell
crypt ipv6 hardened"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://adelie.polymtl.ca/"
Comment 1 Chris White (RETIRED) gentoo-dev 2004-11-28 06:57:09 UTC
PPC Herd,

Thoughts on this (specifically lu_zero, since you're on media-video and ppc :P)?
Comment 2 Luca Barbato gentoo-dev 2004-11-28 07:07:32 UTC
first of all -fsigned-char should be avoided.
second you can't use the altivec useflag if you are on a g3.

Looks like that is a configure issue in mplayer

please issue
USE="-altivec" emerge mplayer
and tell me if works
Comment 3 Dean Pierce 2004-11-28 12:49:07 UTC
ok, the compile did work when altivec was removed from the use list, and since I am on a g3, that would make sense :-)
Comment 4 Luca Barbato gentoo-dev 2004-11-28 13:00:40 UTC
Marked resolved as worksforme
Comment 5 Luca Barbato gentoo-dev 2004-11-28 23:09:01 UTC
Closing