Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 726724 - dev-lisp/sbcl-1.4.9 on amd64 fails to build with multiple definition of `os_vm_page_size'; linux-os.o:(.bss+0x8): first defined here
Summary: dev-lisp/sbcl-1.4.9 on amd64 fails to build with multiple definition of `os_v...
Status: RESOLVED DUPLICATE of bug 706314
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Prefix
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-02 04:32 UTC by Sammy Pfeiffer
Modified: 2020-12-20 12:10 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (sbcl_1.4.9_build.log,127.60 KB, text/x-log)
2020-06-02 04:32 UTC, Sammy Pfeiffer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sammy Pfeiffer 2020-06-02 04:32:59 UTC
Created attachment 643108 [details]
build.log

When trying to build on Gentoo Prefix on amd64 dev-lisp/sbcl-1.4.9 I get:
2020-06-01T19:01:02.1002641Z x86_64-pc-linux-gnu-gcc -Wl,-O1 -Wl,--as-needed -Wl,--export-dynamic -no-pie -o sbcl alloc.o backtrace.o breakpoint.o coalesce.o coreparse.o dynbind.o funcall.o gc-common.o globals.o hopscotch.o interr.o interrupt.o largefile.o main.o monitor.o murmur_hash.o os-common.o parse.o print.o purify.o pthread-futex.o regnames.o run-program.o runtime.o safepoint.o save.o sc-offset.o search.o thread.o time.o validate.o var-io.o vars.o wrap.o x86-64-arch.o linux-os.o linux-mman.o x86-64-linux-os.o fullcgc.o gencgc.o traceroot.o immobile-space.o elf.o x86-64-assem.o ldso-stubs.o -ldl -lpthread -lz -lm
2020-06-01T19:01:02.1162285Z /tmp/gentoo/usr/lib/gcc/x86_64-pc-linux-gnu/10.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: x86-64-linux-os.o:(.bss+0x0): multiple definition of `os_vm_page_size'; linux-os.o:(.bss+0x8): first defined here
2020-06-01T19:01:02.1869666Z collect2: error: ld returned 1 exit status

(Note: my EPREFIX is /tmp/gentoo).


I'm unable to build a newer version because of: https://bugs.gentoo.org/726722

Note that it does build successfully on x86 for me.

Additionally, I can provide a Docker image where this issue can be reproduced:
docker pull awesomebytes/roogp_ros_kinetic_ros_base:2055
docker run -it awesomebytes/roogp_ros_kinetic_ros_base:2055 /bin/bash

But note that it is a pretty huge image, as this is part of a bigger CI pipeline, it's about 8GB.
Comment 1 Sam James archtester gentoo-dev Security 2020-12-20 12:10:23 UTC
Seems to be fixed now?

*** This bug has been marked as a duplicate of bug 706314 ***