Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 726696 - net-misc/dhcp - dhclient fails to bring up interface due to some issue in /var/lib/dhcp/dhclient.leases
Summary: net-misc/dhcp - dhclient fails to bring up interface due to some issue in /va...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
Depends on:
Reported: 2020-06-01 18:59 UTC by Davyd McColl
Modified: 2020-06-01 19:07 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

dhclient.leases (dhclient.leases,5.78 KB, text/plain)
2020-06-01 19:00 UTC, Davyd McColl

Note You need to log in before you can comment on or make changes to this bug.
Description Davyd McColl 2020-06-01 18:59:29 UTC
After going for a reboot, I noticed that my network wasn't up. I tried to `rc-service net.enp5s0 restart`, but got messages like:

 * Bringing up interface enp5s0                                                                                                  
 *   config_enp5s0 not specified; defaulting to DHCP                                                                             
 *   dhcp ...                                                                                                                    
 *     Running dhclient ...                                                                                                      
 *     start-stop-daemon: failed to start `/sbin/dhclient'                                                                       
 [ !! ]                                                                                                                          
 [ !! ]                                                                                                                          
net.enp5s0         | * ERROR: net.enp5s0 failed to start

I tried manually with `dhclient enp5s0` and got no error (but also no network) until I tried with `-v`, upon which I saw the message:

Can't allocate interface elease

After manually configuring my network with `ifconfig` (thank goodness I remember how!), I found gentoo forum posts which suggested that the issue may be to do with /var/lib/dhcp/dhclient.leases. Looking in that file, I don't see an obvious error, but perhaps it would be more obvious to someone who knows more. I tried moving that file off to /var/lib/dhcp/dhclient.leases.bak and restarting network, upon which everything worked. I rebooted just to make sure, and everything still worked. So it seems there's some issue in that file (which I hadn't touched before today) that prevented dhclient from working. I will attach that file after this issue is created.

Reproducible: Always

Steps to Reproduce:
1. have my wonky dhclient.leases file
2. attempt to bring up a network interface called enp5s0
3. experience no network
Actual Results:  
No network after a reboot until I removed /var/lib/dhcp/dhclient.leases

Expected Results:  
/var/lib/dhcp/dhclient.leases is a file managed by processes other than me. I expect those processes to act smarter than I would ^_^. Network should have continued to work after a reboot.
Comment 1 Davyd McColl 2020-06-01 19:00:11 UTC
Created attachment 643090 [details]