Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 726670 - app-misc/sl does not respect CFLAGS/LDFLAGS
Summary: app-misc/sl does not respect CFLAGS/LDFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Patrice Clement
URL:
Whiteboard:
Keywords:
: 729404 (view as bug list)
Depends on:
Blocks: qa-cflags ldflags
  Show dependency tree
 
Reported: 2020-06-01 15:52 UTC by Agostino Sarubbo
Modified: 2020-10-30 20:51 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,6.60 KB, text/plain)
2020-06-01 15:52 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-06-01 15:52:07 UTC
This is an auto-filed bug because app-misc/sl does not respect CFLAGS/LDFLAGS.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to add "-frecord-gcc-switches" to CFLAGS/CXXFLAGS/FFLAGS/FCFLAGS and LDFLAGS="${LDFLAGS} -Wl,--defsym=__gentoo_check_ldflags__=0". If this is not something about c/c++ see this bug as an hint to hide the QA warning (with QA_FLAGS_IGNORED) where is not possible to respect CFLAGS/LDFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2020-06-01 15:52:12 UTC
Created attachment 643058 [details]
build.log

build log and emerge --info
Comment 2 Patrice Clement gentoo-dev 2020-06-04 06:58:27 UTC
5f444e02e0e87bc2c27a67d986a1da06a428eba2
Comment 3 Agostino Sarubbo gentoo-dev 2020-06-04 10:55:36 UTC
I still can reproduce the ldflags issue
Comment 4 Larry the Git Cow gentoo-dev 2020-06-04 15:36:45 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=cd74ec7b947eb456f238e45ca13c9918bf31515a

commit cd74ec7b947eb456f238e45ca13c9918bf31515a
Author:     Patrice Clement <monsieurp@gentoo.org>
AuthorDate: 2020-06-04 12:31:17 +0000
Commit:     Patrice Clement <monsieurp@gentoo.org>
CommitDate: 2020-06-04 15:36:37 +0000

    app-misc/sl: honor LDFLAGS.
    
    Closes: https://bugs.gentoo.org/726670
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Patrice Clement <monsieurp@gentoo.org>

 app-misc/sl/sl-5.02.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 5 Patrice Clement gentoo-dev 2020-10-30 20:51:30 UTC
*** Bug 729404 has been marked as a duplicate of this bug. ***