Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 72661 - LiveCD: amd64 2004.3-r1 Universal LiveCD hangs on boot
Summary: LiveCD: amd64 2004.3-r1 Universal LiveCD hangs on boot
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: Everything (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Release Team
Depends on:
Reported: 2004-11-27 11:23 UTC by Sami Nieminen
Modified: 2005-05-04 04:27 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

working kernel config using 2.6.9-r14 (2.6.9-gentoo-r14.config,27.85 KB, text/plain)
2005-01-19 06:30 UTC, Eric Johanson

Note You need to log in before you can comment on or make changes to this bug.
Description Sami Nieminen 2004-11-27 11:23:53 UTC
When selecting boot option 'doscsi' (installing from SCSI drive), the LiveCD boot hangs during "Loading modules..." phase while scanning for sata_sis module. If I don't specify doscsi it won't hang, but prompts me for the root since the cd is on SCSI drive.

My hadware:
MSI K8N Neo2 motherboard with nforce3 Ultra
AMD Athlon64 3000+

Reproducible: Always
Steps to Reproduce:
1. Use LiveCD to boot "gentoo doscsi"
Actual Results:  
Boot process hangs on scanning of sata_sis module. 

Expected Results:  
Boot goes past the scanning phase.
Comment 1 Eric Johanson 2005-01-18 18:29:38 UTC
It would seem that many of the sata_* drivers require APIC_IO, which the current live cds don't have.  

I have the exact same hang problem with sata_via.  Details of the problem are reported here:

Feature request:  Could we enable APIC_IO on the next live_cd? 

Comment 2 Chris Gianelloni (RETIRED) gentoo-dev 2005-01-19 05:59:33 UTC
I was under the impression that APIC is forced on with an SMP kernel.  The kernel on the 2004.3 LiveCD was SMP.  There is no available option for APIC for SMP kernels, as APIC is a hard dependency for SMP.
Comment 3 Eric Johanson 2005-01-19 06:28:40 UTC
Here's what I know:

the 'emachines-nofb' kernel from 'install-amd64-2004.2-minimal.iso' (which uses the other [non-sata] via driver) works like a charm. 

The only kernel on install-amd64-minimal-2004.3-r1.iso locks up during modprobe sata_via. 

Once I got gentoo installed, emerging linux-2.6.9-gentoo-r14/ building/installing worked like a charm.  I'll attach my config shortly. 

It may not be APIC.  But it's the only info I could find online related to this lockup, and it seems like it's rather similar to our problem. 

How else can I help?   This box will (hopefully) get into production this weekend, but until then, I can try whatever kernels/configs/livecds/etc to assist with debugging this. 
Comment 4 Eric Johanson 2005-01-19 06:30:56 UTC
Created attachment 48948 [details]
working kernel config using 2.6.9-r14

per my post on 2005-01-19 06:28 PST
Comment 5 Chris Gianelloni (RETIRED) gentoo-dev 2005-05-03 09:19:05 UTC
Have you tried a 2005.0 CD to see if this issue has been resolved?
Comment 6 Sami Nieminen 2005-05-03 14:07:44 UTC
Sorry, I haven't tried any new CD images, since I installed Debian and am happy with it now.
Comment 7 Chris Gianelloni (RETIRED) gentoo-dev 2005-05-04 04:27:38 UTC
OK... sorry to hear that you've decided against Gentoo... maybe you'll give us another chance some time in the future... thanks for the quick response