Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 726386 - app-backup/synology-cloud-station-backup does not respect CFLAGS/LDFLAGS
Summary: app-backup/synology-cloud-station-backup does not respect CFLAGS/LDFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Pacho Ramos
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: qa-cflags ldflags
  Show dependency tree
 
Reported: 2020-05-31 08:34 UTC by Agostino Sarubbo
Modified: 2020-05-31 12:42 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,9.20 KB, text/plain)
2020-05-31 08:34 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-31 08:34:33 UTC
This is an auto-filed bug because app-backup/synology-cloud-station-backup does not respect CFLAGS/LDFLAGS.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to set CFLAGS="${CFLAGS} -frecord-gcc-switches" and LDFLAGS="${LDFLAGS} -Wl,--defsym=__gentoo_check_ldflags__=0". If this is not something about c/c++ context you may want to set also FFLAGS and FCFLAGS or just see this bug as an hint to hide the QA warning where is not possible to respect CFLAGS/LDFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-31 08:34:38 UTC
Created attachment 642828 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-05-31 12:42:38 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=e2660ff772c1e0ecc742f3d591ad1657718ab4ea

commit e2660ff772c1e0ecc742f3d591ad1657718ab4ea
Author:     Pacho Ramos <pacho@gentoo.org>
AuthorDate: 2020-05-31 11:23:33 +0000
Commit:     Pacho Ramos <pacho@gentoo.org>
CommitDate: 2020-05-31 12:42:19 +0000

    app-backup/synology-cloud-station-backup: Bump to 4469
    
    Also this package installs prebuilt stuff
    
    Closes: https://bugs.gentoo.org/726386
    Package-Manager: Portage-2.3.100, Repoman-2.3.22
    Signed-off-by: Pacho Ramos <pacho@gentoo.org>

 app-backup/synology-cloud-station-backup/Manifest  |  2 +
 .../synology-cloud-station-backup-4469.ebuild      | 46 ++++++++++++++++++++++
 2 files changed, 48 insertions(+)