Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 726250 - x11-plugins/wmpop3 fails to compile with -fno-common or gcc-10
Summary: x11-plugins/wmpop3 fails to compile with -fno-common or gcc-10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Bernard Cafarelli
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-30 11:20 UTC by Agostino Sarubbo
Modified: 2020-06-13 09:04 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,8.75 KB, text/plain)
2020-05-30 11:21 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-30 11:20:55 UTC
This is an auto-filed bug because x11-plugins/wmpop3 fails to compile with -fno-common or gcc-10.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to set CFLAGS="${CFLAGS} -fno-common" or compile it with gcc-10 that enables -fno-common by default.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-30 11:21:00 UTC
Created attachment 642718 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-06-13 09:04:40 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a063bda4b1a5fb21f06f35a4548ff17e3725b253

commit a063bda4b1a5fb21f06f35a4548ff17e3725b253
Author:     Bernard Cafarelli <voyageur@gentoo.org>
AuthorDate: 2020-06-13 09:01:11 +0000
Commit:     Bernard Cafarelli <voyageur@gentoo.org>
CommitDate: 2020-06-13 09:04:24 +0000

    x11-plugins/wmpop3: fix build with -fno-common
    
    Closes: https://bugs.gentoo.org/726250
    Package-Manager: Portage-2.3.100, Repoman-2.3.22
    Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>

 .../wmpop3/files/wmpop3-0.5.6a-fno-common.patch    | 23 ++++++++++++++++++++++
 x11-plugins/wmpop3/wmpop3-0.5.6a-r1.ebuild         |  4 +++-
 2 files changed, 26 insertions(+), 1 deletion(-)