Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 726154 - app-emulation/virtualbox-6.1.6[qt5] w/ Qt 5.15 error: aggregate ‘QPainterPath tp’ has incomplete type and cannot be defined
Summary: app-emulation/virtualbox-6.1.6[qt5] w/ Qt 5.15 error: aggregate ‘QPainterPath...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: qt-5.15
  Show dependency tree
 
Reported: 2020-05-29 22:20 UTC by cmvu
Modified: 2020-06-03 00:25 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info '=app-emulation/virtualbox-6.1.6::gentoo' (emerge.info,4.88 KB, application/x-info)
2020-05-29 22:23 UTC, cmvu
Details
Gzipped build log (build.log.gz,283.38 KB, application/gzip)
2020-05-29 22:24 UTC, cmvu
Details
qt headers fix (qt-headers.patch,3.50 KB, patch)
2020-05-29 22:28 UTC, cmvu
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description cmvu 2020-05-29 22:20:47 UTC
Build fails with when building with GUI with Qt 5.15.0. But not sure if this is caused by gcc-10.



Reproducible: Always

Steps to Reproduce:
1.emerge -v virtualbox
2.
3.
Comment 1 cmvu 2020-05-29 22:23:35 UTC
Created attachment 642612 [details]
emerge --info '=app-emulation/virtualbox-6.1.6::gentoo'
Comment 2 cmvu 2020-05-29 22:24:10 UTC
Created attachment 642614 [details]
Gzipped build log
Comment 3 cmvu 2020-05-29 22:26:08 UTC
BTW i used patch https://722676.bugs.gentoo.org/attachment.cgi?id=638426 to fix problem with gcc-10 version check
Comment 4 cmvu 2020-05-29 22:28:41 UTC
Created attachment 642616 [details, diff]
qt headers fix

Quick and dirty solution for this bug. This patch just explicitly adds #includes in several places
Comment 5 Andreas Sturmlechner gentoo-dev 2020-05-30 07:49:47 UTC
Nicely done. This is entirely caused by Qt 5.15.
Comment 6 peter@prh.myzen.co.uk 2020-05-30 21:31:21 UTC
(In reply to cmvu from comment #0)
> Build fails with when building with GUI with Qt 5.15.0. But not sure if this
> is caused by gcc-10.

It isn't. I get it too with 9.3.0.
Comment 7 peter@prh.myzen.co.uk 2020-05-30 21:36:53 UTC
(In reply to peter@prh.myzen.co.uk from comment #6)
> (In reply to cmvu from comment #0)
> > Build fails with when building with GUI with Qt 5.15.0. But not sure if this
> > is caused by gcc-10.
> 
> It isn't. I get it too with 9.3.0.

Regards,
Peter.

Gentoo testing system, openrc-0.42.1
gcc 9.3.0, sys-kernel/gentoo-sources 5.4.38
QT 5.15.0, KDE frameworks 5.70.0, KDE plasma 5.18.5
KDE apps 20.04.1 incl KMail 5.14.1 (20.04.0), akonadi 20.04.1
dev-db/mariadb-10.4.12, net-libs/webkit-gtk-2.28.2
x11-drivers/xf86-video-amdgpu 19.1.0
dev-libs/amdgpu-pro-opencl-19.30.838629
Comment 8 Larry the Git Cow gentoo-dev 2020-06-02 21:52:02 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=8507cc179dc91f1aa8803ee67e48018c7c6733b1

commit 8507cc179dc91f1aa8803ee67e48018c7c6733b1
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2020-06-02 21:26:38 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2020-06-02 21:51:50 +0000

    app-emulation/virtualbox: Fix build with Qt 5.15
    
    Thanks-to: cmvu <cmvu@protonmail.com>
    Closes: https://bugs.gentoo.org/726154
    Package-Manager: Portage-2.3.100, Repoman-2.3.22
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 .../files/virtualbox-6.1.6-qt-5.15.patch           | 92 ++++++++++++++++++++++
 app-emulation/virtualbox/virtualbox-6.1.6.ebuild   |  2 +
 2 files changed, 94 insertions(+)
Comment 9 Larry the Git Cow gentoo-dev 2020-06-03 00:10:50 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c15842f13dc218913f6d95555c65c90f844f5ec2

commit c15842f13dc218913f6d95555c65c90f844f5ec2
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2020-06-03 00:09:26 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2020-06-03 00:10:33 +0000

    app-emulation/virtualbox: Fix 6.0.20 build with Qt 5.15 too
    
    Closes: https://bugs.gentoo.org/726154
    Package-Manager: Portage-2.3.100, Repoman-2.3.22
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 .../files/virtualbox-6.0.20-qt-5.15.patch          | 82 ++++++++++++++++++++++
 .../files/virtualbox-6.1.6-qt-5.15.patch           | 82 ----------------------
 app-emulation/virtualbox/virtualbox-6.0.20.ebuild  |  2 +
 app-emulation/virtualbox/virtualbox-6.1.6.ebuild   |  3 +-
 4 files changed, 86 insertions(+), 83 deletions(-)