Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 72613 - upgrade to gdm 2.6 doesn't display warning
Summary: upgrade to gdm 2.6 doesn't display warning
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-11-27 03:44 UTC by Ask Holme
Modified: 2004-11-28 13:59 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ask Holme 2004-11-27 03:44:07 UTC
i'm running a LTSP based setup with KDE as environemnt and GDM as login manager. 
I recently broke the system by upgrading the gdm 2.6, initially the upgrade seemed the went fine, however i had to discover myself that gdm had changed the format of sessions files from 2.4 to 2.6. This caused all my curent session files, including  the kde ones, to fail and therefor noone could login. 
Portage should warn uppon upgrade of a package where the new version is incompatiable with the earlier one. 

Reproducible: Always
Steps to Reproduce:
1. install gdm 2.4 and setup with session files
2. upgrade to gdm 2.6 

Actual Results:  
. no session files converted

Expected Results:  
either warned me that the format had changed, or converted the session files for
me.
Comment 1 foser (RETIRED) gentoo-dev 2004-11-28 07:24:58 UTC
This request is a bit late, this scheme has been available stable for months now and so far we had no complaints. Yes, kde isn't supported out of the box, but that is the kde devs slacking, because they were on the conversion bugs since day 1. Custom sessions we shouldn't mess with to being with.

I agree it could've used a warning when it got just introduced, but right now I don't think it has much merit anymore.

btw, this scheme got introduced in the 2.4.4 series, although in a different location.
Comment 2 Ask Holme 2004-11-28 08:56:59 UTC
i do not agree at all.

i do understand that gentoo has a release cycle for ebuilds, however a release cycle can never be an argument not to fix bugs, just because they are discovered  after the cycle has ended. 

And to make it clear, no matter who is slacking it will always be a portage error if a package upgrade breaks the system without issuing any kind of warning. 

ps.
i do not complain about the scheme, i like the new scheme and everything - i would  just like a warning
Comment 3 foser (RETIRED) gentoo-dev 2004-11-28 13:39:06 UTC
It has not much todo with release cycles of ebuilds, it is just a fact that this has been in the tree for quite a while now and nobody really complained. We even took our time to have all WM's etc, update their session files so it the transition would as smooth as possible, to my knowledge most WM's did so (with the notable exception of KDE).

This is an issue of effort vs. pay-off . I don't think for those relative few ppl that now still have to upgrade & have custom sessions it is not worth the time to spend on it, you must realize that we're dealing with a volunteer effort here & I don't intend to spend time on things i do not think are worth it. That was why i closed it WONTFIX, not because I didn't think it was an issue at all. Well, all the time gain is lost already because i have to write this reply.
Comment 4 foser (RETIRED) gentoo-dev 2004-11-28 13:59:02 UTC
to get back to this, i've been a bit unreasonable here. I do get touchy over ppl reopening bugs on basically non-issues, but I'll add a warning note when updating gdm next time. So consider this 'fixed' anyway.