Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 726032 - sys-fs/jfsutils calls ar directly
Summary: sys-fs/jfsutils calls ar directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-29 06:58 UTC by Agostino Sarubbo
Modified: 2020-08-20 17:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,15.81 KB, text/plain)
2020-05-29 06:58 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-29 06:58:31 UTC
This is an auto-filed bug because sys-fs/jfsutils calls ar directly.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different AR implementation (like llvm-ar) by setting the AR variable. So this issue has been reproduced by setting the AR variable to x86_64-pc-linux-gnu-ar and by removing the /usr/bin/ar binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-29 06:58:36 UTC
Created attachment 642460 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-08-20 17:50:32 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=421df5f64771c31ae2e664029023ef41a133a875

commit 421df5f64771c31ae2e664029023ef41a133a875
Author:     Thomas Deutschmann <whissi@gentoo.org>
AuthorDate: 2020-08-20 17:33:52 +0000
Commit:     Thomas Deutschmann <whissi@gentoo.org>
CommitDate: 2020-08-20 17:50:17 +0000

    sys-fs/jfsutils: don't call AR directly
    
    Closes: https://bugs.gentoo.org/726032
    Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>

 sys-fs/jfsutils/files/jfsutils-1.1.15-check-for-ar.patch | 10 ++++++++++
 sys-fs/jfsutils/jfsutils-1.1.15-r1.ebuild                |  9 ++++++++-
 2 files changed, 18 insertions(+), 1 deletion(-)