Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 726002 - sys-fs/mhddfs does not respect CFLAGS/LDFLAGS
Summary: sys-fs/mhddfs does not respect CFLAGS/LDFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sergey Popov
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: qa-cflags ldflags
  Show dependency tree
 
Reported: 2020-05-29 06:54 UTC by Agostino Sarubbo
Modified: 2020-11-15 17:14 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,9.31 KB, text/plain)
2020-05-29 06:54 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-29 06:54:02 UTC
This is an auto-filed bug because sys-fs/mhddfs does not respect CFLAGS/LDFLAGS.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to set CFLAGS="${CFLAGS} -frecord-gcc-switches" and LDFLAGS="${LDFLAGS} -Wl,--defsym=__gentoo_check_ldflags__=0". If this is not something about c/c++ context you may want to set also FFLAGS and FCFLAGS or just see this bug as an hint to hide the QA warning where is not possible to respect CFLAGS/LDFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-29 06:54:08 UTC
Created attachment 642430 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-11-15 17:14:21 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ac73470ace408e119778067463c8bb2f0ec99711

commit ac73470ace408e119778067463c8bb2f0ec99711
Author:     Sergey Popov <pinkbyte@gentoo.org>
AuthorDate: 2020-11-15 17:12:46 +0000
Commit:     Sergey Popov <pinkbyte@gentoo.org>
CommitDate: 2020-11-15 17:14:19 +0000

    sys-fs/mhddfs: reorganize patches to respect CFLAGS and LDFLAGS
    
    Reported-by: Agostino Sarubbo <ago@gentoo.org>
    Closes: https://bugs.gentoo.org/726002
    Package-Manager: Portage-3.0.8, Repoman-3.0.2
    Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>

 sys-fs/mhddfs/files/mhddfs-0.1.39-segfault-fix.patch   | 17 -----------------
 sys-fs/mhddfs/files/mhddfs-respect-compiler-vars.patch |  7 ++++---
 2 files changed, 4 insertions(+), 20 deletions(-)