Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 725630 - gnustep-apps/sogo:fails to build with -fno-common or gcc-10
Summary: gnustep-apps/sogo:fails to build with -fno-common or gcc-10
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gnustep herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-27 13:00 UTC by Nabucho
Modified: 2020-06-26 11:03 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nabucho 2020-05-27 13:00:26 UTC
I'm trying to compil SOGO on my linux box.

SOPE compiled well... but SOGO failed always at the same place :


Making all for wobundle Mailer...
x86_64-pc-linux-gnu-gcc -shared \
-rdynamic -Wl,-O1 -Wl,--as-needed -pthread -o Mailer.SOGo/./Mailer \
./obj/Mailer.obj/Product.m.o ./obj/Mailer.obj/SOGoMailManager.m.o ./obj/Mailer.obj/SOGoDraftObject.m.o ./obj/Mailer.obj/SOGoMailBaseObject.m.o ./obj/Mailer.obj/SOGoMailAccounts.m.o ./obj/Mailer.obj/SOGoMailAccount.m.o ./obj/Mailer.obj/SOGoMailFolder.m.o ./obj/Mailer.obj/SOGoMailLabel.m.o ./obj/Mailer.obj/SOGoMailNamespace.m.o ./obj/Mailer.obj/SOGoMailObject.m.o ./obj/Mailer.obj/SOGoMailObject+Draft.m.o ./obj/Mailer.obj/SOGoSentFolder.m.o ./obj/Mailer.obj/SOGoDraftsFolder.m.o ./obj/Mailer.obj/SOGoTrashFolder.m.o ./obj/Mailer.obj/SOGoJunkFolder.m.o ./obj/Mailer.obj/SOGoMailBodyPart.m.o ./obj/Mailer.obj/SOGoHTMLMailBodyPart.m.o ./obj/Mailer.obj/SOGoImageMailBodyPart.m.o ./obj/Mailer.obj/SOGoMessageMailBodyPart.m.o ./obj/Mailer.obj/SOGoCalendarMailBodyPart.m.o ./obj/Mailer.obj/SOGoVCardMailBodyPart.m.o ./obj/Mailer.obj/SOGoMailForward.m.o ./obj/Mailer.obj/SOGoMailReply.m.o ./obj/Mailer.obj/EOQualifier+MailDAV.m.o ./obj/Mailer.obj/NSData+Mail.m.o ./obj/Mailer.obj/NSData+SMIME.m.o ./obj/Mailer.obj/NSDictionary+Mail.m.o ./obj/Mailer.obj/NSString+Mail.m.o ./obj/Mailer.obj/SOGoUser+Mailer.m.o \
-L../SOGo/SOGo.framework/Versions/Current/sogo/ -lSOGo -L../../SOGo/./obj/ -L../../SOPE/NGCards/./obj/ -lNGCards -L../../SOPE/GDLContentStore/./obj/ -lGDLContentStore -L/usr/local/lib -Wl,-rpath,/usr/lib64/sogo -L/root/GNUstep/Library/Libraries -L/usr/local/lib64 -L/usr/lib64 -lNGObjWeb -lNGMime -lNGStreams -lNGExtensions -lGDLAccess -lNGObjWeb -lNGMime -lNGLdap -lNGStreams -lNGExtensions -lEOControl -lDOM -lSaxObjC -lSBJson -lcrypto -lgnustep-base -l:libobjc.so.4 -lm
/usr/lib/gcc/x86_64-pc-linux-gnu/10.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: ./obj/Mailer.obj/SOGoMailFolder.m.o:/root/sogo/SoObjects/Mailer/SOGoMailObject.h:54: multiple definition of `SOGoMailCoreInfoKeys'; ./obj/Mailer.obj/SOGoDraftObject.m.o:/root/sogo/SoObjects/Mailer/SOGoMailObject.h:54: first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/10.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: ./obj/Mailer.obj/SOGoMailObject.m.o:/root/sogo/SoObjects/Mailer/SOGoMailObject.h:54: multiple definition of `SOGoMailCoreInfoKeys'; ./obj/Mailer.obj/SOGoDraftObject.m.o:/root/sogo/SoObjects/Mailer/SOGoMailObject.h:54: first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/10.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: ./obj/Mailer.obj/SOGoMailObject+Draft.m.o:/root/sogo/SoObjects/Mailer/SOGoMailObject.h:54: multiple definition of `SOGoMailCoreInfoKeys'; ./obj/Mailer.obj/SOGoDraftObject.m.o:/root/sogo/SoObjects/Mailer/SOGoMailObject.h:54: first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/10.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: ./obj/Mailer.obj/SOGoMailBodyPart.m.o:/root/sogo/SoObjects/Mailer/SOGoMailObject.h:54: multiple definition of `SOGoMailCoreInfoKeys'; ./obj/Mailer.obj/SOGoDraftObject.m.o:/root/sogo/SoObjects/Mailer/SOGoMailObject.h:54: first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/10.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: ./obj/Mailer.obj/SOGoMailForward.m.o:/root/sogo/SoObjects/Mailer/SOGoMailObject.h:54: multiple definition of `SOGoMailCoreInfoKeys'; ./obj/Mailer.obj/SOGoDraftObject.m.o:/root/sogo/SoObjects/Mailer/SOGoMailObject.h:54: first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/10.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: ./obj/Mailer.obj/SOGoMailReply.m.o:/root/sogo/SoObjects/Mailer/SOGoMailObject.h:54: multiple definition of `SOGoMailCoreInfoKeys'; ./obj/Mailer.obj/SOGoDraftObject.m.o:/root/sogo/SoObjects/Mailer/SOGoMailObject.h:54: first defined here
collect2: error: ld returned 1 exit status
gmake[3]: *** [/usr/share/GNUstep/Makefiles/wobundle.make:173: Mailer.SOGo/./Mailer] Error 1
gmake[2]: *** [/usr/share/GNUstep/Makefiles/Master/rules.make:297: Mailer.all.wobundle.variables] Error 2
gmake[1]: *** [/usr/share/GNUstep/Makefiles/Master/serial-subdirectories.make:53: internal-all] Error 2
make: *** [/usr/share/GNUstep/Makefiles/Master/serial-subdirectories.make:53: internal-all] Error 2


Tried with the gento 4.1.1-1, made a specific ebuild for the 4.3.2, use the GIT repository... but no way always the same error !


The environment :

Portage 2.3.99 (python 3.8.3-final-0, default/linux/amd64/17.1/no-multilib, gcc-10.1.0, glibc-2.31-r3, 5.6.13-gentoo x86_64)
=================================================================
System uname: Linux-5.6.13-gentoo-x86_64-Intel-R-_Core-TM-_i7-6700HQ_CPU_@_2.60GHz-with-glibc2.2.5
KiB Mem:    16333712 total,  10674956 free
KiB Swap:    8388604 total,   7311868 free
Timestamp of repository gentoo: Fri, 22 May 2020 00:45:01 +0000
Head commit of repository gentoo: 15b5a88eb7fece8b5912b37d54dc0f3f6c4f6e0b
sh bash 5.0_p17
ld GNU ld (Gentoo 2.34 p4) 2.34.0
app-shells/bash:          5.0_p17::gentoo
dev-lang/perl:            5.30.2-r2::gentoo
dev-lang/python:          3.8.3::gentoo
dev-util/cmake:           3.17.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.7::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.69-r5::gentoo
sys-devel/automake:       1.13.4-r2::gentoo, 1.16.2::gentoo
sys-devel/binutils:       2.34-r1::gentoo
sys-devel/gcc:            10.1.0::gentoo
sys-devel/gcc-config:     2.2.1::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.6::gentoo (virtual/os-headers)
sys-libs/glibc:           2.31-r3::gentoo
Repositories:

gentoo
    location: /var/antos/portage
    sync-type: rsync
    

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=haswell -mmmx -msse -msse2 -msse3 -mssse3 -mcx16 -msahf -mmovbe -maes -mpclmul -mpopcnt -mabm -mfma -mbmi -mbmi2 -mavx -mavx2 -msse4.2 -msse4.1 -mlzcnt -mrdrnd -mf16c -mfsgsbase -mfxsr -mxsave -mxsaveopt"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=haswell -mmmx -msse -msse2 -msse3 -mssse3 -mcx16 -msahf -mmovbe -maes -mpclmul -mpopcnt -mabm -mfma -mbmi -mbmi2 -mavx -mavx2 -msse4.2 -msse4.1 -mlzcnt -mrdrnd -mf16c -mfsgsbase -mfxsr -mxsave -mxsaveopt"
DISTDIR="/var/antos/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.modulix.net/gentoo/ http://gentoo.mirrors.ovh.net/gentoo-distfiles/ http://ftp.free.fr/mirrors/ftp.gentoo.org/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="fr en"
MAKEOPTS="-j9"
PKGDIR="/var/antos/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="-e "ssh -l antos -i /lib/antos/common/.id_rsa""
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/tmp"
USE="X acl aes amd64 audit avx avx2 bashlogger berkdb bzip2 caps cli crypt dri f16c fma3 gdbm gmp iconv ithreads libtirpc logrotate minizip mktemp mmx mmxext modern-top mpfr native-cflags ncurses nftables nls nptl numa openmp pam pclmul pcre pcre16 pcre32 perl popcnt readline seccomp smp split-usr sse sse2 sse3 sse4_1 sse4_2 ssl ssse3 tcpd threads tracepath udev unicode xattr zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64 pc" INPUT_DEVICES="keyboard libinput mouse evdev synaptics" KERNEL="linux" L10N="fr en" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_8" PYTHON_TARGETS="python3_8" RUBY_TARGETS="ruby24 ruby25" USERLAND="GNU" VIDEO_CARDS="vesa fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 1 Nabucho 2020-05-27 20:33:47 UTC
The same bug has been discovered on debian too :

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=957826
Comment 2 Nabucho 2020-05-28 05:44:25 UTC
The problem seems to be related to https://wiki.gentoo.org/wiki/Gcc_10_porting_notes/fno_common

Manually make a patch to add the -fcommon and the compil step working fine now.

Will make a new ebuild for it waiting for the source modification
Comment 3 Bernard Cafarelli gentoo-dev 2020-05-28 16:08:01 UTC
Thanks for the report, indeed as seen from log errors (and debian bug) this is a build error with -fno-common

And yes I do not see relevant changes in master upstream (or in PR https://github.com/inverse-inc/sogo/pulls), I will hold off on bumping sogo in tree until it compiles with gcc-10.

On a side note, if you actually run 4.3.2 (with gcc-9 or with -fno-common) with a simple ebuild rename it will be nice to know: I can only check compilation works fine so any user feedback is welcome
Comment 4 Kalchenko Alexandr 2020-06-26 11:03:00 UTC
We are running sogo 4.3.2 (gcc-9) for about 1,5 month without any issues.
Yes, just simple ebuild rename