Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 725552 - sci-libs/mkl-rt does not respect CFLAGS/LDFLAGS
Summary: sci-libs/mkl-rt does not respect CFLAGS/LDFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: lumin
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: qa-cflags ldflags
  Show dependency tree
 
Reported: 2020-05-26 21:00 UTC by Agostino Sarubbo
Modified: 2020-11-09 07:38 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,14.26 KB, text/plain)
2020-05-26 21:00 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-26 21:00:34 UTC
This is an auto-filed bug because sci-libs/mkl-rt does not respect CFLAGS/LDFLAGS.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to set CFLAGS="${CFLAGS} -frecord-gcc-switches" and LDFLAGS="${LDFLAGS} -Wl,--defsym=__gentoo_check_ldflags__=0". If this is not something about c/c++ context you may want to set also FFLAGS and FCFLAGS or just see this bug as an hint to hide the QA warning where is not possible to respect CFLAGS/LDFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-26 21:00:39 UTC
Created attachment 641970 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-11-09 07:38:25 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=94b1a98a4d9480266163c56c84990d042a5b98e7

commit 94b1a98a4d9480266163c56c84990d042a5b98e7
Author:     Aisha Tammy <gentoo@aisha.cc>
AuthorDate: 2020-11-05 13:49:33 +0000
Commit:     Benda Xu <heroxbd@gentoo.org>
CommitDate: 2020-11-09 07:38:14 +0000

    profiles/package.mask: mask sci-libs/mkl-rt, provided by mkl
    
    Bug: https://bugs.gentoo.org/747310
    Closes: https://github.com/gentoo/gentoo/pull/18137
    Closes: https://bugs.gentoo.org/725552
    Closes: https://bugs.gentoo.org/731920
    Closes: https://bugs.gentoo.org/731922
    Closes: https://bugs.gentoo.org/731924
    
    Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
    Signed-off-by: Benda Xu <heroxbd@gentoo.org>

 profiles/package.mask | 6 ++++++
 1 file changed, 6 insertions(+)